"Icons" transition causes crash

Bug #802134 reported by Oded Pegev on 2011-06-26
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Medium
Andy Finch

Bug Description

I have several projects created by automatically adding many short videos to the timeline with random transitions. When doing a playback or an export, the program crashes with a segmentation fault as soon as it reaches a transition called "Icons". (I'm not sure what this transition is, actually; it's generated randomly). Replacing the transition manually with another transition solves the problem.

Installation: AV Linux 5.0

Thanks for maintaining Openshot! it's a wonderful project.

Olivier Girard (eolinwen) wrote :

Hi,
I installed this week-end AV Linux 5.0 and i have done some tests for a member of our forum. I played with several type of files like several HD files and she is perfect, Gmag have done a great stuff. Unfortunately, I have not tested this transition.
Could you run openshot in a console and put us the result ?
If you have a segfault in this ouput, could you do that : http://openshotusers.com/forum/viewtopic.php?f=12&t=180
Like this we could certainly see where is the problem.
Thanks.

Andy Finch (fincha) wrote :

There is no transition called Icons, it appears as if it is adding the Icons subfolder (that holds the images for each transition) as a transition.

Changed in openshot:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 1.4.0
Andy Finch (fincha) on 2011-07-13
Changed in openshot:
status: Confirmed → In Progress
assignee: nobody → Andy Finch (fincha)
Andy Finch (fincha) on 2011-08-08
Changed in openshot:
status: In Progress → Fix Committed
Andy Finch (fincha) on 2011-09-23
Changed in openshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers