scrolling a clip not in the timeline

Reported by Geppo on 2011-02-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Medium
Unassigned

Bug Description

Hi,
  i'm using the 1.3 version.
sometimes, scolling a clip (not placed in the timeline),with the preview scrollbar, it lost the clip and start scroling the timeline, o i have to re-select the clip on the clips list and scroll it again.
I'm not able to reproduce it.

Jonathan Thomas (jonoomph) wrote :

Hmmm, I have not seen this behavior before. Without being able to reproduce this issue, it will be near impossible to fix. Please keep trying to find a way to reproduce it, and update this ticket if you make a break through. =) Thanks and good luck!

Changed in openshot:
status: New → Incomplete
Geppo (gepponline) wrote :

Here I Am!
 Now i can reproduce the problem.
Here is a video of what happen.
Any Ideas?

Jonathan Thomas (jonoomph) wrote :

Ahhh, yes I see what happened. Does it always behave this way for you? Or does it only switch to the timeline preview when the timeline has been modified... and not yet previewed?

For example, after it switches back to the timeline preview, if you double click the file again, can you then drag the bar and seek around the correct video? Or does it still switch back to the timeline preview? Thanks!

Changed in openshot:
milestone: none → 1.3.1
status: Incomplete → Confirmed
importance: Undecided → Medium
Geppo (gepponline) wrote :

You got it!
 It happen ONLY when the timeline has been modified!

Doing this test, i've noticed that resizing the clip on the timeline, the preview window change frame but i expected that still freeze on the same frame 'cause i didn't move the cursor
Maybe it's due to the approximation of the percentage in the drag bar.

Jonathan Thomas (jonoomph) wrote :

Fixed and committed to the trunk. This will be released with 1.3.1, hopefully very soon.

Changed in openshot:
status: Confirmed → Fix Committed
moimael (moimael) on 2011-05-03
Changed in openshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers