Missing icon and identification in Ubuntu sound preferences

Reported by Conscious User on 2010-06-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Low
Unassigned

Bug Description

When you play a video in OpenShot and open the Ubuntu sound preferences, in the "Applications" tab there is a OpenShot specific volume slider. However, this slider has the "icon not found" icon and is identified only as "python".

Related branches

Olivier Girard (eolinwen) wrote :

I confirm this bug and the program is called python. it is working only when you play a file with and not when Openshot is opening. See the screenshots for more details below.

Olivier Girard (eolinwen) wrote :
Changed in openshot:
status: New → Confirmed
importance: Undecided → Low
Changed in openshot:
assignee: nobody → Daniel Ellis (danellisuk)
Daniel Ellis (danellisuk) wrote :

According to the pulse audio wiki, applications should set some properties to identify itself to pulse audio:-

http://www.pulseaudio.org/wiki/ApplicationProperties

Attached is a patch which adds the required variables. I don't know where the best location to put these three lines are, so it would be best if Jonathan could choose a suitable home for these three lines.

However! This patch does not work (yet!) because there is an issue with the pulse module of SDL. The SDL pulse module is identifying itself to PulseAudio using the process name. On my system, I have patched libsdl to not do this, and then finally OpenShot is identified correctly in the Sound Preferences dialog.

I will raise a bug with the libsdl1.2debian-pulseaudio package and add a reference to that bug here.

Andy Finch (fincha) wrote :

Thanks for looking into this Daniel.

Daniel Ellis (danellisuk) wrote :

Bug report for libsdl is Bug #597859

Andy Finch (fincha) on 2010-06-25
Changed in openshot:
milestone: none → 1.2.0
Jonathan Thomas (jonoomph) wrote :

Have the SDL developers commented on this yet? I think I am going to wait to implement this patch, until we know what the SDL folks say about the patch. Thanks for looking into this!

Changed in openshot:
milestone: 1.2.0 → none
Daniel Ellis (danellisuk) wrote :

No comment from upstream yet (http://bugzilla.libsdl.org/show_bug.cgi?id=1011). I'm not sure how long to wait before emailing them directly. I think I will wait another week or so, in case they are on holiday.

John Volk (poweruser32) on 2011-06-14
tags: added: patch
John Volk (poweruser32) wrote :

According to http://bugzilla.libsdl.org/show_bug.cgi?id=1011#c3 it has been fixed in SDL 1.3. I am going ahead and nominating this for release 1.4.

Changed in openshot:
milestone: none → 1.4.0
status: Confirmed → Triaged
Changed in openshot:
milestone: 1.4.0 → 1.4.1
Jonathan Thomas (jonoomph) wrote :

We will soon no longer be using SDL to playback audio. So, we'll need to revisit this issue when we start integrating our own library backend, which uses JUCE to playback audio. Thanks.

Changed in openshot:
assignee: Daniel Ellis (danellisuk) → nobody
milestone: 1.4.1 → none
status: Triaged → Confirmed
Andy Finch (fincha) wrote :

Thanks for the patch, it's now committed.

Changed in openshot:
status: Confirmed → Fix Committed
milestone: none → 1.4.3
Changed in openshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.