GIF Support

Bug #543847 reported by Brett Alton on 2010-03-22
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Wishlist
Unassigned

Bug Description

I noticed that there is no GIF export functionality and OpenShot seems unable play animated GIF files so I was wondering if there was any plans for future GIF support?

There is some sort of GIF export functionality in the fact that 'gif' is under video format but it still asks for a video codec and bitrate/quality. When I tried to export via gif, openshot crashed.

Olivier Girard (eolinwen) wrote :

At my knowledge, there is no plans to implement the GIF feature.And i don't think that Openshot has implemented this feature. Sorry.

Are you trying to create an image sequence of GIF images? Or an animated
gif? If you are trying to create an image sequence, be sure to use the
"Image Sequence" option on the "Advanced" tab. I do not think it uses the
bit-rate options when exporting an image sequence. I did some googling, and
it looks like FFmpeg supports GIF and animated GIFs, so in theory, it's
possible to use that format with OpenShot.

Can someone else give this a try, and see if you can confirm the crashing
behavior?

If that still crashes, I suppose you could export PNG images, and then run
some command line to batch convert the PNGs into GIFs.

Thanks,
-Jonathan

On Mon, Mar 22, 2010 at 1:31 PM, cenwen <email address hidden> wrote:

> At my knowledge, there is no plans to implement the GIF feature.And i
> don't think that Openshot has implemented this feature. Sorry.
>
> --
> GIF Support
> https://bugs.launchpad.net/bugs/543847
> You received this bug notification because you are a member of OpenShot
> Developers, which is subscribed to OpenShot Video Editor.
>
> Status in OpenShot Video Editor: New
>
> Bug description:
> I noticed that there is no GIF export functionality and OpenShot seems
> unable play animated GIF files so I was wondering if there was any plans for
> future GIF support?
>
> There is some sort of GIF export functionality in the fact that 'gif' is
> under video format but it still asks for a video codec and bitrate/quality.
> When I tried to export via gif, openshot crashed.
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openshot.developers<https://launchpad.net/%7Eopenshot.developers>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openshot.developers<https://launchpad.net/%7Eopenshot.developers>
> More help : https://help.launchpad.net/ListHelp
>

moimael (moimael) wrote :

gif is an outdated file format, i think you should look at APNG which is animated png with a far better quality than gif.

moimael (moimael) on 2010-05-29
Changed in openshot:
status: New → Invalid
Jonathan Thomas (jonoomph) wrote :

I'm bringing this ticket back to life. It is possible to create an animated gif, but it requires some additional parameters added to the avformat consumer to work properly:

pix_fmt=rgb24

I was thinking we might add an export template for "Animated Gif" which would automatically set this property.

Changed in openshot:
status: Invalid → Confirmed
importance: Undecided → Wishlist
Antonio Roberts (hellocatfood) wrote :

@moimael

As far as gif goes, it's still a widely used file format, especially as apng was rejected as an official file format by the png group.

Changed in openshot:
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers