Thumbnail is for first frame of original clip

Bug #534284 reported by Nicholas Seward on 2010-03-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Low
Unassigned

Bug Description

After you use the razor tool on a clip, all the produced clips still use the same thumbnail. It would be nice if the first frame of the clip was used instead of the first frame of the original.

32bit Ubuntu 9.04 (Linux Mint 7)
Installed via DEB
OpenShot 1.1

Andy Finch (fincha) on 2010-03-09
Changed in openshot:
status: New → Confirmed
Andy Finch (fincha) on 2010-04-04
Changed in openshot:
importance: Undecided → Low
moimael (moimael) on 2010-10-29
Changed in openshot:
milestone: none → 1.3.0
Changed in openshot:
milestone: 1.3.0 → 1.4.0
Berg (emil-berg91) wrote :

Fix released!

Features:
Updates thumbnails for both images and image sequences at the timeline depending on their start frame.
Is quite fast. I can't spot that much of a difference, but my computer is pretty new, though.
Uses the file thumbnail image (shown in the treeview) if the clip starts at 0.00.
Gives the thumbnail images the names file_extension_2 and up, and put them in the thumbnail folder.
Removes unused thumbnails, to not clutter the folder.
Rebuilds the thumbnails folder if lost, which possibly could be a fix for #512516. This was implemented due to the next point.
Should be backwards compatible, i.e. old projects should also load.
Otherwise, works as expected.

The patch is 1.4.0-alpha based.

Andy Finch (fincha) wrote :

Thanks for the patch, will take a look at it soon!

Berg (emil-berg91) wrote :

It should be "Updates thumbnails for both videos and image sequences at the timeline". Updating the thumbnail for an image is a bit worthless.

Andy Finch (fincha) on 2011-08-16
Changed in openshot:
status: Confirmed → Fix Committed
Andy Finch (fincha) on 2011-09-23
Changed in openshot:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments