Openshot 1.0 opens twice

Bug #505264 reported by sfantu on 2010-01-09
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
High
Jonathan Thomas

Bug Description

If i have a instance of open shot open and i right-click a folder or a group of pictures and select open with open-shot .. the action will add the files to the first instance of openshot and open another one with the files added as well .

Jonathan Thomas (jonoomph) wrote :

Very strange. Can anyone else confirm this behavior?

Daniel Ellis (danellisuk) wrote :

Confirmed on Ubuntu 9.10 UNR with OpenShot 1.0.0. Start OpenShot, browse using nautilus to Videos folder, right click on a video file and open with "OpenShot". A second instance of OpenShot is started and the video is added to both instances.

Changed in openshot:
status: New → Confirmed
Olivier Girard (eolinwen) wrote :

what have you in the terminal ?
And could you post the result of this command (just to see) :
ps -x
Thanks
(Heu just a stupid question : what is UNR ? )
What your version 32 or 64 bits ?
How have you installed Openshot , deb or ppa ?

sfantu (sfantus1) wrote :
Download full text (5.1 KiB)

sfantu@sfantu-desktop:~$ ps -x
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
  PID TTY STAT TIME COMMAND
 1928 ? Sl 0:00 /usr/bin/gnome-keyring-daemon --daemonize --login
 1943 ? Ssl 0:00 gnome-session
 2020 ? Ss 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-s
 2023 ? Ss 0:51 /bin/dbus-daemon --fork --print-pid 7 --print-address
 2024 ? S 0:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/pul
 2028 ? Ssl 3:02 /usr/bin/pulseaudio --start
 2082 ? S 0:00 /usr/lib/pulseaudio/pulse/gconf-helper
 2084 ? S 0:12 /usr/lib/libgconf2-4/gconfd-2
 2093 ? Ssl 0:07 /usr/lib/gnome-settings-daemon/gnome-settings-daemon
 2096 ? Ss 0:00 seahorse-daemon
 2098 ? S 0:00 /usr/lib/gvfs/gvfsd
 2106 ? Ssl 0:00 /usr/lib/gvfs//gvfs-fuse-daemon /home/sfantu/.gvfs
 2110 ? S 0:39 /usr/lib/notify-osd/notify-osd
 2114 ? S 0:00 /bin/sh /usr/bin/compiz
 2182 ? R 15:00 /usr/bin/compiz.real --ignore-desktop-hints --replace
 2183 ? Sl 1:26 gnome-panel
 2184 ? Sl 1:55 nautilus
 2186 ? S 0:02 python /usr/share/system-config-printer/applet.py
 2190 ? S 0:00 bluetooth-applet
 2191 ? Sl 0:00 /usr/lib/evolution/2.28/evolution-alarm-notify
 2196 ? S 0:00 /usr/lib/gvfs/gvfs-gdu-volume-monitor
 2197 ? S 0:00 /usr/lib/policykit-1-gnome/polkit-gnome-authenticatio
 2199 ? S 0:00 nm-applet --sm-disable
 2203 ? Sl 0:26 /usr/bin/python /usr/bin/ubuntuone-client-applet
 2204 ? SL 0:00 keepassx
 2205 ? S 0:15 /usr/bin/python /usr/bin/specto
 2214 ? Sl 1:55 pidgin
 2216 ? Sl 0:24 /usr/bin/python /usr/bin/conduit -i
 2221 ? S 0:01 update-notifier --startup-delay=60
 2224 ? S 0:00 gnome-volume-control-applet
 2226 ? S 0:00 gnome-power-manager
 2227 ? S 0:00 /usr/lib/gnome-disk-utility/gdu-notification-daemon
 2228 ? Ss 0:00 gnome-screensaver
 2232 ? S 0:00 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor
 2234 ? S 0:00 /usr/lib/gvfs/gvfsd-trash --spawner :1.9 /org/gtk/gvf
 2239 ? Ss 0:00 /bin/sh -c /usr/bin/compiz-decorator
 2240 ? S 0:16 /usr/bin/gtk-window-decorator
 2265 ? Ssl 0:00 /usr/lib/bonobo-activation/bonobo-activation-server -
 2270 ? S 0:34 python /usr/lib/gnome-applets/music-applet --oaf-acti
 2281 ? S 0:48 /usr/lib/gnome-applets/multiload-applet-2 --oaf-activ
 2284 ? S 0:00 /usr/lib/indicator-applet/indicator-applet-session --
 2285 ? S 0:01 /usr/lib/indicator-applet/indicator-applet --oaf-acti
 2287 ? S 0:08 /usr/lib/alarm-clock-applet/alarm-clock-applet --oaf-
 2290 ? S 0:36 /usr/bin/python /usr/bin/dockbarx.py --oaf-activate-i
 2292 ? S 0:00 /usr/lib/gnome-applets/trashapplet --oaf-activate-iid
 2293 ? S 0:00 bash /usr/bin/tomboy-panel --oaf-activate-iid=OAFIID:
 2296 ? Sl 0:02 mono /usr/lib/tomboy/Tomboy.e...

Read more...

Olivier Girard (eolinwen) wrote :

okay i want severals things; Could you reproduce this bug. If yes, do it and when it's done, open a window and type the command ps -x and post it. After, you should see , normaly, two instances of openshot. Kill one by this :
kill PID (pid is the number of the software to stop for exemple for you pidgin kill 2214) and say us what's happen and the new ps -x.
Thanks.

Daniel Ellis (danellisuk) wrote :

Hi cenwen, I will attempt to answer your questions. UNR is Ubuntu Netbook remix, it is 32bit (it does not come in the 64bit variety). It is basically Ubuntu desktop but tweaked for netbooks, mostly to do with the smaller display size. It is an official Ubuntu version and is available from the Ubuntu home page.

My test is using OpenShot 1.0.0 from the ppa.

Here, I start openshot from the terminal:-

$ openshot
Added /usr/share/openshot to system path
--------------------------------
   OpenShot (version 1.0.0)
--------------------------------
/usr/share/openshot/windows/SimpleGladeApp.py:340: GtkWarning: gtk_toolbar_set_icon_size: assertion `icon_size != GTK_ICON_SIZE_INVALID' failed
  return gtk.glade.XML(self.glade_path, root, domain)
A new frmMain has been created

Then run ps -x to show the PID:-

$ ps -x | grep "openshot"
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
 2820 pts/0 Sl+ 0:13 /usr/bin/python /usr/bin/openshot
 2869 pts/1 S+ 0:00 grep --color=auto openshot

I then browse to my Videos folder and right click on a video file (TestNtsc.vob) and select "Open With > OpenShot Video Editor". Another OpenShot instance is started and the video file has been added to both OpenShot instances.

Here is the output of ps:-

$ ps -x | grep "openshot"
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
 2820 pts/0 Sl+ 0:14 /usr/bin/python /usr/bin/openshot
 2902 ? Sl 0:13 /usr/bin/python /usr/bin/openshot /home/daniel/Videos/TestNtsc.vob
 2924 pts/1 S+ 0:00 grep --color=auto openshot

I then kill the second instance as you requested:-

$ kill 2902

The second instance is closed as expected, the first instance continues to work fine. I am not sure what that test shows though.

Olivier Girard (eolinwen) wrote :

Hi Daniel
Thanks for all (explication UNR, tests, commands,..).
I have tried to reproduce it with severals type of files (flv, mov, avi, dv) but i can't, only one Openshot is open.
Strangely, with a mpg file it had been added at the first project and when i have closed the second, he is stay.
Only this file and i know that we have some problems (white output) with this type of files and the cause is MLT so i'm thinking that but i'm not sure.
For the moment, i have none solution. Jonathan i confirm this.

Daniel Ellis (danellisuk) wrote :

I have now tested this on my desktop machine (Ubuntu Desktop 64bit) to confirm that it was not an issue to do with Ubuntu Netbook Remix. I have reproduced the issue with the following file types: vob, flv, xvid, mpeg.

Olivier Girard (eolinwen) wrote :

flv and xvid too ? Strange i've reproduced it with mpeg but it's works fine, for me, flv and xvid.
Thanks to have checked if it was an issue own UNR :)

moimael (moimael) wrote :

I confirm this bug with an .ogv file. And for me (version 1.1.2), the second instance of openshot doesnt load fully but crash.

Changed in openshot:
importance: Undecided → Low
Jonathan Thomas (jonoomph) wrote :

I have finally reproduced this bug. Currently, it's not possible to open files with nautilus, since it freezes up OpenShot. This will be fixed very soon. =)

Changed in openshot:
milestone: none → 1.1.3
assignee: nobody → Jonathan Thomas (jonoomph)
importance: Low → High
Changed in openshot:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers