Select and move multiple clips and transitions

Bug #420159 reported by Jay on 2009-08-27
286
This bug affects 60 people
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Wishlist
Unassigned

Bug Description

An item that would be very useful when creating a movie is to be able to select multiple clips and transitions in order to move them on the timeline.

For example, if I want to insert or trim a clip at the begining of my movie, I have to move each following clip and transition one by one. With the possibility to select all following clips and transitions, it could be done easily with one mouse drag.

(I currently use version 0.9.22)

Helen McCall (wildnfree) wrote :

Hello Jay,

This is something that Jonathan intends looking at soon.

markba: The link you give is to a blueprint for something different. It just refers to mass population of the timeline.

Many thanks for your comments

Helen

Changed in openshot:
status: New → Confirmed
Helen McCall (wildnfree) on 2009-08-28
tags: added: wishlist
removed: whichlist
Andy Finch (fincha) on 2009-10-05
Changed in openshot:
importance: Undecided → Wishlist
Pixtu (mail4pixtu) wrote :

I would just like to add my vote for this feature to be moved up the priority list and taken off the 'wish' list.

I don't know but appreciate that it may be a difficult feature to implement, but I am a little surprised that it wasn't there from the beginning.

Unless you have some kind of super computer brain (or a Crystal Ball would work!), it doesn't take long with a project to find that you need to insert a clip or reduce/remove one.

Now, unless I am missing something, this is currently a very fiddly process and definitely not in keeping with OpenShot being easy to use for either beginners or more experienced users. Yes, there is a 'shift clips' feature which can shift all clips on (only) the same track by a given number of seconds, but this does not include any transitions or effects.

This is not intended as a 'dig' in any sense as I really like OpenShot and what it has already become. I'm just asking that the priority of this feature is raised as I am sure everyone will really thank you for it.

Rgs

Jef Damen (jef-damen) wrote :

@Pixtu: At this moment it's also possible to move transitions in the same way as moving clips, just by rightclicking on the transition.
Jef

Can an elastic band (or whatever you call it -- the selection tool that Nauitlus has on the desktop and file browser) be created to select multiple tracks and transitions?

First of all, openshot is the greatest thing in video editing that has happened to linux, so thanks.

Now, I too have the mentioned problem, and I too think that it is more than a simple quirk. It practically limits the size of a project.
Can I suggest that a palliative, interim solution could be the possibility of inserting a clip in the middle of the timeline, and make it "open" it's space? I mean, move all the clips, transition etc that are to the right of the clip length, letting the user choose if apply this to this track or to all tracks or to all video or audio track. Would be very useful.

Paulo (paulo-morais-viraminas) wrote :

I think that the Brett and Romano suggestions are great.

I also think that we could select multiple clips by holding shift key and selecting the clips.

We could also cut and copy the clips, so we could paste it on other project, for example.

I think that with this resource, OpenShot could be a professional option for video edition on linux, considering that we have really poor options for doing it.

zerbob (zerbugug) wrote :

I agree with every thing above ; it would be great to have the ability to :
- insert clips (cf Romano)
- select multiple clips and transitions on the timeline using shift or ctrl or a box
- using the last feature, replace the duplicate tool with a cut/copy/paste tool (copy the selected clips to the cursor. Currently when you duplicate a clip it appears just next to the old one, possibly under another one).

Another good thing would be an option to write text on the screen, with basic settings (font, size, align, maybe color), because the current tool isn't very practical for subtitles or such things, you have to use inkscape or gimp to make them properly. I think this has already been requested.

Also when you press c to cut it cuts all tracks, there should be a way to lock some of them, I don't make it a feature request because maybe there's one and I missed it^^.

Finally when you import a sequence, instead of choosing how many frames per image it would be nice to set the framerate (I'm asking that because I make lego-animated movies)

I can't think of anything else. Openshot is great software, definitely THE video editor for Gnome (when you try apt-get install kdenlive you get 200MB of dependencies ^^). So, thanks for developing, now we have a video editor, all what we need is a few games and there won't be anyone left on windows (or will there ?).

I think that this feature request sould be among the most important ones on the roadmap. It is really needed when your project starts to get big.

Olivier Girard (eolinwen) wrote :

Totally agree with you so I push it in the next realize/version.

Changed in openshot:
milestone: none → 1.4.0

Thanks a lot !

Eduardo Rivas (jerivasmelgar) wrote :

Yes! Thanks for adding a milestone, I hope we can see this implemented soon!

tags: removed: wishlist
Changed in openshot:
status: Confirmed → Triaged
Changed in openshot:
milestone: 1.4.0 → 1.4.1
Andrea Denzler (andreaplanet) wrote :

There can be many ideas on how to implement this feature:

- grouping multiple items into one (to be saved with the video). This means that also changing effects on a grouped item will affect all the single items (i know that this can be complicated to do). it could be on multiple levels too, like with charting software.

- just simple "ctrl"+click to select multiple items temporarily, allowing moving, copy, paste, etc. And other effects too.
- or "ctrl" + click to add the selected track to the current group (with a new highlight color)

- click + draw rectangle + release. All tracks within the area are selected.

just my 2 cents...

Changed in openshot:
milestone: 1.4.1 → 1.5.0

This is the only missing feature that I actually find really limiting, all the others are more just minor things that bug me. I would love to see this in 1.5.0! Thanks to the developers for all their hard work!

Dmitri (ryba4) wrote :

This would be very useful.

Andrea Denzler's ideas are good. I'd suggest another way that might be worth trying:

 - an icon on a clip that changes 'sticking mode', making it stick to other clips, and all the touching or overlapping clips be moved together with transitions.

Flamekebab (flamekebab) wrote :

I thought it was just me being daft. Apparently this is still an issue!

Hopefully it'll get fixed in 2.x but really? Amazing effects but we can move a group of clips around?

Hope I will receive this feature in this life :/
Nevertheless - great editor with this big disadvantage. Like a Mercedes on wooden tires.

newsox (newsox-h) wrote :

my video is just a few jpg image files in rotation with music for about an hour.. without the ability to copy/paste a block of clips i suppose it just turns into a big time investment placing each image clip? probly i'm just missing that this was fixed, as this bug was first reported back in 2009. If someone could please point me twords the workaround for this bug i'd be very grateful.. Thanx and Merry Christmas!

Olivier Girard (eolinwen) wrote :

No at first look it has been planed in the 1.5.0.
Did this trick won't help you ?
http://www.openshotusers.com/help/1.3/en_GB/ar01s09.html#sect2_41

Andy Finch (fincha) on 2016-01-14
Changed in openshot:
status: Triaged → Fix Released
milestone: 1.5.0 → none
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions