Can’t import assets with a question mark in the file name

Bug #1416698 reported by Chriki™ on 2015-01-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenShot Video Editor
Low
Unassigned

Bug Description

Architecture (64 bits or 32 bits) : 64 bits
Operating System & version : Ubuntu 14.04
Installation Method : distro package
Version of Openshot installed : 1.4.3
BZR Revision used (if any) : N/A
MLT/melt version : ?
FFmpeg (i.e.libavcodec) version : from distro package (54?)
FFmpeg installation : from distro package

OpenShot fails to import assets with a question mark in the file name, saying something like “OpenShot doesn’t support this file format” (my translation).

In my particular case, I was creating a new title which had a question mark in its name. When finishing the title creation dialog, the title didn’t show up anywhere. This was confusing. I found the created SVG file in my file manager and tried to import it manually which led to the error message above. That was confusing again. When I removed the question mark from the file name, the SVG file could be imported without any problems as expected.

Changed in openshot:
status: New → Invalid
Chriki™ (chrikitm) wrote :

@Olivier Girard: why is this bug “Invalid”? Can’t you reproduce the issue? Is it expected behavior?

I've just quickly test creating an new personalized title using the title2D
and I've noted nothing. The title is displayed in Openshot like planned.
I think that's more how do you create your title than a bug of opnehsot or
inkscape.
How do you proceed for creating a tilte ?

2015-03-15 15:34 GMT+01:00 Chriki™ <email address hidden>:

> @Olivier Girard: why is this bug “Invalid”? Can’t you reproduce the
> issue? Is it expected behavior?
>
> --
> You received this bug notification because you are a member of OpenShot
> Bugs, which is subscribed to OpenShot Video Editor.
> https://bugs.launchpad.net/bugs/1416698
>
> Title:
> Can’t import assets with a question mark in the file name
>
> Status in OpenShot Video Editor:
> Invalid
>
> Bug description:
> Architecture (64 bits or 32 bits) : 64 bits
> Operating System & version : Ubuntu 14.04
> Installation Method : distro package
> Version of Openshot installed : 1.4.3
> BZR Revision used (if any) : N/A
> MLT/melt version : ?
> FFmpeg (i.e.libavcodec) version : from distro package (54?)
> FFmpeg installation : from distro package
>
> OpenShot fails to import assets with a question mark in the file name,
> saying something like “OpenShot doesn’t support this file format” (my
> translation).
>
> In my particular case, I was creating a new title which had a question
> mark in its name. When finishing the title creation dialog, the title
> didn’t show up anywhere. This was confusing. I found the created SVG
> file in my file manager and tried to import it manually which led to
> the error message above. That was confusing again. When I removed the
> question mark from the file name, the SVG file could be imported
> without any problems as expected.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openshot/+bug/1416698/+subscriptions
>
> --
> Mailing list: https://launchpad.net/~openshot.bugs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openshot.bugs
> More help : https://help.launchpad.net/ListHelp
>

--
Olivier
Cenwen un elfe sur la banquise/ an elve on the ice
Mon blog perso sur le multimédia, Ubuntu, Linux et OpenShot :
http://linuxevolution.wordpress.com/
Le forum d'Openshot où vous me trouverez : http://openshotusers.com/
http://openshotusers.com/forum/index.php
Nothing is lost until the last second.
The family motto : When we want, we can.
Astuces, Actualités, Logiciels, bref sur tout ce que je ne fais d'articles
dessus Google+ <https://plus.google.com/u/0/111472725110173916234/posts>

Chriki™ (chrikitm) wrote :

Steps to reproduce with Openshot 1.4.3 on Ubuntu 14.04:

1. Open OpenShot.
2. In the “Title” menu, select “New Title …”
3. Under “Start here”, select “Gold 2” and click “Create new Title”.
4. As the name enter “Test? Yes.” and click “OK”.
5. Enter “Test? Yes.” into both fields and click “OK” again.
6. Click “Apply”.
→ Nothing happens. The new title doesn’t appear in the “Project Files” list.

Further steps to reproduce the mentioned message:

1. Create an arbitrary SVG file with Inkscape and call the file “test.svg”.
2. In a shell run: “cp test.svg 'test2.svg'”
2. Open OpenShot.
3. Hit Ctrl+F to get to the import dialog.
4. Import “test.svg”.
→ Works up to here, the file shows up in the “Project Files” list.
5. Hit Ctrl+F again.
6. Import “test?.svg”.
→ An information dialog pops up with the message “OpenShot doesn’t support this file format” (my translation). After clicking “OK” the “Project Files” lists hasn’t changed compared to before the import.

Olivier Girard (eolinwen) wrote :
Download full text (3.4 KiB)

Yeah. I 've done some test and I confirm this issue. And I can tell you
that the issue come from the ?. Done the same step that you have write at
the begining without the ? . With the . that's work too.

2015-03-15 18:40 GMT+01:00 Chriki™ <email address hidden>:

> Steps to reproduce with Openshot 1.4.3 on Ubuntu 14.04:
>
> 1. Open OpenShot.
> 2. In the “Title” menu, select “New Title …”
> 3. Under “Start here”, select “Gold 2” and click “Create new Title”.
> 4. As the name enter “Test? Yes.” and click “OK”.
> 5. Enter “Test? Yes.” into both fields and click “OK” again.
> 6. Click “Apply”.
> → Nothing happens. The new title doesn’t appear in the “Project Files”
> list.
>
> Further steps to reproduce the mentioned message:
>
> 1. Create an arbitrary SVG file with Inkscape and call the file “test.svg”.
> 2. In a shell run: “cp test.svg 'test2.svg'”
> 2. Open OpenShot.
> 3. Hit Ctrl+F to get to the import dialog.
> 4. Import “test.svg”.
> → Works up to here, the file shows up in the “Project Files” list.
> 5. Hit Ctrl+F again.
> 6. Import “test?.svg”.
> → An information dialog pops up with the message “OpenShot doesn’t support
> this file format” (my translation). After clicking “OK” the “Project Files”
> lists hasn’t changed compared to before the import.
>
> --
> You received this bug notification because you are a member of OpenShot
> Bugs, which is subscribed to OpenShot Video Editor.
> https://bugs.launchpad.net/bugs/1416698
>
> Title:
> Can’t import assets with a question mark in the file name
>
> Status in OpenShot Video Editor:
> Invalid
>
> Bug description:
> Architecture (64 bits or 32 bits) : 64 bits
> Operating System & version : Ubuntu 14.04
> Installation Method : distro package
> Version of Openshot installed : 1.4.3
> BZR Revision used (if any) : N/A
> MLT/melt version : ?
> FFmpeg (i.e.libavcodec) version : from distro package (54?)
> FFmpeg installation : from distro package
>
> OpenShot fails to import assets with a question mark in the file name,
> saying something like “OpenShot doesn’t support this file format” (my
> translation).
>
> In my particular case, I was creating a new title which had a question
> mark in its name. When finishing the title creation dialog, the title
> didn’t show up anywhere. This was confusing. I found the created SVG
> file in my file manager and tried to import it manually which led to
> the error message above. That was confusing again. When I removed the
> question mark from the file name, the SVG file could be imported
> without any problems as expected.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openshot/+bug/1416698/+subscriptions
>
> --
> Mailing list: https://launchpad.net/~openshot.bugs
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openshot.bugs
> More help : https://help.launchpad.net/ListHelp
>

--
Olivier
Cenwen un elfe sur la banquise/ an elve on the ice
Mon blog perso sur le multimédia, Ubuntu, Linux et OpenShot :
http://linuxevolution.wordpress.com/
Le forum d'Openshot où vous me trouverez : http://openshotusers.com/
http://openshotusers.com/forum/inde...

Read more...

Changed in openshot:
status: Invalid → Confirmed
importance: Undecided → Low
milestone: none → 1.5.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers