Find Nearest not listed in distance order.

Bug #579406 reported by chris_debian on 2009-07-26
2
Affects Status Importance Assigned to Milestone
OpenSatNav
Medium
Kieran Fleming

Bug Description

Hi, Kieran.

I was testing the _Find Nearest.._ tool this moring.

Most of the results seemed fine, but sometimes I would find that a result that was 5 miles away would be listed, then 6 miles away, BUT the next was 5 miles. I would expect them to be in ascending order.

I couldn't see any pattern to this behaviour.

Any thoughts?

Chris.

chris_debian (cjhandrew) wrote :

This is the only bug that hasn't got a target release, so I've gone for 1.1. Happy to change if necessary.

Chris.

chris_debian (cjhandrew) wrote :

Just tried latest SNAP-SHOT. Still the same problem. Not listed in distance order.

Chris.

Kieran Fleming (kieran-fleming) wrote :

No, that hasn't been fixed yet. It's a difference between how OSM namefinder and OSN measure distances. This problem should be easy to fix.

Murphy (murphy2712+launchpad) wrote :

Actually it's not a bug, it's a "feature": #5 :)
I think you need to merge this bug #37 with feature #5.

Kieran Fleming (kieran-fleming) wrote :

Actually, it's not the same. Bug #5 says that it only happens when the text based search is used, not the Find nearest (POI) search. You can test out the queries on http://gazetteer.openstreetmap.org/namefinder/

Text based: use the same search string as you would in OSN
Find nearest: for the nearest pub it would be "pub near <lat>,<long>"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers