[Upstream] [hardy] Feature Request: Read-only document should be editable

Bug #97292 reported by Michael B. Trausch on 2007-03-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: openoffice.org

When opening a document from a source such as e-mail in Evolution, the file is a read-only copy. However, sometimes, it is worthwhile to be able to make edits to the document, and then save it as a new file. For example, let’s say someone sends me a spreadsheet with the financials of a company contained in it, and I would like to key in some equations to do some analysis on those figures. As it stands presently, I have to either (a) save the attachment from within Evolution to my home folder and then open it from within OOo or the file manager or whatever, or (b) open the attachment from within Evolution, save a read-write copy of the file, and then proceed to work on it.

When an attempt is made to edit the file, OOo pops up a dialog stating that the “Document opened in read-only mode.” Instead, it should probably say something like, “The document you are attempting to edit is read-only. Would you like to work on a copy?” with a yes/no option. If the user selects “Yes,” then OpenOffice could disassociate the document in memory with the one it originally opened on disk, treating the document as an unsaved document without a file name, and then permit the user to go about their business and save the file if they want. I know that for me, I sometimes want to make minor changes to get a number out, and then toss the document away—so saving it as an intermediary file is really not optimal.

I know that this is the way it works for files in Writer and Calc. I am assuming that this is the same across the board in all of the portions of OOo.

Chris Burgan (cburgan) wrote :

Thanks for your report.

I just attempted e-mailing myself a document and I was able to edit it, then I realized it wasn't read-only but located in tmp. So I created a new file and performed a chmod 444 to make it read only to everyone and opened that file. I can confirm you can't write in it, but at the same time as soon as you go and "save as" to something else, the file then becomes editable. I would imagine this is how it is meant to be.

If you could reply with the version of Ubuntu/OpenOffice you are using and if this performs differently then the above, I would appreciate it.

Changed in openoffice.org:
status: Unconfirmed → Needs Info
Michael B. Trausch (mtrausch) wrote :

Using fully updated Ubuntu Feisty—so OOo 2.2.0~rc3~oof680m10-0ubuntu3 at the moment. However, this has been a persistent thing—I just never got around to putting the feature request in like I had meant to long ago, considering that the use case for editing data like that did not come up very often. For example, I just opened something from an NNTP feed that was attached—a Microsoft Word document—by double-clicking it from within Evolution. The file doesn’t seem to show up in the output from “lsof”, but it is read-only. If I wanted to edit it, I would have to re-save it, which is fine. In this case, I don’t want to edit the file. However, when I get my grade sheets in, I like to just use the spreadsheet to calculate percentages so I can see where I stand as of those grade sheets. Instead, I either need to open up bc, gcalctool, or resave the document before I can input new formulas. It is just a minor inconvenience, but the more frequently such a situation occurs, the more of a time-eater it gets to be. :-)

Attached is the screen shot of the document as it was opened from Evolution.

Matthias Klose (doko) on 2007-03-31
Changed in openoffice.org:
importance: Undecided → Wishlist
status: Needs Info → Confirmed
Changed in openoffice:
status: Unknown → Unconfirmed
Changed in openoffice:
status: Unconfirmed → Rejected
Michael B. Trausch (mtrausch) wrote :

The upstream issue was resolved as a duplicate of http://www.openoffice.org/issues/show_bug.cgi?id=73155

I don’t know if that should just be replaced in the tracker above or added. I tried adding it, but Launchpad did not seem to like that idea...

Changed in openoffice:
status: Unknown → Confirmed
Mendez (ubuntu-mendez) wrote :

Just to add that this is still present and an annoyance.

OO won't even let you apply a sort to the data if it's been opened read-only and I can imagine this would be quite a problem in a corporate situation where a user might only have read access to a document and you don't want them to be creating their own copies.

I think it would be more intuitive if the read-only only became an issue when you tried to save the document as with Excel.

matt felser (mfelser) wrote :

I use Thunderbird and I am experiencing similar issues. Is there a workaround for this?

Is it the mail clients' problem or OpenOffice.org's?

  • unnamed Edit (189 bytes, application/pgp-signature; name=signature.asc)

On Tue, 2008-04-15 at 02:40 +0000, matt felser wrote:
> Is it the mail clients' problem or OpenOffice.org's?

The problem is most likely OOo's "fault". OOo should really open a
read-only document such that when you attempt to make the first edit to
it, you are prompted to open a copy of it in read-write mode, treating
the next subsequent save as a "Save As". There is a button that lets
you do this manually, but I can't recall ATM where that is because I've
not used OOo in so long... I have actually moved over to XeTeX/XeLaTeX
for most of my document preparation needs.

 --- Mike

--
Michael B. Trausch <email address hidden>
home: 404-592-5746, 1 www.trausch.us
cell: 678-522-7934 im: <email address hidden>, jabber
Ubuntu Unofficial Backports Project: http://backports.trausch.us/

Chris Cheney (ccheney) wrote :

Click on the button "Edit File" it is the fifth icon from the left.

Chris

Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
status: Confirmed → Triaged
Chris Cheney (ccheney) on 2010-05-14
tags: added: hardy
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.