The OpenOffice.org Suite

[upstream] [3.2] Recent Documents doesn't include files opened from within OOO

Reported by Nick Moffitt on 2006-10-19
46
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenOffice
Fix Released
Unknown
Ubuntu
Low
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Note: Also verify the fix corrects the duplicate related bug:
"Documents opened from openoffice 'recent documents' list are not added to the gnome 'recent documents' list"

Binary package hint: openoffice.org-gnome

On Edgy, running openoffice.org 2.0.4-0ubuntu2, selecting a document with the file selection dialog within OOO does not add that file to the Places->Recent Documents list.

If you open the file from nautilus, causing OOO to be launched, the file is added to the Recent Documents list.

GNOME changed the recent files mechanism which was previously based on
a "freedesktop.org standard" and now it's something different, and
there is no migration path at all. IMNSHO the guy who changed the
recent files code should have enhanced the panel (and only the panel)
to support both methods.

The new scheme requires linking to gtk+ unconditionally which isn't
possible for OOo.

This is not strictly OOo-only, all GNOME apps that used the old scheme
have to be ported one by one to the new scheme (it's not a simple
recompile). I don't expect that all GNOME apps in the repository have
been ported.

You might want to consider reassigning to gnome-panel (because it's
the only location where a workaround can be implemented, not because
it's the panel's fault)

Matthias Klose (doko) on 2006-10-19
Changed in openoffice.org:
status: Unconfirmed → Confirmed

I can confirm that the same problem is present under Kubuntu, when using the Recent Documents kicker applet. It also applies for files _created_ within OpenOffice.

Sebastien Bacher (seb128) wrote :

Thank you for your bug. That's not a gnome-panel bug

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Rejected
Yotam Benshalom (benshalom) wrote :

As a heavy OpenOffice user, who works on several documents simultaneously and keeps opening and closing them, I find this bug extremely annoying. It actually makes the recent document list quite useless for me. Maybe we can raise its importance?

Matthias Klose (doko) on 2007-03-07
Changed in openoffice.org:
importance: Undecided → Low
Michael Broadbent (mikebro) wrote :

This appears to still be in issue in Feisty Herd 5 with the latest updates.

Changed in openoffice:
status: Unknown → In Progress
Kevin Kubasik (kkubasik) wrote :

So is the only real solution here a dirty hack on OpenOffice's part, or an API shift/fix/change for gtk/gnome? If we can define who really needs to do what for this to happen, I'll try to get things moving, since this is a huge pain when working on lab reports ;)

Ohb01 (ohb01) wrote :

I'm also seeing the same issue with OOO 2.2 and Ubuntu Feisty 7.04 with the latest updates. It reduces the system's intuitiveness, and affects user productivity. Therefore, I'd like to add my vote in favor of correcting this issue, as

Is there a method for deciding who would fix an issue like this, so it does not fall "between the cracks" of two or three different Open Source projects?

Thanks in advance for your help.

Changed in openoffice:
status: In Progress → Fix Released
Henrik Nilsen Omma (henrik) wrote :

Targeted (and fixed) upstream for OOo 2.3. Still broken in Gutsy with 2.2.1.

Gert Kulyk (gkulyk) wrote :

It is still broken in Gutsy (ooo 2.3 rc1-1ubuntu1), in debian (tested with sid, gtk 2.10) it works. Did gtk-recent-manager change again in gtk 2.12 or is an ubunu-specific patch preventing the use of it? It seems like it is still using .recently-used instead of .recently-used.xbel. Any idea why?

Gert Kulyk (gkulyk) wrote :

As I found out, it is working in Gutsy, but not if your user-profile is migrated from feisty. Seems like fix is released.

Changed in openoffice:
status: Fix Released → Confirmed
Chris Cheney (ccheney) on 2008-03-15
Changed in openoffice.org:
status: Confirmed → Fix Released

Chris Cheney: Are you sure this is fixed when migrating from Feisty? Upstream still says "Confirmed".

Chris Cheney (ccheney) wrote :

Milan,

It's fixed but is not completely fixed in all cases which is why it is still open upstream, it seems to work fine on Ubuntu though except in the upgrade case like Gert mentioned due to the old user profile. If the user profile (.openoffice.org2 dir) is removed it works.

Chris

Yes. If you consider this as fixed then it's okay. But OTOH it might be good to keep it open so that upgraders can find what's going on when searching for bug reports about that.

I've just tested this in Jaunty, and it seems that it's working now, even when upgrading from Intrepid and beyond.

Craig McQueen (cmcqueen1975) wrote :

In Jaunty I was still having this issue. I've done the incremental Ubuntu upgrades since, I can't remember when, possibly Feisty.

I followed the suggestion of deleting my user .openoffice.org2 directory, but that didn't fix it. I then tried deleting my user .openoffice.org directory, and that fixed the issue. (It also lost my OpenOffice options, so I had to re-do those.)

Craig: Yes, .openoffice.org2 is now replaced in OO.o 3.0 with .openoffice.org/3/, thus removing the former has no effect. And BTW, my previous comment is wrong, there are still cases where the recent files are not updated.

I'd really like somebody to tell us where we can fix this problem without removing the entire config folder. So far, looking into the different config files did not give me any hint...

Changed in openoffice:
status: Confirmed → Invalid
Chris Cheney (ccheney) on 2009-08-27
Changed in openoffice:
status: Invalid → Unknown
Changed in openoffice.org (Ubuntu):
status: Fix Released → Triaged
summary: - Recent Documents doesn't include files opened from within OOO
+ [upstream] [3.2] Recent Documents doesn't include files opened from
+ within OOO
Changed in openoffice:
status: Unknown → Fix Released
Chris Cheney (ccheney) on 2009-09-11
description: updated
Yotam Benshalom (benshalom) wrote :

Checking with the last dev snapshot (OOo-dev 3.2.0 DEV300m57 (build:9422)):
When a document is opened via file->Open dialog, it is added to the gnome recent documents list.
When a document is opened via file->Recent Documents, it is NOT added to the gnome recent document list.
Therefore the fix is only partial.

Chris Cheney (ccheney) wrote :

Thanks, I forward your comment to the upstream bug report, hopefully they can still fix it in time for OOo 3.2

Robert Roth (evfool) wrote :

I have checked this on Maverick using Openoffice 3.2.1-7ubuntu1 and it is fixed for me (Document is added to Gnome Recent Documents list when opening with File->Open and also when opening with File->Recent documents.) Can anyone confirm that this has been fixed indeed?

I think it's been fixed some time ago indeed.

Changed in openoffice.org (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.