The OpenOffice.org Suite

[upstream] "Object 1,2,3,..." instead of my formulas

Reported by Dem0n3D on 2009-12-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenOffice
New
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

Math formulas in .odt document become unreadable after saving (Writer 3.0) and opening (Same in Writer 3.0 and 3.1) document. Instead of formulas, I saw "Object 1", "Object 2", etc.

ProblemType: Bug
Architecture: amd64
Date: Mon Dec 28 19:44:41 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Kubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: fglrx
Package: openoffice.org-core 1:3.1.1-5ubuntu1
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-16.53-generic
SourcePackage: openoffice.org
Uname: Linux 2.6.31-16-generic x86_64
XsessionErrors:
 (polkit-gnome-authentication-agent-1:2652): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (npviewer.bin:4974): Gtk-WARNING **: /usr/lib/gtk-2.0/2.10.0/engines/libqtcurve.so: wrong ELF class: ELFCLASS64
---
Architecture: i386
DistroRelease: Ubuntu 10.04
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100427)
NonfreeKernelModules: nvidia
Package: openoffice.org 1:3.2.0-7ubuntu4
PackageArchitecture: i386
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=ru_RU.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Tags: lucid
Uname: Linux 2.6.32-22-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare www-data

Dem0n3D (demon-asgard) wrote :
Leif Andersen (leifandersen) wrote :

I've also noticed this same problem. Although I'm using 10.04 rather than 9.10, and OpenOffice 3.2, rather than 3.1 or 3.0. I'm attaching a document to demonstrate what I mean. Also, this bug seems to be very similar: http://qa.openoffice.org/issues/show_bug.cgi?id=100230

Chris Cheney (ccheney) on 2010-05-13
tags: added: kubuntu
tags: added: karmic
Chris Cheney (ccheney) wrote :

[This is an automatic notification.]

This bug was reported against an earlier version of Ubuntu, can you test if it still occurs on Ubuntu 10.04 LTS (Lucid Lynx)?

Please note we also provide technical support for older versions of Ubuntu, but not in the bug tracker. Instead, to raise the issue through normal support channels, please see:

    http://www.ubuntu.com/support

If you are the original reporter and can still reproduce the issue on Lucid, please run the following command to refresh the report:

  apport-collect 501030

Bear in mind that you may need to install the python-launchpadlib package from the universe repository. Additionally, when prompted to give apport-collect permissions for Launchpad you will need to give it at least the ability to "Change Non-Private" data as it will be adding information to your bug report.

If you are not the original reporter, please file a new bug report, so we can work with you as the original reporter instead (you can reference bug 501030 in your report if you think it may be related):

  ubuntu-bug openoffice.org

If by chance you can no longer reproduce the issue on Lucid or if you feel it is no longer relevant, please mark the bug report 'Fix Released' or 'Invalid' as appropriate, at the following URL:

  https://bugs.launchpad.net/ubuntu/+bug/501030

Changed in openoffice.org (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected
description: updated

Did your openoffice crash around the time that this happened? The upstream bug report seems to indicate it may be related to it crashing.

Dem0n3D (demon-asgard) wrote :

No.

Chris Cheney (ccheney) on 2010-05-21
summary: - "Object 1,2,3,..." instead of my formulas
+ [upstream] "Object 1,2,3,..." instead of my formulas
Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in openoffice:
status: Unknown → New

Original attachment Document downloaded, renamed, and immediately uploaded.

Dem0n3D, you may have fallen into one of following issues regarding Math formulas:

+ As per upstream discussion their is a known issue with Math objects being corrupted upon saving.
+ The multi-language issue discussed here: http://wiki.services.openoffice.org/wiki/Documentation/FAQ/Formula/I_have_written_a_document_containing_a_formula._I_gave_it_to_a_friend_and_when_she_opened_it_the_user-defined_symbols_didn%27t_work._What%27s_the_matter%3F

The attachments are a result of the problem but do not help tremendously in narrowing down how to reproduce this. Is their a simple test case you can provide where one creates a formula, save the file, and upon reopening demonstrates this problem? Can you reproduce the problem in LibreOffice Writer?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in openoffice.org (Ubuntu):
status: Triaged → Incomplete
Dem0n3D (demon-asgard) wrote :

Christopher M. Penalver, no, I can't.

Changed in openoffice.org (Ubuntu):
importance: Medium → Low
status: Incomplete → New
Changed in libreoffice (Ubuntu):
status: Incomplete → New

The bug task for LibreOffice is being closed due to your last comment regarding this being fixed by updating to it. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in libreoffice (Ubuntu):
status: New → Invalid
Changed in openoffice.org (Ubuntu):
status: New → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.