OpenOffice.org Calc does not have enough columns

Bug #240895 reported by Diederik Zwager
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

I opened the attached Excel 1997-2003 spreadsheet that has a lot of columns (one for every day of the year, plus a few more). However OpenOffice.org Calc will only display the columns up until "IV". That means that the last 3 months of the year are not visible.

Please fix this.

Revision history for this message
Diederik Zwager (dzwager) wrote :
Revision history for this message
Marco da Silva (igama) wrote :

What version of OpenOffice are you using?

That is not related to Ubuntu, but OpenOffice it Self.

If your using OpenOffice 2.3 , Try OpenOffice 2.4 , you can get the DEBS at openoffice.org.

If using 2.4 you can try the OpenOffice 3.0 Beta.

Revision history for this message
Dimitrios Symeonidis (azimout) wrote :

The issue exists in OpenOffice 2.4.

It is one of the features in OpenOffice 3:
http://marketing.openoffice.org/3.0/featurelistbeta.html#1024_Columns_Per_Calc_Sheet_.28Instead_of_256.29

If you want, you can try using OpenOffice 3 release candidates from here:
http://download.openoffice.org/680/?intcmp=1461
however, it is not recommended for production systems...

Otherwise, you should just wait (version 3 should be out in autumn I think)

Changed in openoffice.org:
status: New → Confirmed
Revision history for this message
Chris Cheney (ccheney) wrote :

The xls file you attached only shows to column 'IV' even in Microsoft Excel 2007. Are you sure your file isn't incomplete?

Thanks,

Chris Cheney

Changed in openoffice.org:
status: Confirmed → Incomplete
Revision history for this message
Chris Cheney (ccheney) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in openoffice.org:
status: Incomplete → Invalid
Revision history for this message
Robert Pawn (bobtpawn) wrote :

I am currently trying to use OO Calc for data analysis, but my data has a little more than 3000 columns. I am expecting interesting effects to happen in the last 700 or so columns, but Calc can't load them.

Changed in openoffice.org (Ubuntu):
status: Invalid → New
Revision history for this message
Dimitrios Symeonidis (azimout) wrote :

confirmed, wishlist
microsoft excel 2007 supports "1,048,576 rows by 16,384 columns" (quoted from http://office.microsoft.com/en-us/excel/HA100738731033.aspx)

Changed in openoffice.org (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Revision history for this message
Chris Cheney (ccheney) wrote :

Can you please attach an example document exhibiting this problem?

Changed in openoffice.org (Ubuntu):
importance: Wishlist → Undecided
status: Confirmed → Incomplete
Chris Cheney (ccheney)
Changed in openoffice.org (Ubuntu):
importance: Undecided → Medium
status: Incomplete → Triaged
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney)
summary: - OpenOffice.org Calc does not have enough columns
+ [upstream] OOo Calc increase columns limit to 16K
Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in openoffice.org (Ubuntu):
importance: Medium → Low
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote : migrating packaging from OpenOffice.org to Libreoffice

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - [upstream] OOo Calc increase columns limit to 16K
+ Calc increase columns limit to 16K
Revision history for this message
Xavier Poinsard (xpoinsard) wrote : Re: Calc increase columns limit to 16K

The bug in libreoffice bugzilla : https://bugs.freedesktop.org/show_bug.cgi?id=50916

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Diederik Zwager, thank you for reporting this and helping make Ubuntu better. The reason why the file you attached only showed up to column IV (256 columns) in OpenOffice.org, and now in LibreOffice, is because this is the specification limit of the Excel 2003 file format. For more on this, please see http://office.microsoft.com/en-us/excel-help/excel-specifications-and-limits-HP005199291.aspx .

As well, if one attempts to open the same file in Microsoft Office Professional Plus 2010 Excel Version 14.0.6023.1000 (32-bit) the same phenomenon occurs. LibreOffice keeps expectation compatibility with this.

Thank you for reporting this and helping make Ubuntu better. Please feel free to report any future bugs you may find.

lsb_release -rd
Description: Ubuntu 12.10
Release: 12.10

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.6.2~rc2-0ubuntu3
  Candidate: 1:3.6.2~rc2-0ubuntu3
  Version table:
 *** 1:3.6.2~rc2-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ quantal/main i386 Packages
        100 /var/lib/dpkg/status

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
summary: - Calc increase columns limit to 16K
+ OpenOffice.org Calc does not have enough columns
Revision history for this message
efa (efa) wrote :

see Libreoffice 1024 column limit:
https://bugs.freedesktop.org/show_bug.cgi?id=50916

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.