The OpenOffice.org Suite

[ooo-build] Flat ODT file has no formatting

Reported by Russel Winder on 2008-05-03
2
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
openoffice.org (Ubuntu)
Low
Chris Cheney

Bug Description

Using OpenOffice.org with Hardy, after having manually introduced the symbolic link:

 lrwxrwxrwx 1 root root 19 2008-05-03 10:27 java-6-sun-1.6.0.03 -> java-6-sun-1.6.0.06/

in /usr/lib/jvm so that writing Flat ODT and DoccBook/XML actually works, I have found that the Flat ODT file is written as a single line. Clearly this is fine as far as XML processing is concerned but it means that this format is useless as a text-based format for storing in a version control system -- mergeability requires that the file be line structured so that merging does not simply result in replacing the whole file (because the whole line is replaced.

If the fodt file were line structured as the DocBooc/XML file is then it would be far better for storing in a version control system.

Chris Cheney (ccheney) wrote :

Confirmed in openoffice.org 1:2.4.1-1ubuntu2.

Changed in openoffice.org:
importance: Undecided → Wishlist
status: New → Triaged

I believe that this is an ooo-build issue since upstream openoffice.org doesn't appear to support writing out to Flat ODT (fodt) format.

"
I have found that the Flat ODT file is written as a single line. Clearly this is fine as far as XML processing is concerned but it means that this format is useless as a text-based format for storing in a version control system -- mergeability requires that the file be line structured so that merging does not simply result in replacing the whole file (because the whole line is replaced).

If the fodt file were line structured as the DocBooc/XML file is then it would be far better for storing in a version control system.
"

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Confirmed

Use some postprocessor to reindent the XML if you like. For instance xmllint --format?

It might be enough to change the line

+ <xsl:output method="xml" encoding="UTF-8"/>

to

+ <xsl:output method="xml" encoding="UTF-8" indent="yes"/>

in filter/source/odfflatxml/odfflatxmlexport.xsl part of patches/dev300/odf-flatxml-import-export.diff

Chris, could you please try it & commit if it improves the output?

Thanks a lot in advance!

Changed in openoffice:
status: Confirmed → Incomplete
Chris Cheney (ccheney) on 2008-10-27
Changed in openoffice.org:
assignee: nobody → ccheney
milestone: none → later

Adding indent="yes" gives a beautifully formatted output perfect for version control systems. Please add this to future releases.

Chris Cheney (ccheney) on 2009-01-17
Changed in openoffice.org:
importance: Wishlist → Low
milestone: later → jaunty-alpha-4

Yes adding indent="yes" corrects this issue. I will commit this fix once I finish the current set of packaging for Ubuntu, in the next few days, if no one else commits the change earlier.

Changed in openoffice:
status: Incomplete → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.0.1-1ubuntu1

---------------
openoffice.org (1:3.0.1-1ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (r1395). Remaining changes:
    - Add Launchpad integration support.
    - Add Launchpad translations support.
    - Add package openoffice.org-style-human.
    - Add some Ubuntu-specific bitmaps. Adjust broffice diversions for these.
    - Add support for compressing debs with lzma.
    - Add support for shared /usr/share/doc directories.
    - Add support to build l10n as a separate source.
    - Add support to build on lpia.
    - Add support to turn off building on sparc.
    - Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - Set startcenter.desktop to not display in the menu.
    - Use imagemagick instead of graphicsmagick.
    - openoffice.org-help switch to internal copy of lucene.
    - Add Depends openoffice.org-math to openoffice.org-writer.
      Closes LP: #223476
    - Remove extra ooo-build changelog. Closes LP: #262579
    - boost1.35 transtition. Closes LP: #297152
    - Add & to ooo87965.execute.sh. Closes LP: #313495
    - OOo needs stlport on i386 for extension compatibility.
      Closes LP: #322188
    - calc needs depends on lp-solve since it links to it.
      Closes LP: #322189
  * Resynchronise with ooo-build-3-0-1 (r15230).
    - Update launchpad-integration menu entries. Closes LP: #41694
    - Add indentation to flat odt files. Closes LP: #226075
    - Change code from Err:529 to Err:519. Closes LP: #226457

 -- Chris Cheney <email address hidden> Thu, 29 Jan 2009 01:00:00 -0600

Changed in openoffice.org:
status: Triaged → Fix Released

Update released for: OpenOffice_org, OpenOffice_org-af, OpenOffice_org-ar, OpenOffice_org-be-BY, OpenOffice_org-bg, OpenOffice_org-ca, OpenOffice_org-cs, OpenOffice_org-cy, OpenOffice_org-da, OpenOffice_org-de, OpenOffice_org-el, OpenOffice_org-en-GB, OpenOffice_org-es, OpenOffice_org-et, OpenOffice_org-fi, OpenOffice_org-fr, OpenOffice_org-galleries, OpenOffice_org-gnome, OpenOffice_org-gu-IN, OpenOffice_org-hi-IN, OpenOffice_org-hr, OpenOffice_org-hu, OpenOffice_org-it, OpenOffice_org-ja, OpenOffice_org-kde, OpenOffice_org-km, OpenOffice_org-ko, OpenOffice_org-lt, OpenOffice_org-mk, OpenOffice_org-mono, OpenOffice_org-nb, OpenOffice_org-nl, OpenOffice_org-nld, OpenOffice_org-nn, OpenOffice_org-officebean, OpenOffice_org-pa-IN, OpenOffice_org-pl, OpenOffice_org-pt, OpenOffice_org-pt-BR, OpenOffice_org-ru, OpenOffice_org-rw, OpenOffice_org-sdk, OpenOffice_org-sdk-doc, OpenOffice_org-sk, OpenOffice_org-sl, OpenOffice_org-sr-CS, OpenOffice_org-st, OpenOffice_org-sv, OpenOffice_org-tr, OpenOffice_org-ts, OpenOffice_org-vi, OpenOffice_org-xh, OpenOffice_org-zh-CN, OpenOffice_org-zh-TW, OpenOffice_org-zu
Products:
SLE-DEBUGINFO 10-SP2 (i386, x86_64)
SLE-DESKTOP 10-SP2 (i386, x86_64)
SLE-SDK 10-SP2 (i386, x86_64)

Download full text (4.8 KiB)

Update released for: OpenOffice_org, OpenOffice_org-LanguageTool, OpenOffice_org-LanguageTool-cs, OpenOffice_org-LanguageTool-de, OpenOffice_org-LanguageTool-en, OpenOffice_org-LanguageTool-es, OpenOffice_org-LanguageTool-fr, OpenOffice_org-LanguageTool-it, OpenOffice_org-LanguageTool-nl, OpenOffice_org-LanguageTool-pl, OpenOffice_org-LanguageTool-ro, OpenOffice_org-LanguageTool-ru, OpenOffice_org-LanguageTool-sv, OpenOffice_org-base, OpenOffice_org-base-debuginfo, OpenOffice_org-base-debugsource, OpenOffice_org-base-devel, OpenOffice_org-base-drivers-postgresql, OpenOffice_org-base-extensions, OpenOffice_org-base-l10n-prebuilt, OpenOffice_org-calc, OpenOffice_org-calc-debuginfo, OpenOffice_org-calc-debugsource, OpenOffice_org-calc-devel, OpenOffice_org-calc-extensions, OpenOffice_org-calc-l10n-prebuilt, OpenOffice_org-components, OpenOffice_org-components-debuginfo, OpenOffice_org-components-debugsource, OpenOffice_org-components-devel, OpenOffice_org-components-l10n-prebuilt, OpenOffice_org-converter, OpenOffice_org-draw, OpenOffice_org-draw-extensions, OpenOffice_org-filters, OpenOffice_org-filters-debuginfo, OpenOffice_org-filters-debugsource, OpenOffice_org-filters-devel, OpenOffice_org-filters-l10n-prebuilt, OpenOffice_org-filters-optional, OpenOffice_org-gnome, OpenOffice_org-help-ar, OpenOffice_org-help-cs, OpenOffice_org-help-da, OpenOffice_org-help-de, OpenOffice_org-help-en-GB, OpenOffice_org-help-en-US, OpenOffice_org-help-en-ZA, OpenOffice_org-help-es, OpenOffice_org-help-et, OpenOffice_org-help-fr, OpenOffice_org-help-gl, OpenOffice_org-help-gu-IN, OpenOffice_org-help-hi-IN, OpenOffice_org-help-hu, OpenOffice_org-help-it, OpenOffice_org-help-ja, OpenOffice_org-help-km, OpenOffice_org-help-ko, OpenOffice_org-help-nl, OpenOffice_org-help-pa-IN, OpenOffice_org-help-pl, OpenOffice_org-help-pt, OpenOffice_org-help-pt-BR, OpenOffice_org-help-ru, OpenOffice_org-help-sl, OpenOffice_org-help-sv, OpenOffice_org-help-zh-CN, OpenOffice_org-help-zh-TW, OpenOffice_org-icon-themes, OpenOffice_org-icon-themes-prebuilt, OpenOffice_org-impress, OpenOffice_org-impress-debuginfo, OpenOffice_org-impress-debugsource, OpenOffice_org-impress-devel, OpenOffice_org-impress-extensions, OpenOffice_org-impress-l10n-prebuilt, OpenOffice_org-kde, OpenOffice_org-l10n-af, OpenOffice_org-l10n-ar, OpenOffice_org-l10n-be-BY, OpenOffice_org-l10n-bg, OpenOffice_org-l10n-br, OpenOffice_org-l10n-ca, OpenOffice_org-l10n-cs, OpenOffice_org-l10n-cy, OpenOffice_org-l10n-da, OpenOffice_org-l10n-de, OpenOffice_org-l10n-el, OpenOffice_org-l10n-en-GB, OpenOffice_org-l10n-en-ZA, OpenOffice_org-l10n-es, OpenOffice_org-l10n-et, OpenOffice_org-l10n-extras, OpenOffice_org-l10n-extras-devel, OpenOffice_org-l10n-extras-prebuilt, OpenOffice_org-l10n-fi, OpenOffice_org-l10n-fr, OpenOffice_org-l10n-ga, OpenOffice_org-l10n-gl, OpenOffice_org-l10n-gu-IN, OpenOffice_org-l10n-he, OpenOffice_org-l10n-hi-IN, OpenOffice_org-l10n-hr, OpenOffice_org-l10n-hu, OpenOffice_org-l10n-it, OpenOffice_org-l10n-ja, OpenOffice_org-l10n-ka, OpenOffice_org-l10n-km, OpenOffice_org-l10n-ko, OpenOffice_org-l10n-lt, OpenOffice_org-l10n-mk, OpenOffice_org-l10n-nb, OpenOffice_org-l10n-nl, OpenOffice_org-l10n-nn, ...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.