dot on numeric pad shows as comma

Bug #194503 reported by Kemel Zaidan aka Legendario
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenOffice
Confirmed
Unknown
xkeyboard-config
Fix Released
Medium
libreoffice (Ubuntu)
Won't Fix
Undecided
Unassigned
openoffice.org (Ubuntu)
Won't Fix
Medium
Unassigned

Bug Description

Binary package hint: openoffice.org

I am using Ubuntu 7.10 and an ABNT2 keyboard, which is a qwerty keyboard to the Portuguese language. The difference is that it has a "ç" key, which is very used on the Portuguese language.

On OpenOffice, the dot on the numeric pad, shows a comma instead of a dot. The dot on the alphabetic section works fine tough. The version of the OpenOffice is 2.3.0 and this happens only on the it. Gedit, for example, works fine.

Revision history for this message
Chris Cheney (ccheney) wrote :

Does this problem only occur on OpenOffice for you? Also which version of the openoffice.org package do you have? Is it 1:2.3.0-1ubuntu5.3?

Thanks,

Chris Cheney

Changed in openoffice.org:
assignee: nobody → ccheney
status: New → Incomplete
Revision history for this message
Kemel Zaidan aka Legendario (kemelzaidan) wrote :

Yes, as I said, it happens only on OpenOffice. My version of the package is the 1:2.3.0-1ubuntu5.3 as well.

Thanks,

Kemel

Chris Cheney (ccheney)
Changed in openoffice.org:
assignee: ccheney → nobody
status: Incomplete → New
Revision history for this message
Chris Cheney (ccheney) wrote :

Do you still have this problem with openoffice.org 1:2.4.1-1ubuntu2 in Ubuntu 8.04?

Changed in openoffice.org:
status: New → Incomplete
Revision history for this message
Renato S. Yamane (renatoyamane) wrote :

This problem exist in OpenOffice.Org release.

This is a strange/stupid feature requested and accepted by developers:
http://www.openoffice.org/issues/show_bug.cgi?id=1820

A lot of NUMERIC KEYPAD have dot/period AND comma, but in OOo both keys send me the same output (comma).

This feature was requested 7 years ago, when an user say: "hey, my numeric keypad have a dot/period, but in my country we use comma as decimal separator".

But now, 7 years later, all keyboards have dot AND comma in numeric keypad. Developers forgot this, implement this feature requested by an user (dot key = comma), and now we have 2 keys (dot AND comma) and only one output (comma).

Best regards,
Renato S. Yamane
Brazil

Revision history for this message
Chris Cheney (ccheney) wrote :

Thanks for the update.

Changed in openoffice.org:
importance: Undecided → Medium
status: Incomplete → Triaged
Revision history for this message
Chris Cheney (ccheney) wrote :

I reopened the upstream bug to have someone there investigate the issue.

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Revision history for this message
Renato S. Yamane (renatoyamane) wrote :

This is brazilian numeric keypad layout:
http://img172.imageshack.us/img172/543/ptbrzu6.jpg

This is a en-us numeric keypad layout:
http://img141.imageshack.us/img141/5600/enusdj5.jpg

Best regards,
Renato S. Yamane

Revision history for this message
Rodrigo Messias Barros (rodrigomessiasbarros) wrote :

This problem happens to me. I'm using Ubuntu 8.10 (Intrepid) with OpenOffice.org 2.4.1. The problem also occurs with gedit, Gnome Console (terminal) and others.

The layout ABNT2 (Brazil) provides a dot "." on the numeric keypad, just below the "+" sign, as shown routed by Renato S. Yamane(see figure attached). But this is not working.

This problem never occurred to me in earlier versions of Ubuntu, only now.

I hope that this can be fixed because is very important the "." (dot) for the use of OpenOffice Calc, for example.

Regards,

(sorry, my english is poor).

Revision history for this message
Renato S. Yamane (renatoyamane) wrote :

As we can see in image attached in above post (Pt-BR with ABNT2 variant), this Keyboard have *dot* AND *comma*, but OOo recognized both as comma.

I really don't understand why the hell OOo developers agree with this (different keys sending same signal).
http://www.openoffice.org/issues/show_bug.cgi?id=1820

Best regards,
Renato S. Yamane

Changed in openoffice:
status: Unknown → Fix Released
Chris Cheney (ccheney)
Changed in openoffice:
status: Fix Released → Unknown
Changed in openoffice:
status: Unknown → Confirmed
Revision history for this message
In , Ander-c3sl (ander-c3sl) wrote :

Brazillian ABNT2 keyboards provides a comma and a dot key on the numeric keypad. The dot key has evdev keycode 129 and the comma key evdev keycode 91. If I understand correctly, the rules file adds +inet(evdev) to the symbols of that keyboard but inet(evdev) sets key I129 to symbol KP_Separator, overriding the previous br setting of KP_Decimal. This combination makes both keys output a comma. Removing the line

key <I129> { [KP_Separator] }

from the evdev section of /usr/X11/xkb/symbols/inet makes those keys behave correctly.

Revision history for this message
In , Sergey V. Udaltsov (svu) wrote :

After discussion on IRC, I am changing I129 to KP_Decimal in symbols/inet. Please check in git

Revision history for this message
realmagnum (realmagnum) wrote :

I would like to confirm this problem in a fresh install of Ubuntu Karmic Koala (9.10) with OpenOffice.org 3.1.1 OOO310m19 (Build:9420).

Is there any workaround for this?

It is impossible to use Calc and even Writer with a bad Keypad.

Revision history for this message
Renato S. Yamane (renatoyamane) wrote :

Some OOo developers don't live in a real world and think this bug .
They tell me that it is a "non-sense":
http://www.openoffice.org/issues/show_bug.cgi?id=1820

Revision history for this message
Rodrigo Messias Barros (rodrigomessiasbarros) wrote : Re: [Bug 194503] Re: dot on numeric pad shows as comma

Hello,

Yes, I confirm that the bug still persists in OOO310m19 OpenOffice.org 3.1.1
(Build: 9420).

regards,

Rodrigo Messias Barros
blogdodigao.wordpress.com
"The Massacre of Ads"

2010/2/24 realmagnum <email address hidden>

> I would like to confirm this problem in a fresh install of Ubuntu Karmic
> Koala (9.10) with OpenOffice.org 3.1.1 OOO310m19 (Build:9420).
>
> Is there any workaround for this?
>
> It is impossible to use Calc and even Writer with a bad Keypad.
>
> --
> dot on numeric pad shows as comma
> https://bugs.launchpad.net/bugs/194503
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The OpenOffice.org Suite: Confirmed
> Status in “openoffice.org” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: openoffice.org
>
> I am using Ubuntu 7.10 and an ABNT2 keyboard, which is a qwerty keyboard to
> the Portuguese language. The difference is that it has a "ç" key, which is
> very used on the Portuguese language.
>
> On OpenOffice, the dot on the numeric pad, shows a comma instead of a dot.
> The dot on the alphabetic section works fine tough. The version of the
> OpenOffice is 2.3.0 and this happens only on the it. Gedit, for example,
> works fine.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/openoffice/+bug/194503/+subscribe
>

Revision history for this message
Kemel Zaidan aka Legendario (kemelzaidan) wrote :

I have the impression it was gone on 3.0 but came back on 3.1.

Revision history for this message
Reynaldo Matos Hortensi (lasanhadeberinjela) wrote :

I have this bug since intrepid until lucid.

Revision history for this message
Kemel Zaidan aka Legendario (kemelzaidan) wrote :

Me too. Still an issue on lucid.

Changed in xkeyboard-config:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Angel Mass (angelmass) wrote :

Also have this problem in Ubuntu 10.10. notice it only happens in Open Office, other programs read it correctly as a dot instead of a comma

Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Kemel Zaidan aka Legendario, does this issue occur for you in LibreOffice?

Changed in libreoffice (Ubuntu):
status: New → Incomplete
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix
Revision history for this message
Björn Michaelsen (bjoern-michaelsen) wrote :
Changed in libreoffice (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.