[upstream] white spaces disappear beyond right margin

Bug #129403 reported by MagicNeophyte on 2007-07-31
74
This bug affects 7 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Wishlist
One Hundred Papercuts
Low
Unassigned
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Undecided
Björn Michaelsen
openoffice.org (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org

When the very end of a line (right margin) is reached, white spaces entered are not moved to the second line, but hidden from view. (Switch on non-printing characters to view.)
White spaces entered at the very beginning of an automatically line-wrapped second line are hidden beyond the end of the right margin of the previous line, only to reappear when the previous line is broken manually by a hard or soft return. When navigating with the arrow keys at the end of a line, the unseen presence of hidden white spaces may be noticed (You have to tap the arrow key as many times as there are spaces, in order to get the cursor to visibly move again).

To reproduce: Switch on non-printing characters. Enter a full line of text, right up to the right margin. Press enter to go to the line below. Input ten white spaces. Move to the beginning of the second line and press backspace. The spaces will disappear beyond the right margin, but you can still navigate them with the arrow keys.

This bug has been in previous versions of OO, and I have reported it before to the Open Office bugzilla site, a year or so ago. There turned out to be, I believe, five different related bug reports in the Open Office bug database. This bug breaks the WYSIWYG principle and also affects Tables. When a series of white spaces fill up more than one line in a table cell, they become invisible, beyond the right boundary of the cell.

Unfortunately, I do not have the knowledge to fix this bug. I think it has something to do with the line wrapping functions in OO. When more than one consecutive white space is detected, they should be put on the next line. A single space at the end of a line may conveniently be hidden when it cannot be displayed before the margin, but multiple spaces must be detected and moved to the second line.

Thanks for taking the time to read this. I know you are probably doing this on a voluntary basis, and I am grateful for that. But maybe this very basic text input bug can be given slightly higher priority. I would think many users run into problems with this, especially in large manually input documents (theses) it can be a real pain.

MagicNeophyte (magic-neophyte) wrote :

I found the bugzilla.openoffice.org bug number, which is 20878

see: http://qa.openoffice.org/issues/show_bug.cgi?id=20878

There are tons of comments that more narrowly define the problem!

Another issue that is claimed to be related is 64201

see: http://qa.openoffice.org/issues/show_bug.cgi?id=64201

Hope this helps.

description: updated
description: updated
Koen Beek (koen-beek) on 2007-11-17
Changed in openoffice.org:
status: New → Confirmed
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
status: Confirmed → Triaged

Very annoying bug, I hope it can be fixed soon.

Download full text (3.2 KiB)

I reported this too. You're right. Enabling the non-printing
characters is a good way to see it. If I make a line of type and then
near the end of the line start hitting the space bar, a few space
characters appear but then after about 5, they all disappear and the
cursor will not move until I hit a letter, which then appears at the
left-most margin on the next line, even if I have hit 20 spaces.

Or try this: Open a new doc and hit the space bar. You will be stopped
when you hit the end of the line. Actually the cursor bounces back to
the beginning of the line.

Peace,
Tom

On Wed, Mar 4, 2009 at 12:47 PM, NoBugs! <email address hidden> wrote:
> Very annoying bug, I hope it can be fixed soon.
>
> --
> [Upstream] [hardy] white spaces disappear beyond right margin
> https://bugs.launchpad.net/bugs/129403
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in The OpenOffice.org Suite: Confirmed
> Status in “openoffice.org” source package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: openoffice.org
>
> When the very end of a line (right margin) is reached, white spaces entered are not moved to the second line, but hidden from view. (Switch on non-printing characters to view.)
> White spaces entered at the very beginning of an automatically line-wrapped second line are hidden beyond the end of the right margin of the previous line, only to reappear when the previous line is broken manually by a hard or soft return. When navigating with the arrow keys at the end of a line, the unseen presence of hidden white spaces may be noticed (You have to tap the arrow key as many times as there are spaces, in order to get the cursor to visibly move again).
>
> To reproduce: Switch on non-printing characters. Enter a full line of text, right up to the right margin. Press enter to go to the line below. Input ten white spaces. Move to the beginning of the second line and press backspace. The spaces will disappear beyond the right margin, but you can still navigate them with the arrow keys.
>
> This bug has been in previous versions of OO, and I have reported it before to the Open Office bugzilla site, a year or so ago. There turned out to be, I believe, five different related bug reports in the Open Office bug database. This bug breaks the WYSIWYG principle and also affects Tables. When a series of white spaces fill up more than one line in a table cell, they become invisible, beyond the right boundary of the cell.
>
> Unfortunately, I do not have the knowledge to fix this bug. I think it has something to do with the line wrapping functions in OO. When more than one consecutive white space is detected, they should be put on the next line. A single space at the end of a line may conveniently be hidden when it cannot be displayed before the margin, but multiple spaces must be detected and moved to the second line.
>
> Thanks for taking the time to read this. I know you are probably doing this on a voluntary basis, and I am grateful for that. But maybe this very basic text input bug can be given slightly higher priority. I would think many users run into problems with this, especially in large manual...

Read more...

I have this problem also
How can this be fixed?

Chris Cheney (ccheney) wrote :

NoBugs!

No one claimed it was fixed, perhaps you don't know how to read bug statuses?

summary: - [Upstream] [hardy] white spaces disappear beyond right margin
+ [upstream] white spaces disappear beyond right margin
Jack Leigh (leighman) wrote :

Yes! Really annoying, and has hung around far too long =D

Confirmed, not fixed in Open Office 3.1 from launchpad PPA (jaunty).

But I have the impression some cosmetic tweaks have made it easier to deal
with.

magic-neophyte

> NoBugs!
>
> No one claimed it was fixed, perhaps you don't know how to read bug
> statuses?
>
> ** Summary changed:
>
> - [Upstream] [hardy] white spaces disappear beyond right margin
> + [upstream] white spaces disappear beyond right margin
>
> --
> [upstream] white spaces disappear beyond right margin
> https://bugs.launchpad.net/bugs/129403
> You received this bug notification because you are a direct subscriber
> of the bug.
>
>

Sense Egbert Hofstede (sense) wrote :

Thank you for taking the time to report this to the One Hundred Paper Cuts project. However, as you indicated yourself this issue is quite a complex bug report. A paper cut, in contrast, is a small usability issue that is easy to fix. This is most certainly not easy to fix, considering the first bug report on the OpenOffice tracker was from 2005. Therefore I'm marking this as Invalid for the One Hundred Paper Cuts project.

Don't worry, though, I'm NOT marking this Invalid as a bug report, I'm just declining it as a paper cut.

affects: hundredpapercuts → null
Changed in null:
status: New → Invalid

Hi All,

This is an EIGHT year old bug that got carried over from Open Office:

http://www.openoffice.org/issues/show_bug.cgi?id=20878
Opened: Wed Oct 8 11:23:00 +0000 2003

Basically, Writer does not show/allow spaces at the end of a line on text. It does not wrap spaces either.

Please fix this!

Many thanks,
-T

Platform / OS due to OOo report.

It problem is on windows and linux, 32 and 64. Last tested on Libreoffice 3.3.0.

on LibreOffice 3.3.1 still exist

Jack Leigh (leighman) on 2011-02-26
Changed in libreoffice (Ubuntu):
status: New → Triaged
Changed in df-libreoffice:
importance: Unknown → Wishlist
status: Unknown → Confirmed
tags: added: lo33

Created attachment 45888
Patch to display non printable characters

blank5.patch is implement the display of the the non printable characters till
the end of right margin.
It works only with left align (the rest aligns was unchanged)

One of the most big benefits of blank5.patch, is possible to edit non printable
character at the end of line (for example inserting new characters).

(In reply to comment #4)
> Created an attachment (id=45888) [details]
> Patch to display non printable characters

Please drop a note on the developer mailing list of this patch. Otherwise it won't reach the right developer. Thanks!

Changed in df-libreoffice:
status: Confirmed → In Progress
Changed in df-libreoffice:
status: In Progress → Fix Released
Marius B. Kotsbak (mariusko) wrote :

This is now fixed upstream in commit 4ee4892968d3e42efc03c1158bebfcdd7bb3249. It is not in any releases yet, but it cherry-picks nice to 3.3.2 version, so producing a patch for Ubuntu should be trivial.

tags: added: hundredpapercuts natty
affects: null → hundredpapercuts
Changed in hundredpapercuts:
status: Invalid → New
Ahmed Shams (ashams) wrote :

Fix Released in ​LibreOffice Productivity Suite as well as in HundredPaperCuts

Changed in hundredpapercuts:
importance: Undecided → Low
status: New → Fix Released
Marius B. Kotsbak (mariusko) wrote :

Hmm, but it is not fixed in Ubuntu yet, right?

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Committed
Changed in libreoffice (Ubuntu):
milestone: none → ubuntu-12.04-beta-1
assignee: nobody → Björn Michaelsen (bjoern-michaelsen)

Fixed as per upstream 3.5.0 released with precise.

Changed in libreoffice (Ubuntu):
status: Fix Committed → Fix Released
Marius B. Kotsbak (mariusko) wrote :

I still reproduce this in precise (LO 3.5.2.2).

*** Bug 44009 has been marked as a duplicate of this bug. ***

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.