[Upstream] [hardy] Writer page numbering offset not working

Bug #118935 reported by Juan Besada on 2007-06-06
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Low
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Wishlist
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org
1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in Writer is when one clicks Insert -> Field -> Page Numbers -> double click page number -> change offset from 0 to 6 -> OK button

-OR-

Insert -> Field -> Other -> Page -> Page Numbers -> Offset 6 -> Insert button

it shows the first Page Number object with 6 inside.

4) What happens instead is it shows a blank object.

WORKAROUND: click Format -> Paragraph -> Text Flow tab -> Insert checkbox checked -> With Page Style checkbox checked -> Page number combobox 6 -> OK button

dito10 (dadibo10) wrote :

In Open Office 2.3 Happens the same situation. The pages ho has a Greater number than the total number of real page don't is displayed.

Chris Cheney (ccheney) wrote :

Confirmed on upstream's openoffice.org 2.4.0~rc2

Changed in openoffice.org:
importance: Undecided → Low
status: New → Confirmed

It works but the 'proper' way to do it is so unintuitive that no regular user will probably ever find out how to do it.

I have opened a new bug about the fact the way to do it "properly" is very non-intuitive:

"go to the first paragraph on the first page (it can be a heading). Format -> Paragraph -> Text Flow. In part "Breaks" mark "Insert" and "With Page Style" and set the starting page number you want."

Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → Invalid
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
b (ben-ekran) wrote :

I confirm this.
Interesting that the page number field setting has an offset that is totally independent of the proper "Insert" method. If you specify an offset for both the offsets are added together.

Note I don't see anything in OO help about your suggested method, it just talking about inserting a field and using the offset.

I've attached a couple test documents for illustration.

b..

b (ben-ekran) wrote :
Chris Cheney (ccheney) wrote :

Well obviously it is confirmed as it is both Triaged in launchpad and has an upstream bug already attached to it that has been open for 5.5 years. :-( It is just that upstream doesn't feel like doing anything about it, as usual.

wolf84 (sciarroneangelo) wrote :

Confirmed at Open Office 3.0

Chris Cheney (ccheney) on 2010-05-13
tags: added: hardy

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/118935

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in Writer is when one clicks Insert -> Field -> Page Numbers -> double click page number -> change offset from 0 to 6 -> OK button

-OR-

Insert -> Field -> Other -> Page -> Page Numbers -> Offset 6 -> Insert button

it shows the first Page Number object with 6 inside.

4) What happens instead is it shows a blank object.

WORKAROUND: click Format -> Paragraph -> Text Flow tab -> Insert checkbox checked -> With Page Style checkbox checked -> Page number combobox 6 -> OK button

The meaning of the offset is: Do not show the actual page number but show the number of the page, that is 6 pages ahead. And if there is no such page, then nothing it shown.
The offset does not change the actual page number and was never intended to do so.

description: updated
summary: - [Upstream] [hardy] openoffice page numbering does not allow page offset
+ [Upstream] [hardy] Writer page numbering offset not working
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed

Juan Besada, after filing an upstream bug LibreOffice bug, it was brought to light that offset will only show the page desired if the number of pages placed in the offset actually exist. What I think you desire is that when one inserts page numbers, it gives the opportunity to define the page number without the LO/OOo restriction/definition, much like Word's procedure: Insert -> Page Numbers -> Format... button -> Start at: combobox 2 -> OK button -> OK button and notice numbering starts at page 2

If this is what you desire, please file an Enhancement bug with LibreOffice upstream requesting exactly this: https://bugs.freedesktop.org/enter_bug.cgi?product=LibreOffice

Otherwise, please mark this bug Invalid for both OpenOffice and LibreOffice.

Changed in libreoffice (Ubuntu):
importance: Medium → Wishlist
Changed in df-libreoffice:
status: Confirmed → Invalid
Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Closed upstream as INVALID, doing here too.

Changed in libreoffice (Ubuntu):
status: Triaged → Invalid

It seems there are no intuitive way to insert page numbers into text document with different starting number :(
LibreOffice developers, please change behavoir of Insert -> Field -> Other -> Page -> Page Numbers -> Offset to user-friendly.

Mantas Kriaučiūnas (mantas) wrote :

It seems there are no intuitive way to insert page numbers into text document with different starting number :(
"Official" WORKAROUND (Format -> Paragraph -> Text Flow tab -> Insert checkbox checked -> With Page Style checkbox checked -> Page number combobox) is not designed for users...

How we can help to fix this important problem?

Changed in df-libreoffice:
status: Invalid → Confirmed

Just tested https://bugs.freedesktop.org/show_bug.cgi?id=44689 and set that to "fixed" since it seems to work.

To offset a page number in LO you need at least as many pages in the document as which you want to offset.

worksforme:

* create writer document with 3 pages
* insert > Field (loose translation here!) > Page number
* double click page number
* enter correction (loose translation!) value of "1"

Page number should display 2 while inserted on first page

If you think this is bad behavior, please create a new bug with exact suggestions about what you would like to see improved and in what why that could be done.

Offset in general does work, so closing this very old bug.

Changed in df-libreoffice:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.