The OpenOffice.org Suite

[upstream] Impress shows black underline in Slide Show despite colored underline

Reported by jochrupp on 2007-04-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice Productivity Suite
Confirmed
Medium
OpenOffice
Confirmed
Unknown
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org-impress

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

OOo 2.x Impress (19.04.07)

3) What is expected to happen in LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/107854/+attachment/2143745/+files/underline.odp && loimpress -nologo underline.odp

the text with colored underlines should remain colored in Slide Show.

4) What happens instead is the underlines are black in Slide Show.

Chris Cheney (ccheney) on 2007-06-18
Changed in openoffice.org:
importance: Undecided → Low
status: Unconfirmed → Confirmed
Chris Cheney (ccheney) wrote :

Confirmed on upstream's openoffice.org 2.4.0~rc2

Chris Cheney (ccheney) on 2008-03-18
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → New
Changed in openoffice:
status: Unknown → Confirmed
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
Changed in openoffice:
status: Confirmed → Fix Released
Changed in openoffice:
status: Fix Released → Confirmed
summary: - [upstream] OOo 2.x Impress Bug: wrong colours in presentation mode
+ [upstream] Impress shows black underline in Slide Show despite colored
+ underline
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

Created attachment 47192
underline.odp

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/107854

OOo bug may be found at:
http://qa.openoffice.org/issues/show_bug.cgi?id=56520

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/107854/+attachment/2143745/+files/underline.odp && loimpress -nologo underline.odp

the text with colored underlines should remain colored in Slide Show.

4) What happens instead is the underlines are black in Slide Show.

tags: added: lo33
Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

Impress, for Thorsten?

[Reproducible] with Daily Build similar to "LibreOffice 3.4.1RC1 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:101)]". Also Overlining is affected as expected.

The problem also is visible for a WRITER text object in Presentation.

I modified Status to Assigned due to facts.

Changed in df-libreoffice:
status: Confirmed → In Progress

Confirmed with LibreOffice 3.3.3 Impress on Win XP & Linux Mandriva 2010 x86.

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.

Still present in LibreOffice 3.5.0rc3 (Mac OS X 10.6.8 Intel Core i5)
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735

On well-designed slides the black underlining can look quite ugly.

Also I use underline colors to provide a visual link to different elements in a drawing having the same color; but I have to use color lines instead (which have to be modified each time the text is edited and thus shifted) - annoying.
I'd give it a higher priority.

DavidEG (davideg) wrote :

Present also in LibreOffice 3.5.3.2 (Ubuntu) and LibreOffice 3.5.4.2 (Windows).
Moreover underline style is not shown propertly neither.

Underline color and style are ok when exporting to pdf.

Mozaic (mozaic) wrote :

Created attachment 73108
View on Slide Show mode: all text are black

Same problem with LibreOffice Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0) on Ubuntu 12.04 x86_64

Created attachment 73109
Noramal view with LibreOffice 4.0: text with color

This bug seems to be a bit confused:
status ASSIGNED with no assignee is unhelpful, back to new, CC Thorsten.

Changed in df-libreoffice:
status: In Progress → Confirmed

*** Bug 69475 has been marked as a duplicate of this bug. ***

Bug are still here T_T
Tested on Ubuntu 12.04 x86_64:
LibreOffice 4.2.0.0.beta2 (Build ID: 1a27be92e320f97c20d581a69ef1c8b99ea9885d ) and LibreOffice 4.1.4.2 (Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72)

Still here in LibreOffice 4.2.3.1
Build ID: 3d4fc3d9dbf8f4c0aeb61498a81f91c5b7922f13 on Ubuntu 12.04.4

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.