ERROR ? openerp: Failed to load server-wide module `web`.

Reported by Navaneeth Krishnan on 2012-03-02

This bug report was converted into a question: question #189411: ERROR ? openerp: Failed to load server-wide module `web`..

28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenERP Server
Undecided
Unassigned

Bug Description

1.this is how i start my server for version 6.1
navaneethk@DT01-015:/home1/navaneethk/6.1/server$ ./openerp-server --addons ../addons/
2.error while running the server is
2012-03-02 05:46:14,466 14741 INFO ? openerp: OpenERP version 6.1
2012-03-02 05:46:14,467 14741 INFO ? openerp: addons paths: /home1/navaneethk/6.1/addons
2012-03-02 05:46:14,467 14741 INFO ? openerp: database hostname: localhost
2012-03-02 05:46:14,467 14741 INFO ? openerp: database port: 5432
2012-03-02 05:46:14,467 14741 INFO ? openerp: database user: navaneethk
2012-03-02 05:46:14,468 14741 INFO ? openerp.service.netrpc_server: starting NET-RPC service on 0.0.0.0:8070
2012-03-02 05:46:14,469 14741 INFO ? openerp.netsvc: Starting 1 services
2012-03-02 05:46:14,476 14741 WARNING ? openerp.modules.module: module web: module not found
2012-03-02 05:46:14,476 14741 CRITICAL ? openerp.modules.module: Couldn't load module web
2012-03-02 05:46:14,477 14741 CRITICAL ? openerp.modules.module: unsupported operand type(s) for +: 'bool' and 'str'
2012-03-02 05:46:14,492 14741 ERROR ? openerp: Failed to load server-wide module `web`.
The `web` module is provided by the addons found in the `openerp-web` project.
Maybe you forgot to add those addons in your addons_path configuration.
Traceback (most recent call last):
  File "./openerp-server", line 252, in <module>
    openerp.modules.module.load_openerp_module(m)
  File "/home1/navaneethk/6.1/server/openerp/modules/module.py", line 407, in load_openerp_module
    zip_mod_path = mod_path + '.zip'
TypeError: unsupported operand type(s) for +: 'bool' and 'str'
2012-03-02 05:46:14,503 14741 INFO ? openerp.wsgi.core: HTTP service (werkzeug) running on 0.0.0.0:8069
2012-03-02 05:46:14,508 14741 INFO ? openerp: OpenERP server is running, waiting for connections...
2012-03-02 05:52:13,793 14741 INFO ? werkzeug: 192.109.209.176 - - [02/Mar/2012 05:52:13] "GET /web/webclient/home HTTP/1.0" 404 -
2012-03-02 05:52:13,861 14741 INFO ? werkzeug: 192.109.209.176 - - [02/Mar/2012 05:52:13] "GET /favicon.ico HTTP/1.0" 404 -
^C2012-03-02 05:55:13,816 14741 INFO ? openerp.netsvc: Stopping 1 services
2012-03-02 05:55:13,816 14741 WARNING ? openerp.service.netrpc_server: Netrpc: closing because of exception [Errno 9] Bad file descriptor
2012-03-02 05:55:14,077 14741 INFO ? openerp.service: Initiating shutdown
2012-03-02 05:55:14,077 14741 INFO ? openerp.service: Hit CTRL-C again or send a second signal to force the shutdown.

security vulnerability: yes → no
visibility: private → public
Amit Parik (amit-parik) wrote :

Hello,

You need to give a web addons path at server side like ./openerp-server --addons=../addons/,../openerp-web/addons/.

Because in latest OpenERP 6.1 and on, our 'web' module of web-addons is loaded as a base. So we must give a web addons
path on server side.
This is not a bug, So I am closing it.

Hope this will help you.

Thanks for understanding!

Changed in openobject-server:
status: New → Invalid

2012-07-07 21:23:38,306 22526 INFO ? openerp: OpenERP version 6.1
2012-07-07 21:23:38,306 22526 INFO ? openerp: addons paths: /srv/openerp/addons
2012-07-07 21:23:38,307 22526 INFO ? openerp: database hostname: localhost
2012-07-07 21:23:38,307 22526 INFO ? openerp: database port: 5432
2012-07-07 21:22:15,543 21219 INFO ? openerp: database user: fenris
2012-07-07 21:22:15,543 21219 INFO ? openerp.service.netrpc_server: starting NET-RPC service on 0.0.0.0:8070
2012-07-07 21:22:15,544 21219 INFO ? openerp.netsvc: Starting 1 services
/usr/lib/python2.7/dist-packages/babel/__init__.py:33: UserWarning: Module test was already imported from /srv/openerp/test/__init__.pyc, but /usr/lib/python2.7/dist-packages is being added to sys.path
  from pkg_resources import get_distribution, ResolutionError
2012-07-07 21:22:15,746 21219 INFO ? openerp.wsgi.core: HTTP service (werkzeug) running on 0.0.0.0:8069
2012-07-07 21:22:15,748 21219 INFO ? openerp.addons.web: embedded mode
2012-07-07 21:22:15,792 21219 WARNING ? openerp.modules.module:
Ambiguous import: the OpenERP module `crm` is shadowed by another
module (available at /usr/lib/python2.7/dist-packages/crm).
To import it, use `import openerp.addons.<module>.`.
2012-07-07 21:22:15,794 21219 CRITICAL ? openerp.modules.module: Couldn't load module web
2012-07-07 21:22:15,794 21219 CRITICAL ? openerp.modules.module: cannot import name crm
2012-07-07 21:22:15,795 21219 ERROR ? openerp: Failed to load server-wide module `web`.
The `web` module is provided by the addons found in the `openerp-web` project.
Maybe you forgot to add those addons in your addons_path configuration.
Traceback (most recent call last):
  File "./openerp-server", line 252, in <module>
    openerp.modules.module.load_openerp_module(m)
  File "/srv/openerp/modules/module.py", line 419, in load_openerp_module
    getattr(sys.modules['openerp.addons.' + module_name], info['post_load'])()
  File "/srv/openerp/addons/web/__init__.py", line 29, in wsgi_postload
    app = common.http.Root(o)
  File "/srv/openerp/addons/web/common/http.py", line 453, in __init__
    static_dirs = self._load_addons(openerp_addons_namespace)
  File "/srv/openerp/addons/web/common/http.py", line 523, in _load_addons
    m = __import__('openerp.addons.' + module)
  File "/srv/openerp/modules/module.py", line 139, in load_module
    mod = imp.load_module('openerp.addons.' + module_part, f, path, descr)
  File "/srv/openerp/addons/project_issue/__init__.py", line 23, in <module>
    import project_issue
  File "/srv/openerp/addons/project_issue/project_issue.py", line 22, in <module>
    from crm import crm
ImportError: cannot import name crm

ls /srv/openerp/addons | pastebinit -> http://paste.ubuntu.com/1080347/

addon web and crm is in the folder

Changed in openobject-server:
status: Invalid → New

Khairul,

I suspect there could be an issue of an access so CRM module is no being used by your user.

Thanks.

So is it possible you guide me to solve this issues ?

On Sun, Jul 8, 2012 at 2:21 PM, Serpent Consulting Services <
<email address hidden>> wrote:

> Khairul,
>
> I suspect there could be an issue of an access so CRM module is no being
> used by your user.
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/944573
>
> Title:
> ERROR ? openerp: Failed to load server-wide module `web`.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-server/+bug/944573/+subscriptions
>

Khairul,

Yes sure, do check all permissions and make sure all addons reside in addons directory.

Thanks.

Thanks ..
do please check this link ... all addon already inside the folder

http://paste.ubuntu.com/1080347/

On Mon, Jul 9, 2012 at 1:47 AM, Serpent Consulting Services <
<email address hidden>> wrote:

> Khairul,
>
> Yes sure, do check all permissions and make sure all addons reside in
> addons directory.
>
> Thanks.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/944573
>
> Title:
> ERROR ? openerp: Failed to load server-wide module `web`.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-server/+bug/944573/+subscriptions
>

im thinking i got the same problem with this:
http://www.openerp.com/forum/topic32913.html

its conflict with the pacemaker ... after rename the crm .. now its work !! thanks !

Hello Khairul Aizat Kamarudzzaman ,

As per your comment #8, I am closing this issue.

Thank you!

Changed in openobject-server:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers