User with admin rights can not configure EMail SMTP Server

Bug #929887 reported by Ferdinand

This bug report was converted into a question: question #187373: User with admin rights can not configure EMail SMTP Server.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Server (MOVED TO GITHUB)
Fix Committed
Low
OpenERP's Framework R&D

Bug Description

only admin can do this

Related branches

Revision history for this message
Vishal Parmar(Open ERP) (vpa-openerp) wrote :

Hello Dr.Ferdinand,

I think you have missed something, would you please assign your user to "Marketing/manager" group because If our user is "Marketing/Manager" then and then only he can send a mail. So If you want to configure outgoing main server then you must be assign a "Marketing/manager" group to your respective user.

As generalize way, in large organize only marketing manager can send a mail, so current behaviour is fine that's why we can not consider this as a bug.

Would you please look in to marketing_campaign 's csv file line #21.

Correct me If I am wrong.

Thanks.

Changed in openobject-addons:
status: New → Invalid
Revision history for this message
Ferdinand (office-chricar) wrote :

I am talking about CONFIGURE SMTP Server

I am sure that this is not the task of a marketing manger but of the admin or user with admin rights

sending mails works (hopefully) for everyone who has access to the crm and mail related forms and functions
* sales man
* invoice accountant
* etc

Changed in openobject-addons:
status: Invalid → New
Revision history for this message
Amit Parik (amit-parik) wrote :

Hello,

As per your comment#2, I am agree with you. We have to assign ir.mail_server ' rights to Admin/Access rights groups.

Thank you!

affects: openobject-addons → openobject-server
Changed in openobject-server:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → OpenERP's Framework R&D (openerp-dev-framework)
Revision history for this message
Twinkle Christian(OpenERP) (tch-openerp) wrote :

Hello,

Thanks For Reporting.

It has been Fixed in https://code.launchpad.net/~openerp-dev/openobject-server/trunk-bug-929887-tch

revno: 4255

It will be available in trunk soon.

Changed in openobject-server:
status: Confirmed → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions