can not import translation

Reported by Ferdinand on 2011-12-23
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenERP Server
Low
OpenERP's Framework R&D

Bug Description

Traceback (most recent call last):
  File "/home/srv/openerp/instances/trunk/openobject-server/openerp/service/netrpc_server.py", line 62, in run
    result = netsvc.dispatch_rpc(msg[0], msg[1], msg[2:])
  File "/home/srv/openerp/instances/trunk/openobject-server/openerp/netsvc.py", line 325, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)
  File "/home/srv/openerp/instances/trunk/openobject-server/openerp/service/web_services.py", line 580, in dispatch
    res = fn(db, uid, *params)
  File "/home/srv/openerp/instances/trunk/openobject-server/openerp/osv/osv.py", line 120, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/home/srv/openerp/instances/trunk/openobject-server/openerp/osv/osv.py", line 172, in execute
    res = self.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/srv/openerp/instances/trunk/openobject-addons/audittrail/audittrail.py", line 495, in execute_cr
    return fct_src(cr, uid, model, method, *args)
  File "/home/srv/openerp/instances/trunk/openobject-server/openerp/osv/osv.py", line 163, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/home/srv/openerp/instances/trunk/openobject-server/openerp/addons/base/module/wizard/base_import_language.py", line 66, in import_lang
    tools.trans_update_res_ids(cr)
AttributeError: 'module' object has no attribute 'trans_update_res_ids

Ferdinand (office-chricar) wrote :

def trans_load_data(cr, fileobj, fileformat, lang, lang_name=None, verbose=True, context=None):
    """Populates the ir_translation table. Fixing the res_ids so that they point
    correctly to ir_model_data is done in a separate step, using the
    'trans_update_res_ids' function below."""

there is no such function

Changed in openobject-server:
assignee: nobody → OpenERP's Framework R&D (openerp-dev-framework)
importance: Undecided → Low
status: New → Confirmed

Hello Ferdinand,

i have tested your issue with latest code but i am not able to reproduce it .it has fixed with recent changes.

will you please check with latest code,if you still face any problem reopen issue with more information.

revision no: 4255

Thanks,
Turkesh Patel

Changed in openobject-server:
status: Confirmed → Invalid
Amit Parik (amit-parik) wrote :

Hello Turkesh,

Again here the correct status should be "Fix released" not "Invalid".

Please open the http://wiki.openerp.com/index.php/RDBug and read the bug management policy.

Thank you!

Changed in openobject-server:
status: Invalid → Fix Released

Hello,

Sorry for inconvenient faced. Here issue has been fixed at following revison

 Revision No: 3951
 Revision ID: <email address hidden>

Thanks,
Turkesh Patel

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers