[1-line fix] 'invisible' attribute not allowed on a 'group' element

Reported by Francois Degrave on 2011-12-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenERP Server
Low
OpenERP's Framework R&D

Bug Description

Hi!

Everything is in the title. Works all fine with this 1-line fix in view.rng:

    <rng:define name="group">
        <rng:element name="group">
            <rng:ref name="overload"/>
            <rng:ref name="access_rights"/>
            <rng:optional><rng:attribute name="invisible"/></rng:optional>
            ...

Changed in openobject-server:
assignee: nobody → OpenERP's Framework R&D (openerp-dev-framework)
importance: Undecided → Low
status: New → Confirmed
summary: - 'invisible' attribute not allowed on a 'group' element
+ [1-line fix] 'invisible' attribute not allowed on a 'group' element
Cuong (bhcuong2008) wrote :

Hi Francois,

Could you tell me why this attribute is not allowed on group elements. Often, I need control 'visible' on the whole group, it's more convenient than controlling visible on each field.

Thank you,

Cuong (bhcuong2008) wrote :

I misunderstand your point.

Francois Degrave (fde-be) wrote :

Hi Cuong,

Precisely, I would like the invisible attribute to be allowed on a 'group' element, which is currently not the case because the rng does not allow it.

Hello,

This Bug is already solved in latest trunk version on revision no:4199 , revid:<email address hidden>

Thanks For reporting.

Thank You.

Changed in openobject-server:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers