OpenERP packages of the All-in-one installer do not honour installation directory

Bug #719905 reported by Stefan Rijnhart (Opener) on 2011-02-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Server (MOVED TO GITHUB)
Confirmed
Low
Stephane Wirtel (OpenERP)

Bug Description

Hi,

the OpenERP All-in-one installer for Windows, version 6.0.1 does not honour the installation directory for the OpenERP server, client and web client. Only the Postgresql database server and the uninstall script get installed in the custom directory. The reason for this is that the custom directory is passed to the underlying NSIS packages within quotes:

Execute: "C:\DOCUME~1\bla\LOCALS~1\Temp\openerp-client-setup-6.0.1-0.exe" /S /D="C:\OpenERP\6.0\Client"

The NSIS documentation states that the argument to the /D switch should not contain any quotes, even though the path contains spaces. Executing the command above without the quotes does indeed install the package in the stated directory.

Btw. filing this bug under 'OpenERP Server' as the Installer project does not allow for bugs to be filed.

Apologies, but I undid the marking of this bug as a duplicate of #307249, because the target bug is marked as "Fix released" (in 2008!) and I am not entitled to reopen it. Feel free to mark this bug as a duplicate again, but then at least *reopen* the target bug yourself.

Hello stefan,

Thanks for pointing out it and sorry for your inconvenience. I am confirming this issue as we are not able to install all the things like server, client, web client in custom directory chosen at the time of installation instead of default one.

Thanks for your participation.

Changed in openobject-server:
assignee: nobody → Stephane Wirtel (OpenERP) (stephane-openerp)
importance: Undecided → Low
status: New → Confirmed
GEM (nimp3) wrote :

Hi,
I found the problem,
following Nsis documentation :
http://nsis.sourceforge.net/Docs/Chapter3.html :

/D sets the default installation directory ($INSTDIR), overriding InstallDir and InstallDirRegKey. It must be the last parameter used in the command line and must not contain any quotes, even if the path contains spaces. Only absolute paths are supported.

in setup.nsi used to build allinone, in commands, there is quotes used with option /D for the path :
line 244 ExecWait '"$TEMP\${OPENERP_SERVER_SETUP}" /S /D="$INSTDIR\Server"'
line 264 ExecWait '"$TEMP\${OPENERP_CLIENT_SETUP}" /S /D="$INSTDIR\Client"'
line 271 ExecWait '"$TEMP\${OPENERP_WEB_SETUP}" /S /D="$INSTDIR\Web"'

just remove quotes and path choose in installation interface, is the real install path for installation :

ExecWait '"$TEMP\${OPENERP_SERVER_SETUP}" /S /D=$INSTDIR\Server'
ExecWait '"$TEMP\${OPENERP_WEB_SETUP}" /S /D=$INSTDIR\Web'
ExecWait '"$TEMP\${OPENERP_CLIENT_SETUP}" /S /D=$INSTDIR\Client'

Bye

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers