cannot login in my db and cannot create new db

Bug #592217 reported by tommy.snello on 2010-06-10
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Odoo Server (MOVED TO GITHUB)
Invalid
Undecided
Unassigned

Bug Description

after the today upgrade it's impossible create new db and (more important) log in to my exist db

[2010-06-10 14:46:49,510] ERROR:web-services:[01]:
[2010-06-10 14:46:49,510] ERROR:web-services:[02]: Environment Information :
[2010-06-10 14:46:49,510] ERROR:web-services:[03]: System : Linux-2.6.32-22-generic-pae-i686-with-Ubuntu-10.04-lucid
[2010-06-10 14:46:49,510] ERROR:web-services:[04]: OS Name : posix
[2010-06-10 14:46:49,510] ERROR:web-services:[05]: Distributor ID: Ubuntu
[2010-06-10 14:46:49,510] ERROR:web-services:[06]: Description: Ubuntu 10.04 LTS
[2010-06-10 14:46:49,511] ERROR:web-services:[07]: Release: 10.04
[2010-06-10 14:46:49,511] ERROR:web-services:[08]: Codename: lucid
[2010-06-10 14:46:49,511] ERROR:web-services:[09]: Operating System Release : 2.6.32-22-generic-pae
[2010-06-10 14:46:49,511] ERROR:web-services:[10]: Operating System Version : #36-Ubuntu SMP Thu Jun 3 23:14:23 UTC 2010
[2010-06-10 14:46:49,511] ERROR:web-services:[11]: Operating System Architecture : 32bit
[2010-06-10 14:46:49,511] ERROR:web-services:[12]: Operating System Locale : it_IT.UTF8
[2010-06-10 14:46:49,511] ERROR:web-services:[13]: Python Version : 2.6.5
[2010-06-10 14:46:49,511] ERROR:web-services:[14]: OpenERP-Server Version : 5.0.11
[2010-06-10 14:46:49,512] ERROR:web-services:[15]: Last revision No. & ID :
[2010-06-10 14:46:49,512] ERROR:web-services:[16]: CREATE DATABASE
[2010-06-10 14:46:49,512] ERROR:web-services:[17]: Traceback (most recent call last):
[2010-06-10 14:46:49,512] ERROR:web-services:[18]: File "/usr/local/lib/python2.6/dist-packages/openerp-server/service/web_services.py", line 92, in __call__
[2010-06-10 14:46:49,512] ERROR:web-services:[19]: tools.init_db(cr)
[2010-06-10 14:46:49,512] ERROR:web-services:[20]: File "/usr/local/lib/python2.6/dist-packages/openerp-server/tools/misc.py", line 46, in init_db
[2010-06-10 14:46:49,512] ERROR:web-services:[21]: f = addons.get_module_resource('base', 'base.sql')
[2010-06-10 14:46:49,512] ERROR:web-services:[22]: AttributeError: 'module' object has no attribute 'get_module_resource'

me too with Ubuntu 8.04, python 2.5, and x64

[2010-06-11 00:15:51,724] INFO:server:version - 5.0.11
[2010-06-11 00:15:51,724] INFO:server:addons_path - /usr/lib/python2.5/site-packages/openerp-server/addons
[2010-06-11 00:15:51,725] INFO:server:database hostname - localhost
[2010-06-11 00:15:51,725] INFO:server:database port - 5432
[2010-06-11 00:15:51,725] INFO:server:database user - openerp
[2010-06-11 00:15:51,725] INFO:objects:initialising distributed objects services
[2010-06-11 00:15:51,915] INFO:web-services:starting XML-RPC services, port 8069
[2010-06-11 00:15:51,915] INFO:web-services:starting NET-RPC service, port 8070
[2010-06-11 00:15:51,915] INFO:web-services:the server is running, waiting for connections...
[2010-06-11 00:17:13,454] INFO:web-services:CREATE DATABASE: test2
[2010-06-11 00:17:14,283] ERROR:web-services:[01]:
[2010-06-11 00:17:14,283] ERROR:web-services:[02]: Environment Information :
[2010-06-11 00:17:14,283] ERROR:web-services:[03]: System : Linux-2.6.24-24-server-x86_64-with-debian-lenny-sid
[2010-06-11 00:17:14,283] ERROR:web-services:[04]: OS Name : posix
[2010-06-11 00:17:14,283] ERROR:web-services:[05]: Distributor ID: Ubuntu
[2010-06-11 00:17:14,283] ERROR:web-services:[06]: Description: Ubuntu 8.04.4 LTS
[2010-06-11 00:17:14,284] ERROR:web-services:[07]: Release: 8.04
[2010-06-11 00:17:14,284] ERROR:web-services:[08]: Codename: hardy
[2010-06-11 00:17:14,284] ERROR:web-services:[09]: Operating System Release : 2.6.24-24-server
[2010-06-11 00:17:14,284] ERROR:web-services:[10]: Operating System Version : #1 SMP Fri Sep 18 16:47:05 UTC 2009
[2010-06-11 00:17:14,284] ERROR:web-services:[11]: Operating System Architecture : 64bit
[2010-06-11 00:17:14,284] ERROR:web-services:[12]: Operating System Locale : es_ES.UTF8
[2010-06-11 00:17:14,284] ERROR:web-services:[13]: Python Version : 2.5.2
[2010-06-11 00:17:14,284] ERROR:web-services:[14]: OpenERP-Server Version : 5.0.11
[2010-06-11 00:17:14,285] ERROR:web-services:[15]: Last revision No. & ID :
[2010-06-11 00:17:14,285] ERROR:web-services:[16]: CREATE DATABASE
[2010-06-11 00:17:14,285] ERROR:web-services:[17]: Traceback (most recent call last):
[2010-06-11 00:17:14,285] ERROR:web-services:[18]: File "/usr/lib/python2.5/site-packages/openerp-server/service/web_services.py", line 92, in __call__
[2010-06-11 00:17:14,285] ERROR:web-services:[19]: tools.init_db(cr)
[2010-06-11 00:17:14,285] ERROR:web-services:[20]: File "/usr/lib/python2.5/site-packages/openerp-server/tools/misc.py", line 46, in init_db
[2010-06-11 00:17:14,285] ERROR:web-services:[21]: f = addons.get_module_resource('base', 'base.sql')
[2010-06-11 00:17:14,285] ERROR:web-services:[22]: AttributeError: 'module' object has no attribute 'get_module_resource'

lvalenzu (lvalenzuelaj) wrote :

me too with Ubuntu 9.10, python 2.6, and x32

tommy.snello (tommy-snello) wrote :

no workaround?

Hello guys,

I have been using ubuntu 10.04 python 2.6, I do not face such a problem.
Make sure the directory structure is intact. Addons under server/bin should match the openERP directory structure.
If addons directory has ill-defined __init__.py, it may happen.

Kindly compare it with http://bazaar.launchpad.net/~openerp/openobject-server/5.0/files/head:/bin/addons/ . All listed files/directories should be there is a mimimum requirement.
Hope this helps.
Thanks.

Changed in openobject-server:
milestone: none → 5.0.12
status: New → Invalid
tommy.snello (tommy-snello) wrote :

perfect, i don't know why but the __init__.py was corrupt. i replaced with the right one and all it's ok.
thanks

Hi Tommy,

Could you please post a technical procedure to replace the corrupted file with a new one? I tried the following commands without success:

cd openerp-server/bin/addons
sudo rm __init__.py
wget http://bazaar.launchpad.net/~openerp/openobject-server/5.0/download/head:/svn2bzr-97f9e0778884e2d05e8cec86a35ae39d4dcb1cf0/__init__.py
cd ../../
sudo python setup.py install

Thanks in advance!!

tommy.snello (tommy-snello) wrote :

i copy the right __init__.py in the addons directory (for me is /usr/local/lib/python2.6/dist-packages/openerp-server/addons) and than restart openerp-server

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers