Import and Export use different translation

Bug #1081953 reported by Rudolf Schnapka on 2012-11-22
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Odoo Server (MOVED TO GITHUB)
Confirmed
Wishlist
OpenERP's Framework R&D

Bug Description

In a way this is related to reported bug:
#854037 export confusing column names
When exporting data "compatible to cvs" the system exports without translation (systems english)
when reimporting the same data, OpenERP expects all data in the currently selected language.
In my case using language german on a regular basis I need to switch to English before attempting to
re-import my modified (or even the untouched originally exported) products.products.csv

so: "compatible" Export and Import work in English but not "de_DE" language user-setting.
not checked, but I must assume that this is also an issue with any other language that needs translation.

I believe this is an easy fix. Maybe I will find my way to a solution soon (I'll check - no promise :-)

thank you...

Amit Parik (amit-parik) on 2012-11-26
affects: openobject-addons → openobject-server

Hello Rudolf Schnapka,

Good Suggestion, We can consider as a imporvement.So, that's why I setting this as wishlist.

Thanks for reporting..

Changed in openobject-server:
assignee: nobody → OpenERP's Framework R&D (openerp-dev-framework)
importance: Undecided → Wishlist
status: New → Confirmed
Paul Catinean (wiz-keed) wrote :

Is this basic issue any closer to being resolved? And to add to this problem, exporting in compatible-mode or any other for that matter does not bring up the translations of the name, still the english version

Rudolf Schnapka (rs-t3) wrote :

Sorry to have lost this issue out of focus. Had an employment switch with work in totally different area (FI/CO). Now I am back on OpenERP and will try to get back to this asap...
But I am still setting up my development hard and software and I have an SAP-project in parallel :-)
I'll dig into it though...

Rudolf Schnapka (rs-t3) wrote :

...and BTW:
When creating an Object that needs translation (like a product) this can (may) be created in native language. The translation to any other language must be done using untranslated english language. This is presumably is the origin for the import problem as well. Just a thought on my side...

Rudolf Schnapka (rs-t3) wrote :

This issue, in my understanding, is a bug:
In following simple scenarios it turn out that two paths to the same installation have different turn outs:
- clean install (1: In native english, no translations; 2: in some language i. e. DE_de translations)
- install mrp (as an example) in both scanarios
- install native translation DE_de in scenario 1 (english install)
This should turn out the same, but several menus are not, but most are translated properly. Where does the diffent behaviour come from?
From this aspect it can be assumed that a complete and correctly translated installation can only be acchieved in native english - so the user installing a module or in other cases exporting data (compatible export) for reimport MUST switch to native english at least before importing data (productive data as well as translations).
By means of switching the language the "translation-bug" can be circumvented. But what if i.e. some user is not capable of using the english language? Rare but might happen. OpenERP is intended for international use but certaily fails in this respect to be used purely in a foreign language...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers