developer mode doesn't work on Safari 8

Bug #1395059 reported by Bertrand Späth on 2014-11-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
A SYLEAM Component - OpenObject Library
Undecided
Unassigned

Bug Description

Both OpenERP 7 and Odoo 8 have problem with the developer mode. Here is the description:

OpenERP 7
Symptom: when activating the developer mode, you get the following error message if you go on settings > app:
TypeError: null is not an object (evaluating 'ClientWidget.prototype')
http://openerp.viija.com:8069/web/static/src/js/views.js:448

How to reproduce:
1. Login onto OpenERP 7
2. activate developer mode
3. go to settings > apps or settings > updates

Error console of Safari states:
[Error] TypeError: null is not an object (evaluating 'ClientWidget.prototype')
 (anonymous function) (views.js, line 448)

OpenERP log: no error shown

Odoo 8
Symptom: When activating the developer mode, you cannot use any module any more (no error message)

How to reproduce:
1. Login onto Odoo 8 (I did it with a managed instance)
2. activate developer mode
3. You only see the menu bar, no content any more

Error console of Safari states:
[Error] TypeError: undefined is not an object (evaluating 'instance.web_analytics.Tracker')
 saas_trial (saas_trial.js, line 132)
 init (boot.js, line 47)
 (anonymous function) (web, line 162)
 fire (jquery.js, line 974)
 fireWith (jquery.js, line 1084)
 ready (jquery.js, line 406)
 DOMContentLoaded (jquery.js, line 83)

Odoo log: no access (managed version)

Notes:
- This only happens on Safari, tested only V8
- Chrome and Firefox work fine
- Environment: MBP late '11 with Yosemite 10.10.1 on OpenERP 7.0-28cc90e
- OpenERP installed on Ubuntu 14.04.1 LTS

description: updated

Hi

Not related on this project

Regards,

Changed in openobject-library:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers