TypeError: value is of the wrong type for this column

Bug #718080 reported by Tristan Hill
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo GTK Client (MOVED TO GITHUB)
Fix Released
Undecided
OpenERP sa GTK client R&D
openerp-client (Ubuntu)
Undecided
Unassigned

Bug Description

Steps
* install openerp gtk client (6.0 branch revno 1808) on ubuntu 11.04
* login to server

Get following traceback:
Traceback (most recent call last):
  File "/home/stan/src/openerp/6.0/client/bin/openerp-client.py", line 135, in <module>
    win.sig_login()
  File "/src/openerp/6.0/client/bin/modules/gui/main.py", line 1029, in sig_login
    id = self.sig_win_menu(quiet=False)
  File "/src/openerp/6.0/client/bin/modules/gui/main.py", line 1145, in sig_win_menu
    res = self.sig_win_new(widget, type='menu_id', quiet=quiet)
  File "/src/openerp/6.0/client/bin/modules/gui/main.py", line 1168, in sig_win_new
    obj.execute(act_id, {'window':self.window})
  File "/src/openerp/6.0/client/bin/modules/action/main.py", line 82, in execute
    self._exec_action(res,datas,context)
  File "/src/openerp/6.0/client/bin/modules/action/main.py", line 143, in _exec_action
    limit=datas['limit'], auto_refresh=datas['auto_refresh'], auto_search = datas['auto_search'], search_view = datas['search_view'])
  File "/src/openerp/6.0/client/bin/modules/gui/window/__init__.py", line 66, in create
    window=window, name=name)
  File "/src/openerp/6.0/client/bin/modules/gui/window/tree.py", line 105, in __init__
    self.sig_reload()
  File "/src/openerp/6.0/client/bin/modules/gui/window/tree.py", line 112, in sig_reload
    self.tree_sc.update()
  File "/src/openerp/6.0/client/bin/modules/gui/window/view_tree/view_tree_sc.py", line 61, in update
    self.COLUMN_ID, s['id']
TypeError: value is of the wrong type for this column

The treestore object in ubuntu 11.04 appears to be strict about the values that it accepts. Presumably this is due to a newer pygtk and/or gtk version. Similar problems have occurred with other pygtk apps; https://bugs.launchpad.net/ubuntu/+source/meld/+bug/703603.

Related branches

Changed in openobject-client:
status: New → Triaged
Changed in openobject-client:
assignee: nobody → OpenERP sa GTK client R&D (openerp-dev-gtk)
Revision history for this message
tfr (Openerp) (tfr) wrote :

It would be nice to have a client that works on last version of ubuntu before the release

Changed in openobject-client:
status: Triaged → Incomplete
status: Incomplete → Confirmed
Changed in openobject-client:
status: Confirmed → Fix Committed
tfr (Openerp) (tfr)
Changed in openobject-client:
status: Fix Committed → Fix Released
Revision history for this message
Mario Sánchez Prada (mariospr) wrote :

This is still failing for me with exactly the same trace with revision 1866 from bzr repository.

Am I missing something?

Revision history for this message
Naresh(OpenERP) (nch-openerp) wrote :

what's your ubuntu version ?

Tristan Hill (stan)
Changed in openerp-client (Ubuntu):
status: New → Invalid
Revision history for this message
Mario Sánchez Prada (mariospr) wrote :

At the moment I'm not using ubuntu in this machine but Fedora 14, so I'd say versions of the dependencies would be pretty much the same (or quite similar) than in ubuntu maverick. In more detail:

 glib2-2.26.0
 gtk2-2.22
 pygobject2-2.21.5
 pygtk2-2.17
 pygtk2-libglade-2.17
 python-2.7-8

I now it's weird to file a bug in launchpad when it was reproduced in fedora, but as I got the code from the bazaar repo in launchpad I thought it was the proper place to do it, specially after finding exactly the same problem reported here.

But if you feel like this is not the proper place for me to ask just let me know and I'll do it in any other place :-)

Last, but not least, I think I could try to reproduce it in a ubuntu environment using a KVM image but that would take me more time which I'mlacking right now, so let's see if we can fix it this way first.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers