install problem x86_64 wrong path

Bug #301561 reported by Ferdinand on 2008-11-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo GTK Client (MOVED TO GITHUB)
Fix Committed
Undecided
Stephane Wirtel (OpenERP)

Bug Description

I had to change
/usr/bin/openerp-client

to run on x86_64

- cd /usr/lib/python2.5/site-packages/openerp-client
+ cd /usr/lib64/python2.5/site-packages/openerp-client

IMHO the "setup.py build" should detect x86_64 automatically and create correct scripts

Changed in openobject-client:
assignee: nobody → matrixise
Changed in openobject-client:
status: New → Confirmed

I have a x86_64 and I tested with a very small setup.py, the setuptools does not install the script to /usr/lib64 but only to /usr/lib.

Ferdinand (office-chricar) wrote :

Hmm!
Isn't this what I reported?

yes, but I wanted to know why not in /usr/lib64, but now I think it is specific to setuptools ( the composent used in the setup.py file ).

But your bug is interesting because if you want to test OpenERP in your home directory, for example $HOME/local, the script was not right. I will fix that as soon as possible.

Changed in openobject-client:
status: Confirmed → Fix Released
Ferdinand (office-chricar) wrote :

resurrected in trunk revno 997

Changed in openobject-client:
status: Fix Released → New
Changed in openobject-client:
status: New → Triaged
tfr (Openerp) (tfr) wrote :

should be fix in lp:~tfr/openobject-client/tfr-packaging, but anyway i've also a x86_64 system and everything is installed in /usr/lib

Changed in openobject-client:
status: Triaged → Fix Committed
Ferdinand (office-chricar) wrote :

@tfr "everything is installed in /usr/lib"
this is interesting - OpenSuSE provides separate python version for x86 and x86_64 installed in /usr/lib and /usr/lib64

On Monday 17 January 2011, you wrote:
> @tfr "everything is installed in /usr/lib"
> this is interesting - OpenSuSE provides separate python version for x86 and
> x86_64 installed in /usr/lib and /usr/lib64

Can't be..

The rule, in short is that python packages that don't contain platform specific
files go to /usr/lib/python2.x, while python packages that also contain
binaries (libxx.so etc. ) go to /usr/lib64/python2.x

It might be that /usr/lib/python2.5 and /usr/lib/python2.6 co-exist in such a
Linux distribution, but this is another issue. We only want to support the
version which has most packages available (usually 2.6, the other is just
there for compatibility).

--
Say NO to spam and viruses. Stop using Microsoft Windows!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers