6.1 : multiple process under windows 7

Bug #1052948 reported by Natanaël on 2012-09-19
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Odoo GTK Client (MOVED TO GITHUB)
Confirmed
Low
OpenERP Publisher's Warranty Team

Bug Description

Hello.

We are experiencing a new bug since we migrate to OpenERP 6.1.
We installed the nightly build client from 17th, july of this year.

1) Steps to reproduce the issue you have observed :

When we close the client, the GUI close. But a process remain, you can see it with the task gestionary.
If you repeat this operations about 10 times without cleaning the task gestionary/shuting down/rebooting your computer, you'll have 10 openerp-client processes. (see atached picture).

2) The result you observed

You have as many openerp-client in your task manager, as you opened openerp-client.

3) The result you expected

Only one process must be seen in the task manager while you use openerp client. When you close the client, the process must be shutting down.

4) The platform your are using

We are using windows 7 pro.
I tried to reproduce the problem using windows XP pro : there's no problem.

5) The OpenERP version you are using

I tried withe the nightly build client version of the 17th of July, 2012 and yesterday's version

Our users reported us this bug because, they were experiencing some bugs in copy/paste on Excel. Stoping the multiple openerp-client process solve the problem.

Natanaël (nglacet) wrote :
Changed in openobject-client:
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
tags: added: maintenance

Hello Natanaël,

I have checked the issue with latest version of GTK-Client downloaded from http://nightly.openerp.com/6.1/nightly/exe/ and I didn't face the problem mentioned in this bug report. Unfortunately, I couldn't find client built of 17th, july, so, I tested on build of 1st Aug from the nightly build link, and the result of that client is as expected.

I checked the same issue with two different machines having windows 7 Ultimate(32bit) and I noticed same behavior, that is, when I close the GTK-Client window, respective process ends.

I have prepared a video for you that shows my end behavior, please go through the video attached.

I would suggest you to check this issue in another machine having windows 7 environment just to be sure that it's not the issue for a specific machine and share the behavior with me you observed in anther machine.

Thanks.

Changed in openobject-client:
status: New → Incomplete

Hello Natanaël,

On further testing, on windows 7 64-bit machine, I'm able to face the issue. Hence, I am confirming the issue. I also checked with OpenERP V6.0 GTK-Client on the same machine, and I didn't face the issue in V6.0.

It seems like it's an upstream bug from the packages that are used to build OpenERP V6.1 GTK-Client for windows.

Thanks.

Changed in openobject-client:
status: Incomplete → Confirmed
importance: Undecided → Low
filsys (office-filsystem) wrote :

We are experiencing this bug also on windows 7 32-bit machine.
Thanks.

Rudolf Schnapka (rs-t3) wrote :

We have this issue too on Win7x64.
greetings

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers