OpenERP Web Client

onchange data for reference field

Reported by sinoj on 2011-02-01
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenERP Web Client
Status tracked in 6.0
6.0
Low
OpenERP Publisher's Warranty Team

Bug Description

Hello,
 When I try to populate a reference field from an on change event, it do not work on webclient but works on GTK client.
This is how I pass the data on onchanage

{'value': {'<field name>': '<model name>,id'}}

I used the format
'<model name>,id'
for default value for a reference field and its working on both Web and GTK client

Hope someone will have make a response on this issue.
thx

sinoj (sinojsebastian) on 2011-02-01
security vulnerability: yes → no
visibility: private → public
DBR (OpenERP) (dbr-openerp) wrote :

Hello,

Have you customized the code?
Would you please elaborate more?
And If you use any existing module than please explain.
So,It will be helpful for us for qualification of this.

Thanks.

Changed in openobject-client-web:
status: New → Incomplete
sinoj (sinojsebastian) wrote :

Hello Devishree Brahmbhatt,
   Thank you for the response. This problem is getting very critical for our project.
We have a reference field on a form (on our module). This field is supposed to be filled by an onchange event from another field on the same form. After the onchange function is called, it successfully fill other fields but this reference field. This reference field will be filled if I test this with a GTK client. That means, I have the issue with Webclient only.

To recreate the issue, you will need one reference field on the form, and onchnage on another field. fill the reference field with value form onchange. the reference field will be filled if you are testing from GTK and will not be filled if you are testing form

Please mail me if you need the maintenance contract details.

sinoj (sinojsebastian) wrote :

Hello Devishree Brahmbhatt,
  I'm attaching a simple module that you can use to test the issue which I was mentioning.

Sinoj

DBR (OpenERP) (dbr-openerp) wrote :

Hello Sinoj,

Thanks for the attached module.
Can you please contact maintenance team by " <email address hidden> " ?

Thanks.

Changed in openobject-client-web:
assignee: nobody → OpenERP SA's Web Client R&D (openerp-dev-web)
importance: Undecided → Low
status: Incomplete → Confirmed
summary: - [6.0.1] onchange data for reference field
+ onchange data for reference field
Vaibhav Darji (vaibhav-openerp) wrote :

Hello Sinoj,

Fixed in Trunk 6.0:
revision:4565 <email address hidden>

Please update your Trunk 6.0.

Thanks.

Changed in openobject-client-web:
status: Confirmed → Fix Released
sinoj (sinojsebastian) wrote :

Thank you verymuch. The issue is resolved and you can close this bug report :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers