[6.0] Infinite screen refresh loop when adding to one2many field

Bug #884755 reported by Craig Gowing (credativ) on 2011-11-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Web Client
Undecided
Unassigned

Bug Description

Steps to reproduce:
1) Create a new record on any form view which contains a one2many field.
2) Fill in all required fields correctly
3) Fill in an other field so it will have a validation error (eg invalid date in date field)
4) Create a new line in the one2many field

Then what occurs is an interesting loop:
- The one2many field will require that the record is saved before it can handle the request, this will invoke the save procedure.
- The save procedure will fail validation and return HTML containing the validation error.
- The save request contained info to show that the one2many field was trying to add a new line so the HTML returned contains JS to start creating a new line.
- The one2many field will require that the record is saved before it can handle the request... etc.

Please see proposed merge request for the fix we are using.

Related branches

Hello Craig,

I have checked this issue at my end with
stable 6.0 but I did not face any problem like
Infinite screen refreshing so would you please
provide more information like video or screen shot.

Thanks and waiting for replay.

Changed in openobject-client-web:
status: New → Incomplete

Hi Jignesh,

Thanks for looking into this bug. I have attached a video of how I can trigger this bug consistently.

Thanks,
Craig

Hello Craig ,

Thanks a lot for reporting this bug and contributing to OpenERP. Unfortunately the OpenERP Web Client project is not going to be developed further after the 6.0 series. As of 6.1 a newer and better web frontend known as the OpenERP Web project[1] will be available.
Our R&D developers normally work in Launchpad to fix bugs for the next release, but there will be no next release for the current OpenERP Web Client. As our resources are limited, all further R&D efforts from the Web team are dedicated to finish the new 6.1 OpenERP Web project[1].
This bug will be closed as "Won't Fix" to show that R&D won't be able to work on it.
Bugs affecting customers in production of course continue to be handled via the OpenERP Enterprise (OPW) maintenance service, and this is the recommended way to have them corrected directly in the 6.0 LTS stable branch.
You can find more details about all of this in the FAQ of our Bug Management Policy documentation[2].
If you are interested, you should soon be able to beta-test the new OpenERP Web 6.1 (this will be announced on OpenERP Community channels).

Thank you for your contributions and for your understanding!

Changed in openobject-client-web:
status: Incomplete → Won't Fix

This affects credativ Ltd (OpenERP UK partner) customers in production.

The fix has already been provided.

Please merge into 6.0.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers