tree "unlimited" option only displayed the 50 records

Bug #795704 reported by Olivier Lenoir on 2011-06-10
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Odoo Web Client
Low
OpenERP R&D Web Team

Bug Description

V6 went with the possibility to display trees with 20, 50, 100, 500 and unlimited ids, the latest (2011-06-09) version of web/addons/openerp/widgets/pager.py seems to overcome this option. If you choose "unlimited" 50
lines are displayed. But you still may display 500 lines...
The source shows this modification : from "UNLIMITED = -1" to "UNLIMITED = False"
Is-it a bug or a decision to actually limit the lines displayed ?

Related branches

Amit Parik (amit-parik) on 2011-06-16
summary: - tree "unlimited" option unavailable
+ tree "unlimited" option only displayed the 50 records
Changed in openobject-client-web:
assignee: nobody → OpenERP R&D Web Team (openerp-dev-web)
importance: Undecided → Low
status: New → Confirmed
Amit Parik (amit-parik) wrote :

Hello,

I have checked this issue it has already discussed in lp ago So please see this bug #713934 and bug #699960.

Before the "unlimited" search has not worked totally due to the speed problem we have set that the only 50 records are displayed in "unlimited" but which is not proper solution because if we are displayed only 50 record in "unlimited" then it will also misleading when user exported the record by using "unlimited" search limit please also see this bug #792754.

As per my opinion we have to display maximum record in "unlimited" search option either display all record or maximum like 500.

Thanks

Hello,

That's mean it is a decision, not a bug.
An evolution could be :
maxrecords = xxxx
if "unlimited"
    if number_of_records more than maxrecords
         display "number of records for this object is too large %", number_of_records
         ask_user "Set a filter to reduce the number of records"

Thanks

Navrang Oza (noz-tiny) on 2011-06-20
Changed in openobject-client-web:
status: Confirmed → In Progress
Navrang Oza (noz-tiny) wrote :

Hello,

Its not any decision, Its a mistake which generated because of solving another problem.
It has been solved now.

Thanks for reporting.

Changed in openobject-client-web:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers