O2Ms nested in O2M form can not be used if the O2M form object has no mandatory attribute

Bug #720173 reported by Xavier (Open ERP) on 2011-02-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Web Client
Medium
OpenERP R&D Web Team

Bug Description

1. Install a database with base_contact

2. Go to Sales > Address Book > Customers and create a new customer

3. Set a customer name and save (via Save and Edit)

At this point, the contacts o2m not editable (and neither should the Address o2m be: the background is that of non-editable and there is a readonly field attribute set, but it's still editable)

4. Click [New] next to address

5. Click [New] next to contacts

Expected:
Should create a new line in Contacts so it's possible to create a contact for the address

Observed:
Reloads the form over and over and over

Note that if you enter anything in a field of address (even though it's not required) then it will work.

The problem is that the address is not created because all its fields are empty (as per addons/openerp/utils/utils.py line 70), and so the contacts o2m tries to create its line even though there is no parent (because the address was not created).

Of course the fix was probably included to stop creating e.g. empty addresses every time you created a customer in the first place...

Related branches

Changed in openobject-client-web:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → OpenERP SA's Web Client R&D (openerp-dev-web)
Changed in openobject-client-web:
status: Confirmed → In Progress
Jiten (OpenERP) (jiten-openerp) wrote :

It has been fixed in lp:~openerp-dev/openobject-client-web/trunk-bug-720173-jra.

revision-info:
4627 <email address hidden>

Thanks.

Changed in openobject-client-web:
status: In Progress → Fix Committed
Changed in openobject-client-web:
milestone: none → 6.0.2
milestone: 6.0.2 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers