REGRESSION - The path '/error/HTTP_INTERNAL_SERVER_ERROR.html.var' was not found.

Bug #599299 reported by Ferdinand on 2010-06-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Web Client
Undecided
Amit Mendapara

Bug Description

rev 2879
saving I get this error
the "var" at the end seems to cause the problem
/error/HTTP_INTERNAL_SERVER_ERROR.html.var

reverting back to 2658 (arbitrarily selected from a working installation) solves the problems

Navrang Oza (noz-tiny) wrote :

Hello,

Can you describe when you are getting this error ?
How can we generate this error ?
Thanks.

Ferdinand (office-chricar) wrote :

at various occasions now
example
add partner contact (with installed base_contact) in line mode
save the contact - click cancel

or (better) edit partner - switch contact to form - new contact -> error

it's sort of random

Navrang Oza (noz-tiny) on 2010-06-28
Changed in openobject-client-web:
status: New → Confirmed
Navrang Oza (noz-tiny) wrote :

Hello,

We are testing in latest stable server, web client.
and we are getting error for "write concurrency" error, but not same like your one.
We will try to solve it and will let you update accordingly.

Thanks for reporting.

Ferdinand (office-chricar) wrote :

"write concurrency" happened here to, but I thought it was me modifying something twice

Navrang Oza (noz-tiny) on 2010-06-29
Changed in openobject-client-web:
status: Confirmed → In Progress
Sananaz (Open ERP) (sma-tiny) wrote :

Hello Ferdinand,

I have tested your problem, But still i am not able to generate the error.

I have Followed these steps:
- Created new DB with base_contact
- Went to partner, edited partner contact
- Switched contact to form
- Clicked on new contact (Here getting concurrency error but after resolving concurrency problem, I am not facing any error and its working fine.)

So can you send us the traceback of your error so that we can judge where does the error come from?
I would like to know whetger you have added any dependancies.

I have investigated and it seems like error comes from Apache server.
Have you enabled both mod_proxy and mod_proxy_http?

Let us know more specific information, so we can get rid of this problem.

Thank you.

Ferdinand (office-chricar) wrote :

thanks for looking into this
I was able to access the server via http in the local network, but not from outside via https - after restart of apache2 everything works again. (could have thought to try this earlier)

Changed in openobject-client-web:
status: In Progress → Invalid
Changed in openobject-client-web:
milestone: none → 5.0.12
Changed in openobject-client-web:
status: Invalid → New
Ferdinand (office-chricar) wrote :

have to reopen:

do not see a pattern yet :-(

Ferdinand (office-chricar) wrote :

following the instructions here - it seems to work now

http://doc.openerp.com/install/linux/web/index.html

BUT please add that

RequestHeader set "X-Forwarded-Proto" "https"

must be added here

# Make sure proxies don't deliver the wrong content
<IfModule mod_headers.c>
    Header append Vary User-Agent env=!dont-vary # Do not know if really needed - just found it here
    RequestHeader set X-Forwarded-Proto https
</IfModule>

and NOT in the
<VirtualHost *:443>
section - putting it here prohibits to start apache

I also suggest to add a link pointing to
http://doc.openerp.com/install/linux/web/index.html
into README.txt

Ferdinand (office-chricar) wrote :
Download full text (5.4 KiB)

sorry to be not more precise - stil not able to fin a pattern

unfortunately not immediately

it seems that after restart some variables are not initialized. just a guess ???

opening a form - the first search fails - back and search again works.

saving an edited form in my current tasks I get
A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: https://openerp.chricar.at/static/javascript/master.js:73

could it be the long URL issue mentioned in
https://bugs.launchpad.net/bugs/522135

using apache2-2.2.8-28.8 on openSUSE 11.0 (X86-64)
Linux cc-187 2.6.25.5-1.1-default #1 SMP 2008-06-07 01:55:22 +0200 x86_64 x86_64 x86_64 GNU/Linux
branch-server r 2066
web-client r 2880

in http_error.log:
[Wed Jul 07 19:03:32 2010] [error] (103)Software caused connection abort: proxy: pass request body failed to 192.168.160.187:8080 (192.168.160.187)
[Wed Jul 07 19:03:32 2010] [error] (103)Software caused connection abort: proxy: pass request body failed to 192.168.160.187:8080 (192.168.160.187) from 10.147.160.176 ()
[Wed Jul 07 19:03:32 2010] [error] proxy: client 10.147.160.176 given Content-Length did not match number of body bytes read
[Wed Jul 07 19:03:32 2010] [error] (70014)End of file found: proxy: pass request body failed to 192.168.160.187:8080 (192.168.160.187) from 10.147.160.176 ()
[Wed Jul 07 19:03:32 2010] [error] [client 10.147.160.176] Handler for proxy-server returned invalid result code 70014, referer: https://openerp.chricar.at/form/edit?model=project.task&id=91&ids=%5B91%5D&view_ids=%5BFalse%2C%20False%2C%20False%2C%20False%5D&view_mode=%5Bu%27tree%27%2C%20u%27form%27%2C%20u%27calendar%27%2C%20u%27graph%27%5D&domain=%5B(%27user_id%27%2C%20%27%3D%27%2C%205)%2C%20(%27state%27%2C%20%27in%27%2C%20(%27open%27%2C%20%27draft%27))%5D&context=%7B%27lang%27%3A%20u%27en_US%27%2C%20%27tz%27%3A%20u%27Europe%2FVienna%27%2C%20%27_terp_view_name%27%3A%20u%27My%20Current%20Tasks%27%2C%20%27client%27%3A%20%27web%27%2C%20%27active_ids%27%3A%20%5B271%5D%2C%20%27active_id%27%3A%20271%7D&offset=0&limit=20&count=1&search_domain=%5B(%27user_id%27%2C%20%27%3D%27%2C%205)%2C%20(%27state%27%2C%20%27in%27%2C%20(%27open%27%2C%20%27draft%27))%2C%20(%27name%27%2C%20%27ilike%27%2C%20%27debug%27)%5D

Traceback (most recent call last):
  File "/home/terp/OpenERP/branch/server/5.0/bin/netsvc.py", line 247, in dispatch
    result = LocalService(service_name)(method, *params)
  File "/home/terp/OpenERP/branch/server/5.0/bin/netsvc.py", line 76, in __call__
    return getattr(self, method)(*params)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/audittrail/audittrail.py", line 363, in execute
    return self.log_fct(db, uid, passwd, model, method, fct_src, *args)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/audittrail/audittrail.py", line 256, in log_fct
    res =fct_src( db, uid, passwd, object, method, *args)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/base_module_record/base_module_record.py", line 38, in execute
    res = super(recording_objects_proxy, self).execute(*args, **argv)
  File "/home/terp/OpenERP/branch/server/5.0/b...

Read more...

Ferdinand (office-chricar) wrote :
Download full text (4.4 KiB)

So I tried some more

* the first filter action very often (allways?) after login fails
** workaround: click back and filter again
** sometimes also this
****
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, root@cc-187 and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
-->
[Wed Jul 07 21:51:59 2010] [error] (103)Software caused connection abort: proxy: pass request body failed to 192.168.160.187:8080 (192.168.160.187) from <my external ip> ()
[Wed Jul 07 21:51:59 2010] [error] proxy: clien <my external ip> given Content-Length did not match number of body bytes read
****
** same workaround: click back and filter again

after switching from simple query to advanced the same error occures ONCE again

IMPORTANT - IMHO this happens only once after restart of the openerp web-client
Can logout and login, close firefox - everythink works fine

special problematic form : my current tasks
first query fails
/error/HTTP_INTERNAL_SERVER_ERROR.html.var
back + require - works
click edit of one line
enter some text into Information tab - notes + save

Traceback (most recent call last):
  File "/home/terp/OpenERP/branch/server/5.0/bin/netsvc.py", line 247, in dispatch
    result = LocalService(service_name)(method, *params)
  File "/home/terp/OpenERP/branch/server/5.0/bin/netsvc.py", line 76, in __call__
    return getattr(self, method)(*params)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/audittrail/audittrail.py", line 363, in execute
    return self.log_fct(db, uid, passwd, model, method, fct_src, *args)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/audittrail/audittrail.py", line 256, in log_fct
    res =fct_src( db, uid, passwd, object, method, *args)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/base_module_record/base_module_record.py", line 38, in execute
    res = super(recording_objects_proxy, self).execute(*args, **argv)
  File "/home/terp/OpenERP/branch/server/5.0/bin/service/web_services.py", line 577, in execute
    res = service.execute(db, uid, object, method, *args)
  File "/home/terp/OpenERP/branch/server/5.0/bin/osv/osv.py", line 58, in wrapper
    return f(self, dbname, *args, **kwargs)
  File "/home/terp/OpenERP/branch/server/5.0/bin/osv/osv.py", line 119, in execute
    res = pool.execute_cr(cr, uid, obj, method, *args, **kw)
  File "/home/terp/OpenERP/branch/server/5.0/bin/osv/osv.py", line 111, in execute_cr
    return getattr(object, method)(cr, uid, *args, **kw)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/project_timesheet/project_timesheet.py", line 162, in write
    hr_anlytic_timesheet.write(cr, uid, [line_id], vals_line, {})
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/hr_timesheet_sheet/hr_timesheet_sheet.py", line 422, in write
    self._check(cr, uid, ids)
  File "/home/terp/OpenERP/branch/server/5.0/bin/addons/hr_timesheet_sheet/hr_timesheet_sheet.py", line 427, in _check
    if att.sheet_id and att.sheet_id.state not in ('draft', 'new'):
...

Read more...

Ferdinand (office-chricar) wrote :

the last error mentioned above also happens with http (instead of https) - apparently a real web client bug

Ferdinand (office-chricar) wrote :

It could be also a (new) firefox incompatibility (tested on OpenSuSE 11.2 and Mac)

just tried with
arora 0.10.2 (webkit)
and
mac safari
work better

Ferdinand (office-chricar) wrote :

this causes problems

branch-server 2066
branch-addons official 2735
branch-addons chricar_5.0_price_unit 2613
stable_5.0-extra-addons 4370
web-client 2880
apache2-2.2.8-28.10

this works on another server
branch-server 1876
branch-addons 2499
trunk-extra-addons 2499
web-client 2658
apache2-2.2.8-28.4

after reverting to 2658 on the other server no more problems

description: updated
summary: - The path '/error/HTTP_INTERNAL_SERVER_ERROR.html.var' was not found.
+ REGRESSION - The path '/error/HTTP_INTERNAL_SERVER_ERROR.html.var' was
+ not found.
Changed in openobject-client-web:
assignee: nobody → Amit Mendapara (cristatus)
Ferdinand (office-chricar) wrote :

r 2910 still same problem
it seems this happens only for the first save operation.

may be also for text fields on notepad pages

Amit Mendapara (cristatus) wrote :

I have just tested with revno 2910 (5.0 branch) and revno 3035 (trunk) by configuring apache as documented here (http://doc.openerp.com/install/linux/web/index.html#configure-https) and I am unable to reproduce such error. It is working as expected...

Most probably, this might be due to your Apache misconfiguration, as in your case, the error seems to be thrown by the apache itself.

Changed in openobject-client-web:
status: New → Invalid
Ferdinand (office-chricar) wrote :

indeed, there was a miss configuration elsewhere
sorry for this

bobby (jeremy-telma) wrote :

Ferdinand,
i got the exact same pb as the one you described.
Could you tell us what was the misconfiguration causing that behavior? This would help me a lot.
Thank you
Bobby

Ferdinand (office-chricar) wrote :

make sure to have only ONE web client installed, follow the guidlines mentioned above how to configure webserver and clear browser cache
we do not use the web client much so it might still be another issue.
hope that helps

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers