OpenObject - Business Intelligence Solution

Cannot drill-down Olap hierarchy in BI module

Reported by mfl on 2009-07-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenERP Addons
Undecided
Vaibhav Darji
OpenObject Business Intelligence
Undecided
Vaibhav Darji

Bug Description

Hello everyone,

I cannot drill-down olap hierarchy while building Olap reports. The application shows "Loading..." and nothing happens.

Details:
I'm running trunk version with last updates.
I've created a new database with samples and installed some modules including BI (profile_BI, olap) and olap_sale, olap_crm.
Now I can partially use olap cube Sales in olap schema OpenERPSales (and OpenERPCRM's cubes as well).
For example, I've built summarized reports:

Code:

| | Unit Sold
--------------------
| Users | 11

But I cannot drill-down olap hierarchy "Users". The application shows "Loading..." and nothing happens.

After short investigation I've found that after dragging-and-dropping olap hierarchy "Users" to the droppable place (at the right) the application server shows the error:

[2009-07-13 11:33:35,312] ERROR:web-services:[01]: Traceback (most recent call last):
[2009-07-13 11:33:35,312] ERROR:web-services:[02]: File "D:\Projects\Workspace\OpenERP-Server\bin\osv\osv.py", line 59, in wrapper
[2009-07-13 11:33:35,312] ERROR:web-services:[03]: return f(self, dbname, *args, **kwargs)
[2009-07-13 11:33:35,312] ERROR:web-services:[04]: File "D:\Projects\Workspace\OpenERP-Server\bin\osv\osv.py", line 119, in execute
[2009-07-13 11:33:35,312] ERROR:web-services:[05]: res = pool.execute_cr(cr, uid, obj, method, *args, **kw)
[2009-07-13 11:33:35,312] ERROR:web-services:[06]: File "D:\Projects\Workspace\OpenERP-Server\bin\osv\osv.py", line 111, in execute_cr
[2009-07-13 11:33:35,312] ERROR:web-services:[07]: return getattr(object, method)(cr, uid, *args, **kw)
[2009-07-13 11:33:35,312] ERROR:web-services:[08]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\olap.py", line 278, in request
[2009-07-13 11:33:35,312] ERROR:web-services:[09]: find_table = warehouse.match_table(cr, uid, request, context)
[2009-07-13 11:33:35,312] ERROR:web-services:[10]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\warehouse.py", line 148, in match_table
[2009-07-13 11:33:35,312] ERROR:web-services:[11]: result = self.parse_query(request)
[2009-07-13 11:33:35,312] ERROR:web-services:[12]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\warehouse.py", line 220, in parse_query
[2009-07-13 11:33:35,312] ERROR:web-services:[13]: qr = query_parser.parseString(query)
[2009-07-13 11:33:35,312] ERROR:web-services:[14]: File "C:\Programs\Python25\lib\site-packages\pyparsing-1.5.2-py2.5-win32.egg\pyparsing.py", line 1078, in parseString
[2009-07-13 11:33:35,312] ERROR:web-services:[15]: raise exc
[2009-07-13 11:33:35,312] ERROR:web-services:[16]: ParseException: Expected "}" (at char 15), (line:1, col:16)

The same error is with OpenERPCRM module samples.

I've traced the application. The error occurs while parsing the string:
"select {[Users].children} on rows from Sales" in module pyparsing.py.

Regards,
Michael

Ashish Bhatia (asb-tiny) on 2009-07-14
Changed in openobject-bi:
assignee: nobody → vda(Open ERP) (vda-tiny)
status: New → In Progress
Vaibhav Darji (vaibhav-openerp) wrote :

Fixed in trunk-extra-addons (rev no. 3663)

Thanks for reporting.

Changed in openobject-bi:
status: In Progress → Fix Released
Changed in openobject-addons:
assignee: nobody → vda(Open ERP) (vda-tiny)
status: New → Fix Released
mfl (mfliorko) wrote :

I've just updated my local sources from launchpad and recreated a new database.

Unfortunately the defect is still reproducible. The same effects.

In the left panel of BI browser after selecting Olap schema and cube I can open Olap dimension and see Olap hierarchy, but I cannot expand any Olap hierarchy - at this moment the application server shows the mentioned error.

My environment configuration:
Windows XP SP 3
PostgreSQL 8.3.4
python 2.5
SQLAlchemy-0.5.3
pyparsing-1.5.2
(I've installed the latest versions of all required python packages)

All other modules work well.

Changed in openobject-bi:
status: Fix Released → Incomplete
Changed in openobject-addons:
status: Fix Released → Incomplete
Ashish Bhatia (asb-tiny) wrote :

Hello,

Instead of communicating on forum and here too , I propose we talk at one place only :).
I did some minor changes to solve the problem.

Pls. Take the update on
olap module (trunk-extra-addons)
bi specific web client ( client-new-trunk)

Let us know if it helped or you can again change the status of this bugs.

Thanks for your bringing this bug.

Changed in openobject-bi:
assignee: vda(Open ERP) (vda-tiny) → asb (Open ERP) (asb-tiny)
status: Incomplete → In Progress
status: In Progress → Fix Committed
Amit Mendapara (cristatus) wrote :

Hello asb,

You should not suggest people to communicate over channel. It's always better to cross reference discussions taken place on forum while you discuss related bugs. Because you might get lot more opinions/suggesting from forum then launchpad...

mfl (mfliorko) wrote :

Hello guys,

I also think that issues should be discussed widely.
Of course, there could be other opinions/helps. Also our discussion could help somebody to resolve similar (or same) issue(s).

I've downloaded all recent source code changes and created a new database.
Now I see another error message:
Parsing MDX...
        select {[Users].children} on rows from Sales
[2009-07-19 23:10:11,842] ERROR:web-services:[01]: Traceback (most recent call last):
[2009-07-19 23:10:11,842] ERROR:web-services:[02]: File "D:\Projects\Workspace\OpenERP-Server\bin\osv\osv.py", line 59, in wrapper
[2009-07-19 23:10:11,842] ERROR:web-services:[03]: return f(self, dbname, *args, **kwargs)
[2009-07-19 23:10:11,842] ERROR:web-services:[04]: File "D:\Projects\Workspace\OpenERP-Server\bin\osv\osv.py", line 119, in execute
[2009-07-19 23:10:11,842] ERROR:web-services:[05]: res = pool.execute_cr(cr, uid, obj, method, *args, **kw)
[2009-07-19 23:10:11,842] ERROR:web-services:[06]: File "D:\Projects\Workspace\OpenERP-Server\bin\osv\osv.py", line 111, in execute_cr
[2009-07-19 23:10:11,842] ERROR:web-services:[07]: return getattr(object, method)(cr, uid, *args, **kw)
[2009-07-19 23:10:11,842] ERROR:web-services:[08]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\olap.py", line 282, in request
[2009-07-19 23:10:11,842] ERROR:web-services:[09]: mdx = mdx_parser.parse(request)
[2009-07-19 23:10:11,842] ERROR:web-services:[10]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\mdx_parser.py", line 163, in parse
[2009-07-19 23:10:11,842] ERROR:web-services:[11]: return self.mdx_query().parseString(query)[0]
[2009-07-19 23:10:11,842] ERROR:web-services:[12]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\mdx_parser.py", line 157, in mdx_query
[2009-07-19 23:10:11,842] ERROR:web-services:[13]: mdx = selectToken + self.mdx_axis_list() + fromToken + self.mdx_cube() + Optional(whereToken + self.mdx_s
[2009-07-19 23:10:11,842] ERROR:web-services:[14]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\mdx_parser.py", line 116, in mdx_axis_list
[2009-07-19 23:10:11,842] ERROR:web-services:[15]: axis_parser = self.mdx_cross_axis() + Optional(onToken + page_name)
[2009-07-19 23:10:11,842] ERROR:web-services:[16]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\mdx_parser.py", line 101, in mdx_cross_axis
[2009-07-19 23:10:11,842] ERROR:web-services:[17]: cross_mdx = crossx | self.mdx_axis()
[2009-07-19 23:10:11,842] ERROR:web-services:[18]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\mdx_parser.py", line 76, in mdx_axis
[2009-07-19 23:10:11,842] ERROR:web-services:[19]: level_parse = self.mdx_level()
[2009-07-19 23:10:11,842] ERROR:web-services:[20]: File "D:\Projects\Workspace\OpenERP-Server\bin\addons\olap\cube\mdx_parser.py", line 46, in mdx_level
[2009-07-19 23:10:11,842] ERROR:web-services:[21]: scalar = Word(alphanums+ alphas8bit +"_"+" "+"-" )
[2009-07-19 23:10:11,842] ERROR:web-services:[22]: UnicodeDecodeError: 'ascii' codec can't decode byte 0x83 in position 26: ordinal not in range(128)

Thanks,
Michael

mfl (mfliorko) wrote :

:)

Changed in openobject-bi:
status: Fix Committed → Incomplete
Ashish Bhatia (asb-tiny) wrote :

Hello Michael,

Its strange that still error continues. Can you tell which encoding (utf-8, latin1 ... ) for the database to connect. I thnk its utf-8 only.

mfl (mfliorko) wrote :

The issue is reproducible if localization settings of Windows account under which OpenERP App server is launched are non-latin.

For example, set "Ukrainian" to the field "Standards and formats" of the window "Regional and Language Options" invoked from Windows Contrrol Panel.

On the other hand the application works properly in the following configuration:
    Standards and formats (1st page of the mentioned window) - English (United States)
    Location (1st page) - Ukraine
    Language for non-Unicode programs (3rd page) - Ukrainian

So, other localization settings ("Location" and "Language for non-Unicode programs") don't influence application behaviour.

mfl (mfliorko) wrote :

Hello asb,

All OpenERP databases are created from the application and have UTF8 encoding.
Details you can find in enclosed screenshot of my database options shown by pgAdmin.

Fill free to ask me more details if you think I can help you.

With kind regards,
Michael

Changed in openobject-bi:
assignee: asb (Open ERP) (asb-tiny) → Jra (Open ERP) (jra-openerp)
Changed in openobject-bi:
status: Incomplete → New
status: New → Incomplete
assignee: Jra (Open ERP) (jra-openerp) → vda(Open ERP) (vda-tiny)
Changed in openobject-bi:
status: Incomplete → In Progress

Hello Michael,
 I have tried same way using same configuration as u said:

 For example, set "Ukrainian" to the field "Standards and formats" of the window "Regional and Language Options" invoked from Windows Contrrol Panel.

On the other hand the application works properly in the following configuration:
    Standards and formats (1st page of the mentioned window) - English (United States)
    Location (1st page) - Ukraine
    Language for non-Unicode programs (3rd page) - Ukrainian

and i have checked using encoding utf-8. its work good.
so may i know that u r using postgresql of openerpallinone? which locale u have for postgresql?
database encoding is utf-8 or koi-8 u?

Hello Michael,

 Thanks for reporting this bug.
 fixed in :
   trunk-extra-addons(olap): rev-no: 3825
  client-new-trunk(bi web client): rev-no: 2046

Thanks.

Changed in openobject-bi:
status: In Progress → Fix Released
Changed in openobject-addons:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers