[6.1] check_total field removed from supplier invoices

Bug #998008 reported by Stéphane Bidoul (Acsone) on 2012-05-11

This bug report was converted into a question: question #197675: [6.1/ trunk] check_total field removed from supplier invoices.

22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Low
OpenERP R&D Addons Team 3
6.1
New
Undecided
OpenERP Publisher's Warranty Team

Bug Description

Hello,

In 6.0 there was a field named check_total on supplier invoices. The user filled that field first with the total amount on the invoice (taxes included). When validating the invoice, the system checked that the computed total matched the entered total. This allowed to catch data entry errors and VAT calculation errors (such as when the wrong tax code were selected).

In 6.1 (and in trunk as far as I can tell), this field (hence the check) has been removed.

Best regards,

-sbi

Related branches

summary: - [6.1 trunk] check_total field removed from supplier invoices
+ [6.1/ trunk] check_total field removed from supplier invoices

Hello Stephan,

Total(check_total) field doesn't displayed anymore on supplier invoice that's why we have removed this exception.

We have make a customer and supplier invoice 's same behavior for 6.1 and more that's why as a usability point of view we have make check_total (Total) invisible on supplier invoice because It doesn't look good to add total manually. That's why the Fabien is removed it. Just look.

http://bazaar.launchpad.net/~openerp/openobject-addons/trunk/revision/6254

So this is a not a bug but this thing is improved in trunk.

Thanks for reporting!

Changed in openobject-addons:
status: New → Invalid
Changed in openobject-addons:
status: Invalid → New
Stéphane Bidoul (Acsone) (sbi) wrote :

Hello,

In my opinion (and our accountant's as well), this is not an improvement, but rather a removed feature.

Indeed, supplier invoices are different than customer invoices in this respect.

When you enter a customer invoice, you calculate and verify the total price yourself. In the case of a supplier invoice, what the user does when entering the invoice in the system, is actually rebuilding the supplier invoice by entering all lines, setting tax codes, etc. In that situation, entering the total first and verifying at the end that all you have entered matches what the supplier meant is a desirable feature. It is easy to make mistakes when entering complex supplier invoices and it is very helpful to have the system check it for you.

I hope this can be reconsidered, as it was really a good feature. And from a useability standpoint, it was very easy to explain the feature to users, while it is quite difficult to explain why it has disappeared.

Best regards,

-sbi

Amit Parik (amit-parik) wrote :

Hello Stephan,

Thanks for your answer on this.

As I said on my comment#1, Total field doesn't displayed anymore on supplier invoice So I don't think the mistake will be made because total is calculated automatically we no need to add the amount. Also If you want this message, So we have to first display total field again on supplier invoice view.

But before implementing this we have to take more inputs and "Opinion' here, also we have to ask "Fabien" that what is the main reason for removed this message?

@Fabien: Would you please share your inputs on this, why this error message is removed?

@Accounting Experts: You can also share your views on this.

Currently I am setting this as an "Opinion", After the discussion on this issue we will take appropriate decision on this.

Thank you!

Changed in openobject-addons:
status: New → Opinion

I fully agree with Stéphane Bidoul (sbi). Supplier invoices are treated differently.

In accounting, it is crucial that for supplier invoices you enter the total amount of the invoice which has to be checked against the total of the individual lines. Compare it to the bank statement where the ending balance (entered manually) is checked against the total of all lines.

As an example enter the following supplier invoice:

one line with 4.75 EUR and 0% VAT
second line with 460.23 EUR and 21% VAT.

OpenERP calculates for the second line 96,65 EUR of VAT, which makes the invoice total equal to 561,63 EUR.

However, the invoice received from the supplier stipulates 96,66 EUR as VAT, which makes the total invoice amount equal to 561.64.
And here, I really don't care about which totals are calculated correctly. That is not the point. Point is I have to enter in OpenERP the exact same invoice figures as my supplier sent me. And I want the system to warn me when there is a difference.

If I encode this invoice without being able to enter the expected total of the invoice (as I used to do in version 6.0), I might post the invoice with the wrong VAT and total (and I know this invoice only has two lines, but the same might happen with a dozen of invoice lines).

Removing this field is NOT an improvement at all!

So PLEASE give me back the check_total field! Or at least give me the choice to have this field or not.

Regards,

Els Van Vossel

Download full text (4.2 KiB)

Morning, i dont have any preference for one way or another, but i guess my
problem is that when these things happen I would prefer to have a publicly
displayed list of what is changed and the reason, so we can interact if
needed.

There were a lot of small changes in 6.1 made and some of them make me
nervous, i.e.:

1 - 'opt_out' in res_partner

2 - def unlink in account_invoice

3 - def _check_currency in account_move_line

4 - account_cancel change

5 - kanban view by default for the modules and other places

6 - positioning of the modules menu

7 - ability to post into closed periods

The list can go on and on and some of them I may have no problems with,
some of them are definitely not making sense and relevant subscriber lists
MUST be informed of before changes are made.

I haven’t subscribed to the expert-accounting@lists because I like to
receive emails, but because I like to be in touch with the accounting
developments and any changes to the accounting modules.

Thanks,

* *

*Vadim Chobanu*

[image: enapps_logo]

T: +44 20 79 52 24 50

M: +44 79 39 23 09 59

E: <email address hidden>

W: www.enapps.co.uk

-------------------------------------------------------------------------
Information in this email is confidential and may be privileged.
It is intended for the addressee only. If you have received it in error,
please notify the sender immediately and delete it from your system.
You should not otherwise copy it, retransmit it or use or disclose its
contents to anyone.
Thank you for your co-operation.
-------------------------------------------------------------------------

Registered Address: 010 Coppergate House; 16 Brune Street; London E1 7NJ

Registered in England No: 07746264

Reg. VAT No. GB 124 1001 86

-----Original Message-----
From: openerp-expert-accounting-bounces+vadim=
<email address hidden> [mailto:
<email address hidden>]
On Behalf Of Amit Parik (OpenERP)
Sent: 22 May 2012 07:12
To: <email address hidden>
Subject: [Openerp-expert-accounting] [Bug 998008] Re: [6.1/ trunk]
check_total field removed from supplier invoices

Hello Stephan,

Thanks for your answer on this.

As I said on my comment#1, Total field doesn't displayed anymore on
supplier invoice So I don't think the mistake will be made because total is
calculated automatically we no need to add the amount. Also If you want
this message, So we have to first display total field again on supplier
invoice view.

But before implementing this we have to take more inputs and "Opinion'

here, also we have to ask "Fabien" that what is the main reason for removed
this message?

@Fabien: Would you please share your inputs on this, why this error message
is removed?

@Accounting Experts: You can also share your views on this.

Currently I am setting this as an "Opinion", After the discussion on this
issue we will take appropriate decision on this.

Thank you!

** Changed in: openobject-addons

       Status: New => Opinion

--

You received this bug notification because you are a member of OpenERP
Accounting Experts, which is subscribed to the bug report.
...

Read more...

Ferdinand (office-chricar) wrote :

I agree with Els

Proposition - make the check configurable for each journal - this way OpenERP can offer what user need/choose

I agree with Els and Ferdinand.

At least make the check configurable for each journal. But if you don't the go definitely back to the old situation, the new is a step back, users will make errors this way and search for hours where differences are.

Peter

I agree with Els.

This is/was a good feature. So I think this would NOT be an improvement.
If others think it is an improvement, I think it should be configurable.

BTW: I agree with Vadim too.

@Amit : why do you change first things and then ask for an opinion of the exports. Is it not cheaper for openerp to ask first the opinion before you change this kind of things. When we report bugs to the support team we get the whole time as an answer this is new functionality and then we get these changes nobody (and then I mean expert users, not beginners) asked for. This is a very fustrating way of working.

Amit Parik (amit-parik) wrote :

Hello Peter,

I understand your emotions..

This issue doesn't regarding new implementation, But this feature is removed from 6.1 by Fabien that's why I asked the "Opinion" of experts as well as I asked the "Opinion' of Fabien.

I think it's better on some issue, We have discuss first before the implementation.

I think you will be understand it.

Thanks

+1 for Els's Suggestion

@Amit, let's not involve emotions, that's for womens magazines. :-)

Just to add in a different view point...

The experience with the 'Check Total' field was very jarring in the
old system, and the error message was very confusing. I would often
get calls from our finance team asking me what the message meant - it
was just because they hadn't entered the check total, not because of
an error on the invoice. When they entered a supplier invoice, they
naturally check the total against the invoice total anyway. So our
finance team were very happy to see this field and the validation
removed (I had a number of comments on this!).

So, please don't put it back! I think that it's okay to make it a
system-configurable option, or even to provide a small optional module
that adds the feature.

James

@jamesj And how did you're accounts check if the total of the lines they entered matched their document ? This is a matter of training.

If we have to remove all the checks in OpenERP, it's like removing on an airport the security, it's easy, it's fast, but when you're in the air, your airplain can explode because there is a bomb placed in it ...

@jamesj, if the error message was unclear, then the error messages needs to be improved, and maybe the help text on the field.

Goran Kliska (gkliska) wrote :

My opinion and opinion of 300+ users is best described as Stéphane Bidoul (Acsone) (sbi) wrote on comment #2.
+301 for Els's Suggestion.

If error message is confusing, we need to change the message text - we use translation anyway.

@James - comment #13
I would suggest other way: If someone is really annoyed with this safety feature then lets make extra module that will make it configurable. "Turn off total check for this Journal" boolean.

@Vadim - comment #6
Thank you for the partial Release Notes.
It woud be nice to have in OpenERP functional Release Notes, something like:
   http://www.postgresql.org/docs/9.1/static/release-9-1-3.html .
It can be simple file in .../module_name/doc/changelog.txt

Goran Kliska
Slobodni programi d.o.o.
Zagreb, Croatia

@Stéphane, @Goran
It's more than just an issue with the error message as users are
correctly entering the invoice and then finding that the system is
rejecting it. There's a useablity issue here, and that won't be solved
by just putting back the field and changing the error message. If
there is to be a check on the invoice value, then it should be clearer
that the expected invoice total should be entered. The current
location of the field is obviously an issue as a number of users
complained about it... and were very happy when it was removed. I've
also heard the same comment from other users outside our company.

As a solution for those that did appreciate this extra check, here is a module that brings back the old functionality.

https://github.com/arnebrasseur/openerp-account_invoice_total

Hello Amit,
Dear OpenErp SA,

Since the vast majority of experts agree that something has to be done about it, I suppose the Opinion status is not the right one anymore.

By the way, the documentation for 6.0 and 6.1 has a very good explanation of this field: http://doc.openerp.com/v6.1/book/3/3_7/invoicing.html#creating-a-supplier-invoice.

If OpenErp SA decides this feature must be optional, I suppose it could be done as a new certified module?

Best regards,

-sbi

Changed in openobject-addons:
status: Opinion → Confirmed
Amit Parik (amit-parik) wrote :

Hello Stephane,

Great, thanks for revival.

You have suggested a good option that is we have to provide a another certified module for this, and I completely agree with on this point. We have to provide this facility too, So if anyone can use it then it this module will help them.

I am confirming the bug as low, and we'll decide what to do on it... perhaps new module is better option.

I would like to request that proper solution has to be discussed with AL or FP.

@Antony/Fabien : you will take the final decision what to do on this issue.

Thank you very much.!

Changed in openobject-addons:
importance: Undecided → Low
assignee: nobody → OpenERP R&D Addons Team 3 (openerp-dev-addons3)
Fabian Semal (fabian.semal) wrote :

+1 with everyone here. Any news on that matter since last month ?

Regards,

Fabian

How is status of this issue ?

tags: added: maintenance

I am out of the office until 22/11/2012.

Note: This is an automated response to your message
"[Openerp-expert-accounting] [Bug 998008] Re: [6.1/ trunk] check_total
field removed from supplier invoices" sent on 11/19/2012 6:04:19 PM.

This is the only notification you will receive while this person is away.

Hello everyone,

this discussion is a bit old and i'm sure a lot of interresting things have already been said. I don't want to argue or comment any decision that would have been taken for stable existing version (and for which i'm not aware, anyways ^^).

My only concern is the trunk, and i would just like to inform you that i added an option to use or not the check_total feature on supplier invoices. To enable it, go in Settings\configuration\accounting and thick the boolean "Check the total of supplier invoices" in the section "eInvoicing & Payments". The behavior is the same as it was previously.

That's why i'm closing this bug report for trunk serie and let the maintenant team do whatever she judges necessary for stable versions.

Thanks for your contribution and please, do continue shouting when you feel it's necessary ;-)
Quentin

Ps: yo fab!

Changed in openobject-addons:
status: Confirmed → Fix Released
summary: - [6.1/ trunk] check_total field removed from supplier invoices
+ [6.1] check_total field removed from supplier invoices

The linked branch (lp:~sbi/account-invoicing/6.1-account_invoice_total) is the current solution for 6.1.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments