MRP: Properties do not work

Bug #926107 reported by gde (OpenERP) on 2012-02-03
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Low
OpenERP R&D Addons Team 2
6.1
Confirmed
Low
OpenERP Publisher's Warranty Team

Bug Description

On the trunk, when we define several BoM for the same product with different properties, the BoM selected is not correct according the properties selected in the Sale Order.

Steps to reproduce:
- Create 3 product (1 to produce and 2 components)
Example: Steel Table (Stockable, MTO, To produce), Table Legs (Stockable, MTS, Buy), Steel Panel (Stockable, MTS, buy) [Create an inventory to put some unit in stock for the table legs and steel panel]

- Create a property group 'Table type' in which you define two properties: 'Kit' and 'Assembled'

- Create two BoM for the steel table
* One with the type: Nomal BoM and one with Kit Phantom type
* Components: 1 panel and 4 legs
* Property: For the Kit BoM, add the property Kit. For the Normal BoM, select the property Assembled

- Create a Sale Order for the product Steel Table and add in the Extra info tab the property Kit
- Deliver the components

- Create a Sale Order for the same product but add the property Assembled
- Deliver the components
--> Wrong! Should generate a Manufacturing Order

Expected behavior:
Selection of the BoM according to the properties defined in the BoM according to the properties selected in the Sales Order (and try to meet a maximum of them).

Amit Parik (amit-parik) on 2012-02-09
Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 2 (openerp-dev-addons2)
importance: Undecided → Low
status: New → Confirmed
Amit Parik (amit-parik) wrote :

Hello,

I look into more on this issue, and I noticed that the property_ids field never used when we confirmed the SO.

Currently it's only for the showing purpose. Wherever I have more then one BoM for one product then it will be identified from it's property. And currently it's not working , So that's why it become a problem when we have more then one BoM for same product.

So this is a good functionality for 6.1, that's why I am setting it as a 'Low'.

Thank you!

Hello,

If I'm not wrong this feature used to work in previous versions. I believe
I was using it in a project in OpenERP v5, I even remember I had a patch
integrated in the distro at this time to have it working. So please double
check because regressions are really something to avoid (users assume that
by upgrading they always get more functionality, not less); also, I think I
need this feature again on a project I'm currently working.

On Thu, Feb 9, 2012 at 9:49 AM, Amit Parik (OpenERP) <email address hidden>wrote:

> Hello,
>
> I look into more on this issue, and I noticed that the property_ids
> field never used when we confirmed the SO.
>
> Currently it's only for the showing purpose. Wherever I have more then
> one BoM for one product then it will be identified from it's property.
> And currently it's not working , So that's why it become a problem when
> we have more then one BoM for same product.
>
> So this is a good functionality for 6.1, that's why I am setting it as a
> 'Low'.
>
> Thank you!
>
> --
> You received this bug notification because you are a member of OpenERP
> Drivers, which is subscribed to OpenERP Addons.
> https://bugs.launchpad.net/bugs/926107
>
> Title:
> MRP: Properties do not work
>
> Status in OpenERP Addons (modules):
> Confirmed
>
> Bug description:
> On the trunk, when we define several BoM for the same product with
> different properties, the BoM selected is not correct according the
> properties selected in the Sale Order.
>
> Steps to reproduce:
> - Create 3 product (1 to produce and 2 components)
> Example: Steel Table (Stockable, MTO, To produce), Table Legs (Stockable,
> MTS, Buy), Steel Panel (Stockable, MTS, buy) [Create an inventory to put
> some unit in stock for the table legs and steel panel]
>
> - Create a property group 'Table type' in which you define two
> properties: 'Kit' and 'Assembled'
>
> - Create two BoM for the steel table
> * One with the type: Nomal BoM and one with Kit Phantom type
> * Components: 1 panel and 4 legs
> * Property: For the Kit BoM, add the property Kit. For the Normal BoM,
> select the property Assembled
>
> - Create a Sale Order for the product Steel Table and add in the Extra
> info tab the property Kit
> - Deliver the components
>
> - Create a Sale Order for the same product but add the property Assembled
> - Deliver the components
> --> Wrong! Should generate a Manufacturing Order
>
>
> Expected behavior:
> Selection of the BoM according to the properties defined in the BoM
> according to the properties selected in the Sales Order (and try to meet a
> maximum of them).
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-addons/+bug/926107/+subscriptions
>

Hello I confirm the regression. We are sending a merge proposal to fix it in a few minutes.

qdp (OpenERP) (qdp) wrote :

fix landed in trunk in revision 7020

thanks

Changed in openobject-addons:
status: Confirmed → Fix Released
tags: added: maintenance
removed: profserv
Davide Corio (enlightx) wrote :

Hello,
i tried to do the same on v7 and it looks like our beloved bug is back

i created 2 BOMs for the same product. each BOM has it's own property (prop1 and prop2)

then i tried to create 2 SO. the first with a line for the product and prop1, the second with a line for the same product and prop2

in both cases i get MOs for the BOM with prop2.

can someone confirm this regression?

Davide Corio (enlightx) wrote :

i managed to get it back to work using the attached patch

wowas (wowas18) wrote :

Why it fix in revision
~openerp/openobject-addons/7.0 » Revision 9172

And then revert back in revision
 ~openerp/openobject-addons/7.0 » Revision 9175

What cause?

Any update on this BUG? It is open for ... ages ,)

@michaelkarrer81: you should comment on lp:1083077

Note that this bug has been fixed in the ocb-70 branch. If you need the fix in 6.1 I suggest you submit a merge proposal on the ocb-6.1 branch of openobject-addons

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers