[6.1] bug with editable tree inside a one2many form

Bug #942301 reported by Graeme Gellatly on 2012-02-27
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Medium
OpenERP Publisher's Warranty Team
Therp Backports (Deprecated)
Status tracked in Addons-6.1
Addons-6.1
Undecided
Unassigned
Addons-7.0
Undecided
Unassigned

Bug Description

To test you will need a chain of relations such as

sale.order -> sale.order.line -> some one2many which is an editable list

When you pop the order.line form everything appears OK. Equally entering data in the form view of the final relation inside the order.line is fine. But when you click create on the tree view the following error is popped.

Firefox
QWeb2 - template['ListView.row.form']: Runtime Error: TypeError: dict.frame is undefined
http://localhost:18069/web/webclient/js:18953

Chrome
Uncaught Error: QWeb2 - template['ListView.row.form']: Runtime Error: TypeError: Cannot call method 'render' of undefined
http://localhost:18069/web/webclient/js:18953

Related branches

affects: openobject-server → openerp-web

Hello Graeme Gellatly,

I have checked your issue new released 6.1 but I didn't faced the same problem as you have describe in your description.Would you please check again and informed us still you have faced the same problem..!

Thanks and waiting for your reply.

Changed in openerp-web:
status: New → Incomplete

Yes, in latest revisions for 6.1 the problem is still present.

On Wed, Feb 29, 2012 at 12:47 AM, Vishal Parmar(Open ERP) <
<email address hidden>> wrote:

> Hello Graeme Gellatly,
>
> I have checked your issue new released 6.1 but I didn't faced the same
> problem as you have describe in your description.Would you please check
> again and informed us still you have faced the same problem..!
>
> Thanks and waiting for your reply.
>
> ** Changed in: openerp-web
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/942301
>
> Title:
> [6.1] bug with editable tree inside a one2many form
>
> Status in OpenERP Web:
> Incomplete
>
> Bug description:
> To test you will need a chain of relations such as
>
> sale.order -> sale.order.line -> some one2many which is an editable
> list
>
> When you pop the order.line form everything appears OK. Equally
> entering data in the form view of the final relation inside the
> order.line is fine. But when you click create on the tree view the
> following error is popped.
>
> Firefox
> QWeb2 - template['ListView.row.form']: Runtime Error: TypeError:
> dict.frame is undefined
> http://localhost:18069/web/webclient/js:18953
>
> Chrome
> Uncaught Error: QWeb2 - template['ListView.row.form']: Runtime Error:
> TypeError: Cannot call method 'render' of undefined
> http://localhost:18069/web/webclient/js:18953
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openerp-web/+bug/942301/+subscriptions
>

Graeme Gellatly (gdgellatly) wrote :

OK I retested, and now it has a different error which I'll report
seperately. From some reason the controllers.js file was the trunk version
not the 6.1 version despite rebasing

On Wed, Feb 29, 2012 at 8:32 AM, Graeme Gellatly <email address hidden>wrote:

> Yes, in latest revisions for 6.1 the problem is still present.
>
>
> On Wed, Feb 29, 2012 at 12:47 AM, Vishal Parmar(Open ERP) <
> <email address hidden>> wrote:
>
>> Hello Graeme Gellatly,
>>
>> I have checked your issue new released 6.1 but I didn't faced the same
>> problem as you have describe in your description.Would you please check
>> again and informed us still you have faced the same problem..!
>>
>> Thanks and waiting for your reply.
>>
>> ** Changed in: openerp-web
>> Status: New => Incomplete
>>
>> --
>> You received this bug notification because you are subscribed to the bug
>> report.
>> https://bugs.launchpad.net/bugs/942301
>>
>> Title:
>> [6.1] bug with editable tree inside a one2many form
>>
>> Status in OpenERP Web:
>> Incomplete
>>
>> Bug description:
>> To test you will need a chain of relations such as
>>
>> sale.order -> sale.order.line -> some one2many which is an editable
>> list
>>
>> When you pop the order.line form everything appears OK. Equally
>> entering data in the form view of the final relation inside the
>> order.line is fine. But when you click create on the tree view the
>> following error is popped.
>>
>> Firefox
>> QWeb2 - template['ListView.row.form']: Runtime Error: TypeError:
>> dict.frame is undefined
>> http://localhost:18069/web/webclient/js:18953
>>
>> Chrome
>> Uncaught Error: QWeb2 - template['ListView.row.form']: Runtime Error:
>> TypeError: Cannot call method 'render' of undefined
>> http://localhost:18069/web/webclient/js:18953
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/openerp-web/+bug/942301/+subscriptions
>>
>
>

Hello Graeme Gellatly,

I have tried lots of time with trunk & 6.1 bug I didn't face the same problem.

Still you have faced the same problem which you have described in you bug specification ?

Like:
Uncaught Error: QWeb2 - template['ListView.row.form']: Runtime Error: TypeError: Cannot call method 'render' of undefined

Thanks and waiting for your reply.

Graeme Gellatly (gdgellatly) wrote :

No I can no longer reproduce with latest 6.1 revisions, although still
reproducable in trunk. The new errors are related to onchange events as
views do not load records in the same way as previous/GTK client making
iterating over a one2many pretty much impossible

On Wed, Feb 29, 2012 at 11:35 PM, Vishal Parmar(Open ERP) <
<email address hidden>> wrote:

> Hello Graeme Gellatly,
>
> I have tried lots of time with trunk & 6.1 bug I didn't face the same
> problem.
>
> Still you have faced the same problem which you have described in you
> bug specification ?
>
> Like:
> Uncaught Error: QWeb2 - template['ListView.row.form']: Runtime Error:
> TypeError: Cannot call method 'render' of undefined
>
> Thanks and waiting for your reply.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/942301
>
> Title:
> [6.1] bug with editable tree inside a one2many form
>
> Status in OpenERP Web:
> Incomplete
>
> Bug description:
> To test you will need a chain of relations such as
>
> sale.order -> sale.order.line -> some one2many which is an editable
> list
>
> When you pop the order.line form everything appears OK. Equally
> entering data in the form view of the final relation inside the
> order.line is fine. But when you click create on the tree view the
> following error is popped.
>
> Firefox
> QWeb2 - template['ListView.row.form']: Runtime Error: TypeError:
> dict.frame is undefined
> http://localhost:18069/web/webclient/js:18953
>
> Chrome
> Uncaught Error: QWeb2 - template['ListView.row.form']: Runtime Error:
> TypeError: Cannot call method 'render' of undefined
> http://localhost:18069/web/webclient/js:18953
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openerp-web/+bug/942301/+subscriptions
>

Hello Graeme Gellatly,

Thanks for your quick reply.

Can you show me which error you did faced ?

In trunk I have make editable sale order line and faced following problem.

Uncaught Error: Unknown field state in domain [["state","not in",["draft"]]]

Thanks for and waiting for your reply.

Changed in openerp-web:
assignee: nobody → OpenERP R&D Web Team (openerp-dev-web)
importance: Undecided → Low
status: Incomplete → Confirmed
Changed in openerp-web:
importance: Low → Medium

Hello,

I can't reproduce this bug anymore, plus it seems quite old and many modifications occurred in o2m since then. I'll just assume it was fixed.

Changed in openerp-web:
status: Confirmed → Invalid
Ray Carnes (rcarnes) wrote :

I am getting this bug in 6.1.1.

Error message:
Uncaught Error: QWeb2 - template['ListView.rows']: Runtime Error: Error: QWeb2 - template['ListView.row']: Runtime Error: Error: Unknown field state in domain [["state","not in",["confirmed","assigned"]]]

It is also replicable via the online demo.

To replicate:

1) Visit http://demo.openerp.com and login
2) Click Sales -> Sales Orders
3) Click on a Sales Order with Order State = To Invoice (China Export or Ecole de Commerce de Liege)
4) Click on a Sales Order line

Ray Carnes (rcarnes) wrote :

I have submitted a warranty ticket.

I can confirm that this issue exist in the 6.1.1

Changed in openerp-web:
status: Invalid → New
Ivan Kunz (9-ik) wrote :

This Error exist still in the 6.1.1

Checked the bug, the issue turns out to be in the addons: in the view stock.move.tree3, the view uses the `state` field of the move_ids (stock moves, on the third tab) to show or hide a button:

    <button name="action_done" states="confirmed,assigned" string="Process" type="object" icon="gtk-go-forward"/>

but the view does not include the `state` field itself, so the resolution blows up with the message you can see as the client can't compute the visibility of the button.

I'm not sure if the button should go or the state field should be added (adding a state field in invisible=1 in the view makes the error disappear), so I just moved the bug to addons.

no longer affects: openerp-web
no longer affects: openerp-web/6.1
no longer affects: openerp-web/trunk
Changed in openobject-addons:
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)
importance: Undecided → Medium
status: New → Confirmed

Hello,

It has been fixed in lp:~openerp-dev/openobject-addons/6.1-opw-573841-msh.

Soon it will be merged in stable version 6.1.

Thanks.

Changed in openobject-addons:
status: Confirmed → Fix Committed
Changed in therp-backports:
status: New → Confirmed
milestone: none → 6.1-maintenance
Changed in therp-backports:
status: Confirmed → Fix Released
Changed in openobject-addons:
status: Fix Committed → Fix Released
Lara (Therp) (lfreeke) on 2013-01-23
Changed in therp-backports:
milestone: 6.1-maintenance → 7.0-maintenance
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments