[6.1] Another average cost error - this time in _get_reference_values function in Stock

Bug #937669 reported by Graeme Gellatly on 2012-02-21
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Fix Committed
OpenERP R&D Addons Team 2

Bug Description

Patch attached.

To see the error, create a purchase order for a different UOM than the default. Best to use a default of kg and a purchase uom of tonne. Product must be average cost. Basically you will end up with an amount 1000 times what it should be.

Related branches

On hold for merging into lp:openobject-addons
OpenERP Core Team: Pending requested 2012-03-12
Graeme Gellatly (gdgellatly) wrote :
Changed in openobject-addons:
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Won't Fix
status: Won't Fix → Confirmed
importance: Undecided → Medium
assignee: nobody → OpenERP R&D Addons Team 2 (openerp-dev-addons2)
Ravish(OpenERP) (rmu-openerp) wrote :

Hello Graeme,

I have checked your patch. it's working fine .Sorry for status inconvenience ,it's due to connection problem.


Changed in openobject-addons:
status: Confirmed → In Progress

Hello Graeme Gellatly,

Thanks for your contribution & nice patch .
It has been fixed in lp:~openerp-dev/openobject-addons/trunk-bug-937669-mma With
Revision ID: <email address hidden>
Revision num: 6668

It will be available in trunk soon.

Changed in openobject-addons:
status: In Progress → Fix Committed


Please try to give enough information to reproduce the bug and to correct it.
- Revision number
- Installed module
- Step to reproduce the bug
- The expected result
- The observed result
And if you have a fix try to give also some information.

Good luck,

Arnaud Pineux (API)

Changed in openobject-addons:
status: Fix Committed → Incomplete
Graeme Gellatly (gdgellatly) wrote :

Why change status 9 months after I put the fix in and it was agreed? It was accepted at the time, it is a very simple bug and very simple to reproduce.

Changed in openobject-addons:
status: Incomplete → Fix Committed
tags: added: ocb-stock-v1
no longer affects: ocb-addons
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers