OpenERP Addons (modules)

[v6.x] [account] _reconciled method for account.invoice method does not take into account the invoice state 'paid' when the result is False

Reported by hbto [Vauxoo] http://www.vauxoo.com on 2012-02-08
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
OpenERP Addons
High
OpenERP Publisher's Warranty Team

Bug Description

I would like to point out regarding taking into account the workflow service for the invoice
in Bug#928616

https://bugs.launchpad.net/openobject-addons/+bug/928616

This means that invoice workflow is missing a transition from paid to re-open,

I am reporting this as a bug because this is just being tackle from account_voucher
but other modules/models are not aware of that being happening,

If you unreconcile payments not by account_voucher, but through account_move_line
action unreconcile entries, then invoices affected will remain in paid state.

So as it happens with test_paid trasition that keeps aware of account.move.line records
It should happen the same for aml being unreconciled that affects the state of other invoices

Thanks a lot

summary: - [v6.x] [account] workflow transition missing for invoice
+ [v6.x] [account] _reconciled method for account.invoice method does not
+ take into account the invoice state 'paid' when the result is False

I decide to change the name to this bug to better address the issue
that I was previously pointed out.

And now I come to you with a patch that addresses this problem.

Applying this patch better addresses the latest lines added to the branch that
fixed the bug#928616 where it was call a wf_service,

Whenever the invoice is not quite reconciled it will change the state from 'paid' to' re-open'

Nhomar - Vauxoo (nhomar) on 2012-02-10
Changed in openobject-addons:
status: New → Confirmed
importance: Undecided → High
Nhomar - Vauxoo (nhomar) wrote :

Please before merging verify this patch supplied by Hbto....

We think is important solve this issue just one time...

https://bugs.launchpad.net/openobject-addons/+bug/928616

This bug have relation

Regards.

Amit Parik (amit-parik) on 2012-02-14
Changed in openobject-addons:
assignee: nobody → OpenERP Publisher's Warranty Team (openerp-opw)

Hello hbto [Vauxoo] http://www.vauxoo.com,

Fixed it in following branch authored to you,

https://code.launchpad.net/~openerp-dev/openobject-addons/6.0-bug-928899-rha
Revision ID: <email address hidden>
Revision 5057

Thanks for reporting it.
Regards.

Changed in openobject-addons:
status: Confirmed → In Progress
status: In Progress → Fix Committed

ok, wonderfull,

El martes 14 de febrero de 2012, Rifakat (OpenERP) <
<email address hidden>> escribió:

> Hello hbto [Vauxoo] http://www.vauxoo.com,
>
> Fixed it in following branch authored to you,
>
>
> https://code.launchpad.net/~openerp-dev/openobject-addons/6.0-bug-928899-rha
> Revision ID: <email address hidden>
> Revision 5057
>
> Thanks for reporting it.
> Regards.
>
> ** Changed in: openobject-addons
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/928899
>
> Title:
> [v6.x] [account] _reconciled method for account.invoice method does
> not take into account the invoice state 'paid' when the result is
> False
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-addons/+bug/928899/+subscriptions
>

Landed into stable 6.0
Revision ID: <email address hidden>
Revision 5073

Regards.

Changed in openobject-addons:
status: Fix Committed → Fix Released
milestone: none → 6.0.4
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers