S.O generates M.O based on specified product but random BOM

Bug #894229 reported by Paul Catinean

This bug report was converted into a question: question #179876: S.O generates M.O based on specified product but random BOM.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Invalid
Undecided
Unassigned

Bug Description

When having multiple bom's defined on a single product (which has procurment method set to "make to order" and supply method "produce") and you issue a sale order (S.O) on that product there is no place to specify which Bill of Material to use from the multitude defined and it just ends up picking a random one when generating the Manufacturing Order.This sort of defeats the whole point of the possibility of having multiple bom's on the same product.There must be a possibility to select the bom from the sale order (with the default value auto-completed would be best) but still a choice must be offered.If there can be a patch released of some sort i would be very interested and in dyer need of one as well!

Paul Catinean (wiz-keed)
description: updated
Revision history for this message
hifly (csnlca) wrote : Re: [Bug 894229] Re: S.O generates M.O based on specified product but random BOM

You can use Property Group / Property function under mrp module to define
which BoM for the same product will be selected by Scheduler.

On Bom/Sale Order Line/Procurement Order form, you can define Property for
same product with many BoMs!

Please try it !

Hifly

On Thu, Nov 24, 2011 at 11:05 AM, Wiz_KeeD <email address hidden>wrote:

> ** Description changed:
>
> When having multiple bom's defined on a single product (which has
> procurment method set to "make to order" and supply method "produce")
> and you issue a sale order (S.O) on that product there is no place to
> specify which Bill of Material to use from the multitude defined and it
> just ends up picking a random one when generating the Manufacturing
> Order.This sort of defeats the whole point of the possibility of having
> - multiple bom's on the same product.If there can be a patch released of
> - some sort i would be very interested and in dyer need of one as well!
> + multiple bom's on the same product.There must be a possibility to select
> + the bom from the sale order (with the default value auto-completed would
> + be best) but still a choice must be offered.If there can be a patch
> + released of some sort i would be very interested and in dyer need of one
> + as well!
>
> --
> You received this bug notification because you are a member of OpenERP
> Framework Experts, which is subscribed to OpenERP Addons.
> https://bugs.launchpad.net/bugs/894229
>
> Title:
> S.O generates M.O based on specified product but random BOM
>
> Status in OpenERP Addons (modules):
> New
>
> Bug description:
> When having multiple bom's defined on a single product (which has
> procurment method set to "make to order" and supply method "produce")
> and you issue a sale order (S.O) on that product there is no place to
> specify which Bill of Material to use from the multitude defined and
> it just ends up picking a random one when generating the Manufacturing
> Order.This sort of defeats the whole point of the possibility of
> having multiple bom's on the same product.There must be a possibility
> to select the bom from the sale order (with the default value auto-
> completed would be best) but still a choice must be offered.If there
> can be a patch released of some sort i would be very interested and in
> dyer need of one as well!
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-addons/+bug/894229/+subscriptions
>

Revision history for this message
Amit Parik (amit-parik) wrote :

Hello,

I have checked this issue, you have specified that If product have more then "BOM" then MO takes a random "BoM". It's nothing like that I think you might have misunderstand something.

Let me explain: If product have more then one "BoM" and you have creates a SO then it will always takes a First "BoM" on it's procurement order. You can see the BoM field in procurement order. If this field is blank then MO will consider always product's first created BoM.

If you have to change the BoM means you wants to another BoM for MO, then you can change from the procurement order before running the procurement.

So I think all are working as normally, I have attached a video for your more reference so would you please check it and notify us where you faced the problem.

Thanks and waiting for your reply!

Revision history for this message
Amit Parik (amit-parik) wrote :
Changed in openobject-addons:
status: New → Incomplete
Revision history for this message
Paul Catinean (wiz-keed) wrote :

You are perfectly correct in everything you say Amit Parik and i'm pretty sure this is going to turn into a question rather than a bug.Your reply was wonderful alongside that video which perfectly illustrated what i want and showed it can be done (allthough you moved pretty fast and i had to replay the video a few times :))

I think my problem was that i had installed the mrp_jit (just in time) module which i think automatically ran the procurement.So in the light of the new evidence you brought up i have uninstalled the mrp_jit module and:

1.Logged out
2.Logged in
3.Restarted the server
4.Create a new sale order
5.Add a product to the order line
6.Save SO
7.Confirm SO

By this stage i have already the manufacturing order created with the default bom (first as you just said) and the procurement exception is in Running State alongside all the P.E's that have "Exception" state because i have not defined minimum orderpoint rules

So i do not have a pretty "Run Procurement" button as you do in the video

I must be doing something wrong, if you have any pointers on this i would very much apreciate it.

Your help so far has been wonderful, thank you very much Amit!

Amit Parik (amit-parik)
Changed in openobject-addons:
status: Incomplete → Invalid
Revision history for this message
Paul Catinean (wiz-keed) wrote :

Apparently it take updating the whole database with -u all after removing the mrp_jit module for changes to take effect, can you change the section to "questions" rather than bugs or should i do that?

Once again, your help was amazing Amit, thank you so much once again and i'm sorry for the troubles caused!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments