OpenERP Addons (modules)

[6.0.2] CALDAV: Android phone cannot be synchronized anymore

Reported by Bernard Renier - ADN on 2011-07-03
32
This bug affects 7 people
Affects Status Importance Assigned to Milestone
OpenERP Addons
Low
OpenERP R&D Addons Team 1

Bug Description

Hello,

For synchronizing mobile OpenERP's documentation mentions the apps Calendar (CalDav) Sync BETA from Hypermatix Software.

This apps does not exist anymore, it has been replaced by Hypermatix's ANDAL (can be tested free, an then bought for a few euros).

Unfortunately, with this new app, synchronisation with OpenERP does'nt work anymore.

As android becomes a standard for mobile phones, could you find a solution for this issue, or at least do you have a repository with the code of the Calendar (CalDav) Sync BETA ?

Regards,

Bernard

On Monday 04 July 2011, you wrote:

> For synchronizing mobile OpenERP's documentation mentions the apps
> Calendar (CalDav) Sync BETA from Hypermatix Software.
>
> This apps does not exist anymore, it has been replaced by Hypermatix's
> ANDAL (can be tested free, an then bought for a few euros).
>...

We're terribly sorry about that, but the lack of Android apps is way beyond
the scope of OpenERP developers.

Originally, we'd thought that a protocol like CalDAV would have a plethora of
apps for Android, or even be supported in the core stack of those phones. But
we discovered, sadly, that only a 3rd party application, a closed[1] one, had
to be used instead.

The best thing we can do (as OpenERP) is to drop a challenge among Android
developers, to provide us a decent CalDAV client. We would really like to see
such a development.

[1] in the sense that we could only access it through the Market, not be able
to transfer this "free" app through phones or even run it in an emulator.

Changed in openobject-addons:
status: New → Triaged

Hi Bernard,

What xrg means is that such issues might be caused by the OpenERP CalDAV implementation, or could actually be caused by the android client software, and it is difficult for us to take an action without having more information.
As you can imagine, it would be impractical for us to go and fix all the CalDAV clients in the world that have errors when connecting to our CalDAV - there is a lot of them, and quite a few are badly broken, something our server cannot magically fix.

We can of course update the documentation to mention that there is no recommended client for Android at the moment, but that will not help you much.

However we would welcome any additional information that could indicate an error in the implementation of CalDAV within OpenERP, allowing us to work on it. Any additional information you find could be helpful, like the kind of error messages your android software gives you, any errors that might appear in the OpenERP server logs when you try to connect, etc.

Also cross-checking with alternative clients can provide valuable info too. On the wiki of the Davical server I see they mention new alternative client for Android, have you tried them? http://wiki.davical.org/w/CalDAV_Clients/Android

Thanks for your feedback!

Changed in openobject-addons:
status: Triaged → Incomplete

FYI I met the developer of this last weekend. It is GPL3.

http://gitorious.org/acal

I don't know if it helps.

On Wed, Aug 31, 2011 at 11:50 PM, Olivier Dony (OpenERP) <
<email address hidden>> wrote:

> Hi Bernard,
>
> What xrg means is that such issues might be caused by the OpenERP CalDAV
> implementation, or could actually be caused by the android client software,
> and it is difficult for us to take an action without having more
> information.
> As you can imagine, it would be impractical for us to go and fix all the
> CalDAV clients in the world that have errors when connecting to our CalDAV -
> there is a lot of them, and quite a few are badly broken, something our
> server cannot magically fix.
>
> We can of course update the documentation to mention that there is no
> recommended client for Android at the moment, but that will not help you
> much.
>
> However we would welcome any additional information that could indicate
> an error in the implementation of CalDAV within OpenERP, allowing us to
> work on it. Any additional information you find could be helpful, like
> the kind of error messages your android software gives you, any errors
> that might appear in the OpenERP server logs when you try to connect,
> etc.
>
> Also cross-checking with alternative clients can provide valuable info
> too. On the wiki of the Davical server I see they mention new
> alternative client for Android, have you tried them?
> http://wiki.davical.org/w/CalDAV_Clients/Android
>
> Thanks for your feedback!
>
>
> ** Changed in: openobject-addons
> Status: Triaged => Incomplete
>
> --
> You received this bug notification because you are subscribed to OpenERP
> Addons.
> https://bugs.launchpad.net/bugs/805267
>
> Title:
> [6.0.2] CALDAV: Android phone cannot be synchronized anymore
>
> Status in OpenERP Modules (addons):
> Incomplete
>
> Bug description:
> Hello,
>
> For synchronizing mobile OpenERP's documentation mentions the apps
> Calendar (CalDav) Sync BETA from Hypermatix Software.
>
> This apps does not exist anymore, it has been replaced by Hypermatix's
> ANDAL (can be tested free, an then bought for a few euros).
>
> Unfortunately, with this new app, synchronisation with OpenERP does'nt
> work anymore.
>
> As android becomes a standard for mobile phones, could you find a
> solution for this issue, or at least do you have a repository with the
> code of the Calendar (CalDav) Sync BETA ?
>
> Regards,
>
> Bernard
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-addons/+bug/805267/+subscriptions
>

Changed in openobject-addons:
status: Incomplete → New
Bernard Renier - ADN (bre-adn) wrote :

Hello Olivier,

I tested all caldav apps available on Android market:

- Caldav-Sync Alpha
- aCal Caldav client
- Andal
- Kalendi Android

For each of them I have a message indicating connection problem to the server

Are you 100% sure of the generic path recommended by OpenERP:

http://host:8069/webdav/db/calendars/users/demo/c/Meetings ?

Regards,

Bernard

Confirming this without reproducing, as it is better for the R&D team to directly check this in a real case with an Android terminal.

Note to R&D: please try some of the Android software mentioned by Bernard and double-check that you can sync with OpenERP calendars. If you can't please check if the error comes from the implementation of the Android client or from OpenERP's caldav.
Depending on this, close the bug as Invalid or fix the problem.

Thanks!

Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 1 (openerp-dev-addons1)
importance: Undecided → Low
status: New → Confirmed
milestone: none → 6.1
Fabian Semal (fabian.semal) wrote :

Hello,

Any news about this topic ? Does anyone knows how to sync OpenERP calendar and Android now ?

Regards,

Fabian

FWIW, I use 'CalDAV-Sync beta' and I get connection errors in the client. The server log spits out:

"WARNING ? caldav.query: Ignore start.. "
"WARNING ? webdav: Cannot calculate own address: '_fileobject' object has no attribute 'getsockname'"

It seems to repeat those line 2 times.

CalDAV-sync beta:
- verifies user/pass at account creation time and that passes.
- can produce a list of calendars on the server, the server log produces at that time:
  "PROPFIND /webdav/hsd/calendars/users/marcel/c/Meetings/ HTTP/1.1" 207 -
  "PROPFIND /.well-known/caldav HTTP/1.1" 404 -
  "PROPFIND /SOGo/dav/ HTTP/1.1" 404 -
  "PROPFIND /groupdav.php/ HTTP/1.1" 404 -
  "PROPFIND /dav/ HTTP/1.1" 404 -
  "PROPFIND /caldav/ HTTP/1.1" 404 -
  "PROPFIND /principals/ HTTP/1.1" 404 -
  "PROPFIND / HTTP/1.1" 301 -
  "PROPFIND /web/webclient/home HTTP/1.1" 200 -

Changed in openobject-addons:
status: Confirmed → Fix Released

(no evidence that the bug was solved, so no reason to mark it Fixed)

Changed in openobject-addons:
status: Fix Released → Confirmed

'Confirmed' includes a commitment to put some effort in to fixing it?

If not, perhaps introduce a state/remark WONTFIX, so we can look for an alternative somehow.

If so, let me know if I can help out testing from linux/android caldav clients. (or iphone, but that already works (somewhat))

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers