Balance Sheet Report - Overall balance calculation error

Bug #722832 reported by Frank Adler on 2011-02-21
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Low
OpenERP R&D Addons Team 3

Bug Description

Hi There,

First bug I log here, so hope this is the right spot.

Have recently installed version 6.0.1 straight from the main website with a minimal module set to complete my annual statement (Balance sheet, P&L) in OpenERP. After entering all transactions as journal entries I went to Reporting | Legal Reports | Accounting Reports | Balance sheet (One period, all entries, no filters). I noticed that the overall balance is calculated incorrectly. If I manually add up all the line items in the balance sheet I get to a total of 9.995.65 EUR (consistently for assets and liabilities) whereas the report returns 11626.82 EUR. I am only using standard modules with one exception which is "account_cancel" and no currency calculations either.

Since this would be pretty essential to any company running their financials through OpenERP it would be great to get this fixed.

Best Regards
Frank

Related branches

affects: openobject-client → openobject-addons

Hello Frank,

The balance sheet reports are working as expected at my end with respect to journal entries.

I have attached the video for your reference, So please refer it and notify us. For now I am closing this bug.

Thanks for your participation.

Changed in openobject-addons:
status: New → Invalid

On 22. 02. 11 10:07, Launchpad Bug Tracker wrote:
> You have been subscribed to a public bug:
>
> Hi There,
>
> First bug I log here, so hope this is the right spot.
>
> Have recently installed version 6.0.1 straight from the main website
> with a minimal module set to complete my annual statement (Balance
> sheet, P&L) in OpenERP. After entering all transactions as journal
> entries I went to Reporting | Legal Reports | Accounting Reports |
> Balance sheet (One period, all entries, no filters). I noticed that the
> overall balance is calculated incorrectly. If I manually add up all the
> line items in the balance sheet I get to a total of 9.995.65 EUR
> (consistently for assets and liabilities) whereas the report returns
> 11626.82 EUR. I am only using standard modules with one exception which
> is "account_cancel" and no currency calculations either.
>
> Since this would be pretty essential to any company running their
> financials through OpenERP it would be great to get this fixed.
>
> Best Regards
> Frank
>
> ** Affects: openobject-addons
> Importance: Undecided
> Status: New
>
as I went through this, let me make you attentive to one possible cause:
either you have accounts that do not balance, or you have some accounts
with the wrong type in your COA, and they get into the total.

suggestion: take the difference and try to match it to some of your
writings, and see if it does not go into a transitory account. then
check the account's setting.

good luck!
bogdan

Frank Adler (frank-adler) wrote :
Download full text (3.6 KiB)

Hi Bogdan,

you are spot on - I checked my accounts yesterday and it's the the net loss which gets added to assets and liabilities. I am using a German SKR04 CoA and it might be that I set the balancing account in the company details wrong. Just not sure which account it needs to be... The other odd thing is that all accounts have a ref nr, where as the net loss has the ref "net loss" so as if OpenERP itself just added it to the accounts in the end underneath the balancing account I specify.

Do you have a tip in terms of what account type etc. the balancing acct should be? ( or even which acct I need to use if you know the SKR04...at the moment it is set to "297800 Verlustvortrag vor Verwendung")

Cheers,
Frank

Sent from my iPad

On 24/02/2011, at 2:27, Bogdan Stanciu <email address hidden> wrote:

> On 22. 02. 11 10:07, Launchpad Bug Tracker wrote:
>> You have been subscribed to a public bug:
>>
>> Hi There,
>>
>> First bug I log here, so hope this is the right spot.
>>
>> Have recently installed version 6.0.1 straight from the main website
>> with a minimal module set to complete my annual statement (Balance
>> sheet, P&L) in OpenERP. After entering all transactions as journal
>> entries I went to Reporting | Legal Reports | Accounting Reports |
>> Balance sheet (One period, all entries, no filters). I noticed that the
>> overall balance is calculated incorrectly. If I manually add up all the
>> line items in the balance sheet I get to a total of 9.995.65 EUR
>> (consistently for assets and liabilities) whereas the report returns
>> 11626.82 EUR. I am only using standard modules with one exception which
>> is "account_cancel" and no currency calculations either.
>>
>> Since this would be pretty essential to any company running their
>> financials through OpenERP it would be great to get this fixed.
>>
>> Best Regards
>> Frank
>>
>> ** Affects: openobject-addons
>> Importance: Undecided
>> Status: New
>>
> as I went through this, let me make you attentive to one possible cause:
> either you have accounts that do not balance, or you have some accounts
> with the wrong type in your COA, and they get into the total.
>
> suggestion: take the difference and try to match it to some of your
> writings, and see if it does not go into a transitory account. then
> check the account's setting.
>
> good luck!
> bogdan
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/722832
>
> Title:
> Balance Sheet Report - Overall balance calculation error
>
> Status in OpenERP Modules (addons):
> Invalid
>
> Bug description:
> Hi There,
>
> First bug I log here, so hope this is the right spot.
>
> Have recently installed version 6.0.1 straight from the main website
> with a minimal module set to complete my annual statement (Balance
> sheet, P&L) in OpenERP. After entering all transactions as journal
> entries I went to Reporting | Legal Reports | Accounting Reports |
> Balance sheet (One period, all entries, no filters). I noticed that
> the overall balance is calculated incorrectly. If I manually add up
> all the line items in the balance sheet I ge...

Read more...

Bogdan Stanciu (bstanciu) wrote :
Download full text (4.3 KiB)

On 23. 02. 11 22:24, Frank Adler wrote:
> Hi Bogdan,
>
> you are spot on - I checked my accounts yesterday and it's the the net
> loss which gets added to assets and liabilities. I am using a German
> SKR04 CoA and it might be that I set the balancing account in the
> company details wrong. Just not sure which account it needs to be... The
> other odd thing is that all accounts have a ref nr, where as the net
> loss has the ref "net loss" so as if OpenERP itself just added it to the
> accounts in the end underneath the balancing account I specify.
>
> Do you have a tip in terms of what account type etc. the balancing acct
> should be? ( or even which acct I need to use if you know the SKR04...at
> the moment it is set to "297800 Verlustvortrag vor Verwendung")
>
> Cheers,
> Frank
>
> Sent from my iPad
>
> On 24/02/2011, at 2:27, Bogdan Stanciu <email address hidden>
> wrote:
>
>> On 22. 02. 11 10:07, Launchpad Bug Tracker wrote:
>>> You have been subscribed to a public bug:
>>>
>>> Hi There,
>>>
>>> First bug I log here, so hope this is the right spot.
>>>
>>> Have recently installed version 6.0.1 straight from the main website
>>> with a minimal module set to complete my annual statement (Balance
>>> sheet, P&L) in OpenERP. After entering all transactions as journal
>>> entries I went to Reporting | Legal Reports | Accounting Reports |
>>> Balance sheet (One period, all entries, no filters). I noticed that the
>>> overall balance is calculated incorrectly. If I manually add up all the
>>> line items in the balance sheet I get to a total of 9.995.65 EUR
>>> (consistently for assets and liabilities) whereas the report returns
>>> 11626.82 EUR. I am only using standard modules with one exception which
>>> is "account_cancel" and no currency calculations either.
>>>
>>> Since this would be pretty essential to any company running their
>>> financials through OpenERP it would be great to get this fixed.
>>>
>>> Best Regards
>>> Frank
>>>
>>> ** Affects: openobject-addons
>>> Importance: Undecided
>>> Status: New
>>>
>> as I went through this, let me make you attentive to one possible cause:
>> either you have accounts that do not balance, or you have some accounts
>> with the wrong type in your COA, and they get into the total.
>>
>> suggestion: take the difference and try to match it to some of your
>> writings, and see if it does not go into a transitory account. then
>> check the account's setting.
>>
>> good luck!
>> bogdan
>>
>> --
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>> https://bugs.launchpad.net/bugs/722832
>>
>> Title:
>> Balance Sheet Report - Overall balance calculation error
>>
>> Status in OpenERP Modules (addons):
>> Invalid
>>
>> Bug description:
>> Hi There,
>>
>> First bug I log here, so hope this is the right spot.
>>
>> Have recently installed version 6.0.1 straight from the main website
>> with a minimal module set to complete my annual statement (Balance
>> sheet, P&L) in OpenERP. After entering all transactions as journal
>> entries I went to Reporting | Legal Reports | Accounting Reports |
>> Balance sheet (One period, all entries, no filters). I noticed...

Read more...

Hello,

It affect to the OpenERP Addons Revision number - 4562

have a look at the correct configured database (https://sites.google.com/site/mgatiny/abc_accounting.zip?attredirects=0&d=1) with the listed opening entries on this blog - http://www.mantavyagajjar.in/2011/03/want-to-setup-openerp-accounting-module.html

It display correct balance in the chart of accounts but when you look at the Balance Sheet report - https://lh3.googleusercontent.com/-JbY-dFNEJkI/TYYED5YFp_I/AAAAAAAAAwk/BEcOgf3c6Gc/s1600/abc_balance_sheet.jpeg

Second small problem with the report is related to the formatting, Asset side it display view type accounts in bold while Liabilities side it does not showing anything in bold.

Changed in openobject-addons:
status: Invalid → New
Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 3 (openerp-dev-addons3)
importance: Undecided → Low
status: New → Confirmed
description: updated
Changed in openobject-addons:
status: Confirmed → In Progress

Hi There,

Have been meaning to upload something further in regards to this bug but
couldn't find the time.

I have played around with different accounts & account types etc. and am
pretty certain, that the only issue with this calculation is that when the
final annual result in the P&L is a loss, it gets ADDED to the linked equity
account in the balance, rather than subtracted.

Hope this helps a little.

Please let me know if I can supply any further information that might be of
help to you.

Regards
Frank

On Mon, Apr 4, 2011 at 2:57 PM, pso (Open ERP) <email address hidden>wrote:

> ** Changed in: openobject-addons
> Status: Confirmed => In Progress
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/722832
>
> Title:
> Balance Sheet Report - Overall balance calculation error
>
> Status in OpenERP Modules (addons):
> In Progress
>
> Bug description:
> Hi There,
>
> First bug I log here, so hope this is the right spot.
>
> Have recently installed version 6.0.1 straight from the main website
> with a minimal module set to complete my annual statement (Balance
> sheet, P&L) in OpenERP. After entering all transactions as journal
> entries I went to Reporting | Legal Reports | Accounting Reports |
> Balance sheet (One period, all entries, no filters). I noticed that
> the overall balance is calculated incorrectly. If I manually add up
> all the line items in the balance sheet I get to a total of 9.995.65
> EUR (consistently for assets and liabilities) whereas the report
> returns 11626.82 EUR. I am only using standard modules with one
> exception which is "account_cancel" and no currency calculations
> either.
>
> Since this would be pretty essential to any company running their
> financials through OpenERP it would be great to get this fixed.
>
> Best Regards
> Frank
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/openobject-addons/+bug/722832/+subscribe
>

Priyesh (OpenERP) (pso-openerp) wrote :

Hello,

Its fixed in https://code.launchpad.net/~openerp-dev/openobject-addons/trunk-bug-722832-pso.
Rev-Id: <email address hidden>
Rev-no: 4617

It will be merged soon with Addons branch.

Thanks for reporting.

Changed in openobject-addons:
status: In Progress → Fix Committed

Hello All,

Corrected things for the bug:

1. problem with the report is related to the formatting, Asset side it display view type accounts in bold while Liabilities side it does not showing anything in bold. (thanks to mga)

2. at the time of loss we will subtract the amount from balance now.

3. corrected code for Net profit and Net loss with NL and NP.

Thank you,
mra

Changed in openobject-addons:
milestone: none → 6.1
qdp (OpenERP) (qdp) wrote :

i probably fixed that bug of computation in revision 4724 (available un trunk). The proposed branch then has to be revised in order to fix only the layout and code problems.

Please Mustufa, can you handle that?

thanks,
Quentin

Changed in openobject-addons:
status: Fix Committed → Confirmed
Changed in openobject-addons:
status: Confirmed → In Progress

Hello,

As mentioned by qdp, i have fixed the issue related to reports layout and code problems in
lp:~openerp-dev/openobject-addons/trunk-bug-722832-psi and it will be merge in main addons very soon.

Revision No: 4793
Revision ID: <email address hidden>

Thanks,
Purnendu SIngh

Changed in openobject-addons:
status: In Progress → Fix Committed
Frank Adler (frank-adler) wrote :

Thanks for looking into this Bug!

Could you pls give me some advice on how to install the latest fixes
straight of launchpad? (i.e. is it an SVN repository?) Would you have a link
to the documentation in that regard - Happy to read through it but remember
giving up last time after not being able find it...

Thanks again for your help and best regards
Frank
_____________________________________
Frank Adler
email: <email address hidden>

On Thu, Jun 16, 2011 at 10:05 PM, Purnendu Singh (OpenERP) <
<email address hidden>> wrote:

> Hello,
>
> As mentioned by qdp, i have fixed the issue related to reports layout and
> code problems in
> lp:~openerp-dev/openobject-addons/trunk-bug-722832-psi and it will be merge
> in main addons very soon.
>
> Revision No: 4793
> Revision ID: <email address hidden>
>
> Thanks,
> Purnendu SIngh
>
> ** Changed in: openobject-addons
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/722832
>
> Title:
> Balance Sheet Report - Overall balance calculation error
>
> Status in OpenERP Modules (addons):
> Fix Committed
>
> Bug description:
> Hi There,
>
> First bug I log here, so hope this is the right spot.
>
> Have recently installed version 6.0.1 straight from the main website
> with a minimal module set to complete my annual statement (Balance
> sheet, P&L) in OpenERP. After entering all transactions as journal
> entries I went to Reporting | Legal Reports | Accounting Reports |
> Balance sheet (One period, all entries, no filters). I noticed that
> the overall balance is calculated incorrectly. If I manually add up
> all the line items in the balance sheet I get to a total of 9.995.65
> EUR (consistently for assets and liabilities) whereas the report
> returns 11626.82 EUR. I am only using standard modules with one
> exception which is "account_cancel" and no currency calculations
> either.
>
> Since this would be pretty essential to any company running their
> financials through OpenERP it would be great to get this fixed.
>
> Best Regards
> Frank
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/openobject-addons/+bug/722832/+subscriptions
>

Frank,

you can refer Merge proposal link with bug, also download the diff/patch from it and then you can apply that patch on your branch.

Thanks,
Mustufa

qdp (OpenERP) (qdp) wrote :

HI there,

as explained in comment #9, the bug of computation has been fixed and released in revision 4724.

Nevertheless, the bug report was left open because we thought that the balance sheet report was needed enhancements in its layout and a merge proposal has been made for that (see comment #10). But lately, we took the decision not to apply the proposed branch because the report will soon be totally replaced, so in order to avoid anymore useless effort i'm closing this bug report and rejecting the merge proposal.

Thanks,
Quentin

Changed in openobject-addons:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments