[trunk] Aged balance report

Bug #698063 reported by Frederic Clementi - Camptocamp on 2011-01-06
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Medium
Unassigned

Bug Description

Hi,

I am sure about what has been done about this report since the backport to V5 but here are 2 errors I see today on the Aged balance report:

1 - Do not includes opening entries
2 - When an invoice is paid/reconcilied after the date of the report thh report do not take it into account.
ex: Invoice on the 20/01/2011 paid on the 10/02/2011 - run the Aged balance report at the date of the 31/01/2011, you cannot see the invoice as open.
This Aged report must match with the Partner ledger.
(you refer to a previous bug report I have made : https://bugs.launchpad.net/openobject-addons/+bug/583666/comments/14)

I know you like this one ;)

Frederic

Hello Fredric,

I have tested the scenario with the latest code and according to the word document attached by you. But when we select the direction as "future" it is considering the amount of invoice which will be paid after the date of report and I am able to get the same balance as partner ledger which is "3100" in our case.

I wanted more information from your side, whether the issue is related with the "past" direction and for that report must have the entries of future payment.

Thanks.

Changed in openobject-addons:
status: New → Incomplete

Hello,

I have attached the report for "future" direction as per the scenario specified by you in word document.

Please notify me if I did follow the wrong steps for reproducing the scenario.

Thanks.

You are right, saz, my point 2 seems to fixed....good

But you will note that we have a problem when payments are partials...payments do not appear in the same column than the invoice (see "problem 1" in odt document)

And the report still does not includes opening entries (though I did not checked again)

qdp (OpenERP) (qdp) wrote :

Hello Frédéric,

yes you are right, partial payment are currently not supported in the aged partner balance. But it's unfortunatelly out of scope to developp it for v6.

furthermore, i don't understand what you're saying about the opening entries. Are you talking about the unpaied invoices from closed fiscalyears that are present in the opening entries of the selected fiscalyear (but there they are closed because of the way we manage the opening of fiscalyears) ?

Quentin

Are you saying that its out of scope to support fundamental accounting
controls? The list should agree to the control account in the GL. If not,
its a serious accounting issue.

On Fri, Jan 7, 2011 at 6:11 AM, qdp (OpenERP) <email address hidden>wrote:

> Hello Frédéric,
>
> yes you are right, partial payment are currently not supported in the
> aged partner balance. But it's unfortunatelly out of scope to developp
> it for v6.
>
> furthermore, i don't understand what you're saying about the opening
> entries. Are you talking about the unpaied invoices from closed
> fiscalyears that are present in the opening entries of the selected
> fiscalyear (but there they are closed because of the way we manage the
> opening of fiscalyears) ?
>
> Quentin
>
> --
> You received this bug notification because you are a member of OpenERP
> Accounting Experts, which is a direct subscriber.
> https://bugs.launchpad.net/bugs/698063
>
> Title:
> [trunk] Aged balance report
>
> Status in OpenObject Addons Modules:
> Incomplete
>
> Bug description:
> Hi,
>
> I am sure about what has been done about this report since the backport to
> V5 but here are 2 errors I see today on the Aged balance report:
>
> 1 - Do not includes opening entries
> 2 - When an invoice is paid/reconcilied after the date of the report thh
> report do not take it into account.
> ex: Invoice on the 20/01/2011 paid on the 10/02/2011 - run the Aged balance
> report at the date of the 31/01/2011, you cannot see the invoice as open.
> This Aged report must match with the Partner ledger.
> (you refer to a previous bug report I have made :
> https://bugs.launchpad.net/openobject-addons/+bug/583666/comments/14)
>
> I know you like this one ;)
>
> Frederic
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openerp-expert-accounting
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openerp-expert-accounting
> More help : https://help.launchpad.net/ListHelp
>

--
Fred Blauer CA, CA.IT, CISA
http://openacct.ca
<email address hidden>
514-667-1555

qdp (OpenERP) (qdp) wrote :

i won't take the risk to break the aged partner report because
*there is only one week left before the v6
*that's not an easy game to deal with
*it is currently working fine (as far as i know) except this point (which is already a nice improvement since v5).

That's why i'm saying it's out of scope to make it before the release of the v6, i'm not saying that it will never be done.

Ferdinand (office-chricar) wrote :

I just wonder how to communicate such issues - at least to partners
IMHO we need a "known issues" web page dealing with such (main) inconveniences not fixed in the current release
checking the bugs is not the way to go for everybody

UNSUBSCRIBE

2011/1/7 Ferdinand @ Camptocamp <email address hidden>

> I just wonder how to communicate such issues - at least to partners
> IMHO we need a "known issues" web page dealing with such (main)
> inconveniences not fixed in the current release
> checking the bugs is not the way to go for everybody
>
> --
> You received this bug notification because you are a member of OpenERP
> Accounting Experts, which is a direct subscriber.
> https://bugs.launchpad.net/bugs/698063
>
> Title:
> [trunk] Aged balance report
>
> Status in OpenObject Addons Modules:
> Incomplete
>
> Bug description:
> Hi,
>
> I am sure about what has been done about this report since the backport to
> V5 but here are 2 errors I see today on the Aged balance report:
>
> 1 - Do not includes opening entries
> 2 - When an invoice is paid/reconcilied after the date of the report thh
> report do not take it into account.
> ex: Invoice on the 20/01/2011 paid on the 10/02/2011 - run the Aged balance
> report at the date of the 31/01/2011, you cannot see the invoice as open.
> This Aged report must match with the Partner ledger.
> (you refer to a previous bug report I have made :
> https://bugs.launchpad.net/openobject-addons/+bug/583666/comments/14)
>
> I know you like this one ;)
>
> Frederic
>
>
>
> _______________________________________________
> Mailing list: https://launchpad.net/~openerp-expert-accounting<https://launchpad.net/%7Eopenerp-expert-accounting>
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~openerp-expert-accounting<https://launchpad.net/%7Eopenerp-expert-accounting>
> More help : https://help.launchpad.net/ListHelp
>

--
*Pedro Dagoberto Almaguer Prado*
Teléfono: (81) 8421-0733
Celular: 044 81 1248-3854
Skype: pedro.dago

qdp (OpenERP) (qdp) wrote :

Hi Frédéric,

i just fixed the fiscalyear trouble and tested with opening entries: it works fine at my side. (revision 4208)

As it only remains the partial reconciliation support and as you created a vote for that, let me close this bug report for the sake of clarity in LP.

Thanks for the contribution

Changed in openobject-addons:
importance: Undecided → Medium
status: Incomplete → Fix Released

LinkedIn
------------

Bug:

Me gustaría añadirte a mi red profesional en LinkedIn. - Pedro Almaguer

Pedro Almaguer
Director en Sinapsys
Monterrey y alrededores, México

Confirma que conoces a Pedro Almaguer
https://www.linkedin.com/e/rwuu2w-gk8qan9w-6w/isd/2344640932/FcOMlrmF/

--
(c) 2011, LinkedIn Corporation

Hi,

Regression on this report which seems not to take into account reconcile at all now. You see the invoives in one column and the payment on an other one !

Thanks

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments