Bank statement problems for multiple payments for one invoice

Bug #597680 reported by Vincent Renaville@camptocamp on 2010-06-23
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Status tracked in Trunk
5.0
Fix Released
High
Unassigned
Trunk
Fix Released
High
Vinay Rana (OpenERP)

Bug Description

Hello,

We have found a problem and solution (I hope ;) ), for multiple paiement with a Bank statement for an invoice.

I will give you 2 uses cases that work like a charm, and one that cause the error:

1) You create an invoice of 1000 CHF
    You pay 200 CHF with a bank statement
    The amount to pay of the invoice decrease to 800 CHF
    You pay 800 CHF with a bank statement
    The invoice is paid/reconciled and the due amount is 0 CHF

2) You create an invoice of 1000 CHF
    You pay 600 CHF with a bank statement
    The amount to pay of the invoice decrease to 400 CHF
    You pay 600 CHF with a bank statement
    The amount to pay of the invoice decrease to -200 CHF and the invoice is NOT paid/reconciled

Now I will give you the use case that doesn't work

3) You create an invoice of 1000 CHF
    You pay 600 CHF with a bank statement
    The amount to pay of the invoice decrease to 400 CHF
    You pay 1000 CHF with a bank statement
    The invoice is paid/reconciled and the due amount is 0 CHF

This is an error, because we lost the previous paiement, the invoice must NOt be paid/reconciled, and the due amount must be equal to -600 CHF.
the probem is located in the Bank statement process, when you received a paiement equal to the invoice amount, it doesn't check if we have a previous partial paiement.

You will find a patch attach to correct the problem.

Thanks for your help,

Vincent

Related branches

Changed in openobject-addons:
milestone: none → 5.0.12
importance: Undecided → High
status: New → Confirmed
summary: - bank statement multiple paiements
+ Bank statement problems for multiple payments for one invoice
Changed in openobject-addons:
status: Confirmed → In Progress

It has been fixed by revision 2765 <email address hidden>.
Thanks for your contribution Vincent.Credits to you.

Changed in openobject-addons:
status: In Progress → Fix Released

This has been fixed in the following revision of trunk-addons:
3794 <email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers