reconcilation do not work for multiple supplier invoices one payment

Bug #561396 reported by Normunds (Alistek)
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Undecided
Unassigned

Bug Description

server 5.0.9
rev. 2033
addons
rev. 2697
OS: Centos5.3 linux 64bit, python2.4

When doing manual reconcile in supplier accounts:
in case when we have multiple partner invoices and one payment against them and balance is equal e.g. ONE PAYMENT = INVOICE1+ INVOICE2+INVOICEx
then reconcile wizard throws wrong view, offering partial or write-off reconcile what is wrong.

Expected result: should fully reconcile without warnings.

Revision history for this message
Normunds (Alistek) (3pm) wrote :

The problem is in addons/account/wizard/wizard_reconcile.py line 66, and the way python handles numbers.

As temporary workaround adding round() resolve the issue, otherwise writeoff is not equal to zero as it should be when debit and credit is equal.

return {'trans_nbr': count, 'account_id': account_id, 'credit': credit, 'debit': debit, 'writeoff': round(debit - credit,8)}

Revision history for this message
Normunds (Alistek) (3pm) wrote :

Sorry, this is wrong branch, but do not know how to move to correct one (addons).

affects: openobject-server → openobject-addons
Revision history for this message
Vinay Rana (OpenERP) (vra-openerp) wrote :

Hello,

You can easily pay multiple supplier invoice for same partner very easily using account_voucher_payment module.

Thanks.

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote : Re: [Bug 561396] Re: reconcilation do not work for multiple supplier invoices one payment

Hello.

Please vra about this especific issue, can you check the lñast request in
this blueprint in what we are working please, we think with this module you
yet are not able to make one payment for multiple invoice in a correct
accounting way, the TeMPO team give us a good feedbak we are thinking in
implement it, it would be great if you can review it, please.

@ Normundus.

Be care you will have a little issue that you can correct with some interim
move...

https://blueprints.launchpad.net/openobject-addons/+spec/account-voucher-paymen

Revision history for this message
Normunds (Alistek) (3pm) wrote :

@vra
"You can easily pay multiple supplier invoice for same partner very easily using account_voucher_payment module."

No I cannot. We do not use manual payments (account_voucher_payment style) - both outgoing and incoming. For outgoing invoice payment we use account_payment module, then export payment to xml for bank web interface. Then import xml bank statement and do semi-automatic and manual reconcilation.

That account_voucher_payment module is suitable for small companies with low bank transactions rate.

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

Working on it

Changed in openobject-addons:
assignee: nobody → Nhomar Hernández - http://openerp.netquatro.com (nhomar)
milestone: none → 5.0.12
importance: Undecided → Medium
Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

Fix commited:
nhomar@nhomar-laptop-20100618055415-4xjk6p6n25bmbwtf

Changed in openobject-addons:
status: New → Fix Committed
Revision history for this message
hbto [Vauxoo] http://www.vauxoo.com (humbertoarocha) wrote : Re: [Bug 561396] Re: reconcilation do not work for multiple supplier invoices one payment

Hello all you gays,
it seems new changes in the way residual in account invoice are calculated
are avoiding
that partial o full conciliations made by account_voucher_payment trigger
the residual,
I have no clue which parameter could be avoiding it to happen, the fact is
that partial and full
reconciliation made manually does trigger residual at the account invoice,
what i don't know
is why account_voucher_payment isn't triggering the functional field.

Expecting someone else can see where is the problem and enlighten me so I or
someone else
could fix this misbehavoir.

Regards.

Hbto

2010/6/18 Nhomar Hernández - http://openerp.netquatro.com <email address hidden>

> Fix commited:
> nhomar@nhomar-laptop-20100618055415-4xjk6p6n25bmbwtf
>
> ** Changed in: openobject-addons
> Status: New => Fix Committed
>
> --
> reconcilation do not work for multiple supplier invoices one payment
> https://bugs.launchpad.net/bugs/561396
> You received this bug notification because you are subscribed to
> OpenObject Addons.
>

Revision history for this message
hbto [Vauxoo] http://www.vauxoo.com (humbertoarocha) wrote :

Hello all you guys, [Sorry for the previous horrible mistake, and the slang
language]
it seems new changes in the way residual in account invoice are calculated
are avoiding
that partial o full conciliations made by account_voucher_payment trigger
the residual,
I have no clue which parameter could be avoiding it to happen, the fact is
that partial and full
reconciliation made manually does trigger residual at the account invoice,
what i don't know
is why account_voucher_payment isn't triggering the functional field.

Expecting someone else can see where is the problem and enlighten me so I or
someone else
could fix this misbehavoir.

Regards.

Hbto

2010/12/23 Humberto Arocha <email address hidden>

> Hello all you gays,
> it seems new changes in the way residual in account invoice are calculated
> are avoiding
> that partial o full conciliations made by account_voucher_payment trigger
> the residual,
> I have no clue which parameter could be avoiding it to happen, the fact is
> that partial and full
> reconciliation made manually does trigger residual at the account invoice,
> what i don't know
> is why account_voucher_payment isn't triggering the functional field.
>
> Expecting someone else can see where is the problem and enlighten me so I
> or someone else
> could fix this misbehavoir.
>
> Regards.
>
> Hbto
>
> 2010/6/18 Nhomar Hernández - http://openerp.netquatro.com <
> <email address hidden>>
>
> Fix commited:
>> nhomar@nhomar-laptop-20100618055415-4xjk6p6n25bmbwtf
>>
>> ** Changed in: openobject-addons
>> Status: New => Fix Committed
>>
>> --
>> reconcilation do not work for multiple supplier invoices one payment
>> https://bugs.launchpad.net/bugs/561396
>> You received this bug notification because you are subscribed to
>> OpenObject Addons.
>>
>
>

Amit Parik (amit-parik)
Changed in openobject-addons:
assignee: Nhomar Hernández - http://openerp.com.ve (nhomar) → nobody
importance: Medium → Undecided
milestone: 5.0.12 → none
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers