[account_voucher_workflow] Error posting "Receipt Voucher" AND "Bank Receipt Voucher" [Trunk fixes this]

Bug #522006 reported by Nhomar - Vauxoo
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Undecided
Unassigned

Bug Description

Hello.

When you try to post a Bank Receipt Voucher or a Receipt Voucher with an amount > 500, the workflow brig to you to "recheck" state, this is incorrect, because this state is only valid for payments, the user is the major of cases don't need validate receive money, he only need validate pay money.

Nhomar - Vauxoo (nhomar)
Changed in openobject-addons:
status: New → Confirmed
assignee: nobody → Nhomar Hernández - http://openerp.netquatro.com (nhomar)
Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

Fix Commited on revno
nhomar@nhomar-laptop-20100215043800-k7km3dzee9siouc7

Changed in openobject-addons:
status: Confirmed → Fix Committed
Revision history for this message
Mantavya Gajjar (Open ERP) (mga) wrote :

hello Nhomar Hernández,

Thanks for the commit.

But I think the better solution is to provide configuration to users instead of changing the workflow.

here I have fixed for the trunk extra addons

<email address hidden>

also Nhomar Hernández, i think we should change stable version to the same solution

Regards,
MGA

Changed in openobject-addons:
status: Fix Committed → Fix Released
Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

Hello mga:

There are 2 problems solved with your change and my change.
Your change:
-- You are really right when said that th amount must be configurable "thanks" i didn't see where this option must be.
My change:
-- It wasn't logic that the receipt of money have control, for this reason it shouldn't be controlled, this was the reason of thi bug.

I tweak a little your change and mine and merge it on stable version, can you check please?

nhomar@nhomar-laptop-20100216165229-d48apc7flcwwyoga

Be careful: you take the "comany_id" like field of control for the journal view on trunk, this field doesn't exist on stable version, I changed by name!

Changed in openobject-addons:
status: Fix Released → Fix Committed
Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

I'm working over this blueprint, because this modules:
account_voucher
account_voucher_payment
account_voucher_workflow
Were so simple, and an ERP needs strong behavior on control in the cashflow.

https://blueprints.launchpad.net/openobject-addons/+spec/account-voucher-paymen

If you can we can work together with this infomation, if you think it needs smething else.

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

All change are being tested on my replication of a production enviroment with data and proccess of the real world, you can trust, because all improvements and changes are very well tested before post it. ;-)

Changed in openobject-addons:
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Revision history for this message
Mantavya Gajjar (Open ERP) (mga) wrote :

Hello Nhomar !!

Can you the new development of the voucher in trunk ?, I think new implementation will hopefully solve all current voucher problems.

Regards,
Mantavya

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote : Re: [Bug 522006] Re: [account_voucher_workflow] Error posting "Receipt Voucher" AND "Bank Receipt Voucher"

Hello mga...

Yes.
We for the development sprint for the 11 to 15 in october are planning
upgrade all the developments done in this module (and another ones) to
trunk, we didn't try the new accunt_voucher yet....

Regards.

2010/9/20 mga (Open ERP) <email address hidden>

> Hello Nhomar !!
>
> Can you the new development of the voucher in trunk ?, I think new
> implementation will hopefully solve all current voucher problems.
>
> Regards,
> Mantavya
>
> --
> [account_voucher_workflow] Error posting "Receipt Voucher" AND "Bank
> Receipt Voucher"
> https://bugs.launchpad.net/bugs/522006
> You received this bug notification because you are a member of OpenERP
> Drivers, which is subscribed to OpenObject Addons.
>
> Status in OpenObject Addons Modules: Fix Committed
>
> Bug description:
> Hello.
>
> When you try to post a Bank Receipt Voucher or a Receipt Voucher with an
> amount > 500, the workflow brig to you to "recheck" state, this is
> incorrect, because this state is only valid for payments, the user is the
> major of cases don't need validate receive money, he only need validate pay
> money.
>
>
>

--
Saludos Cordiales

Nhomar G. Hernandez M.
+58-414-4110269
+58-212-6615932
+58-212-9536734 ext 124
+58-212-9512643
Skype: nhomar00
Web-Blog: http://geronimo.com.ve
Servicios IT: http://openerp.netquatro.com
Linux-Counter: 467724
Correos:
<email address hidden>
<email address hidden>

Revision history for this message
Jay Vora (Serpent Consulting Services) (jayvora) wrote : Re: [account_voucher_workflow] Error posting "Receipt Voucher" AND "Bank Receipt Voucher"

Thanks Nhomar,

We would like to close this one. Keep posting.

Thanks.

Revision history for this message
Jay Vora (Serpent Consulting Services) (jayvora) wrote :

On trunk, account_voucher has been improved a lot and works very well.
I am closing this thread in the context of trunk.
Interrupt,if I miss anything.
Thanks.

Changed in openobject-addons:
status: Fix Committed → Fix Released
assignee: Nhomar Hernández - http://openerp.com.ve (nhomar) → nobody
summary: [account_voucher_workflow] Error posting "Receipt Voucher" AND "Bank
- Receipt Voucher"
+ Receipt Voucher" [Trunk fixes this]
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers