Multi-currency Consolidation

Bug #516396 reported by Samuel I. (Toradex) on 2010-02-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Medium
Jay Vora (Serpent Consulting Services)

Bug Description

The consolidation of financial accounts in different currencies does not work.

We have a multi-company/currency setup with 3 different branches (CHF, EUR, USD) and holding (parent) company with consolidation accounts. The system calculates a total balance for the consoidation account but does NOT consider the currency exchange rates for consolidated children.

- Asset Branch 1: 10'000 CHF
- Asset Branch 2: 20'000 EUR
- Asset Branch 3: 30'000 USD
---------------------------------------
- Assets Holding: 60'000 CHF (Internal Type = Consolidation)

Furthermore, the balance of consolidation accounts are not visible for its parent account:

Balance Holing 0.0 CHF !!! (parent, view account)
 - Assets Holding 60'000 CHF (Internal Type = Consolidation)
 - Liabilities Holding -20'000 CHF (Internal Type = Consolidation)

With the given documentation we were really expecting that these scenarios are supported.Of course we have the multi-company accounting module installed (v5.0). Do you know what is problem here?

Thank you.

Changed in openobject-addons:
importance: Undecided → Medium
Changed in openobject-addons:
status: New → Confirmed
milestone: none → 5.0.8
Changed in openobject-addons:
assignee: nobody → Jay (Open ERP) (jvo-openerp)

Hi,

I think this cannot really be fixed into stable because of your release policy :( !

We already coded this as a module called "c2c_multi_currency_consolidated_chart".

What you can do to help is porting this features into trunk, the same way we coded it for 5.0. This was review by an accountant, so you can trust the computation.

Let me know if you gonna port this into trunk or not, and if you may even accept this in the core for 5.0.

Thanks in advance,

Joël

Samuel I. (Toradex) (samsimg) wrote :

We would greatly appreciate any effort to port this in to trunk.

Changed in openobject-addons:
milestone: 5.0.8 → 5.0.9
Changed in openobject-addons:
milestone: 5.0.9 → 5.0.10
Changed in openobject-addons:
milestone: 5.0.10 → 5.0.11
Changed in openobject-addons:
milestone: 5.0.11 → 5.0.12
Samuel I. (Toradex) (samsimg) wrote :

This issue has been address with the module: c2c_multi_currency_consolidated_chart

http://doc.openerp.com/technical_guide/c2c_multi_currency_consolidated_chart.html#description

Feel free to share your thoughts.

Thanks!

Changed in openobject-addons:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers