Error in SQL query, when you try to make a payment without select an invoice

Bug #510181 reported by Nhomar - Vauxoo
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Odoo Addons (MOVED TO GITHUB)
Fix Released
Undecided
Unassigned

Bug Description

When try to add a payment in:

Finantial management > Voucher Entries > Select all aoptons here.
Then....

In the lines, you try to make a payment in advance "without invoice related", give an error in SQL query.

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

Modules intalled:

account_voucher
account_voucher_payment
account_voucher_workflow

Changed in openobject-addons:
status: New → In Progress
Revision history for this message
Stephane Wirtel (OpenERP) (stephane-openerp) wrote :

What's the sql error ? or query ?

Have you tried with the --debug argument on the command line of the server ?

Can you provide the query and the params ?

Thank you

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

Of Course

I attach all the log file:

Look the error begin in line : 932 a end in Line: 1008

Changed in openobject-addons:
status: In Progress → Confirmed
Revision history for this message
Jay Vora (Serpent Consulting Services) (jayvora) wrote :

Fixed by revision 4193 <email address hidden>.

These modules really need some good testing and analysis.

Thanks.

Changed in openobject-addons:
status: Confirmed → Fix Released
Revision history for this message
Nhomar - Vauxoo (nhomar) wrote : Re: [Bug 510181] Re: Error in SQL query, when you try to make a payment without select an invoice

We are using them.....

We are agree with you, but they are really needed, OpenERP needs a form like
this to receive the money....
Only Account_Voucher is not enough.

Nhomar

2010/1/21 Jay (Open ERP) <email address hidden>

> Fixed by revision 4193 <email address hidden>.
>
> These modules really need some good testing and analysis.
>
> Thanks.
>
>
> ** Changed in: openobject-addons
> Status: Confirmed => Fix Released
>
> --
> Error in SQL query, when you try to make a payment without select an
> invoice
> https://bugs.launchpad.net/bugs/510181
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in OpenObject Addons Modules: Fix Released
>
> Bug description:
> When try to add a payment in:
>
> Finantial management > Voucher Entries > Select all aoptons here.
> Then....
>
> In the lines, you try to make a payment in advance "without invoice
> related", give an error in SQL query.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/openobject-addons/+bug/510181/+subscribe
>

--
Saludos Cordiales

Nhomar G. Hernandez M.
+58-414-4110269
+58-212-6615932
+58-212-9536734 ext 124
+58-212-9512643
Web-Blog: http://geronimo.com.ve
Servicios IT: http://openerp.netquatro.com
Linux-Counter: 467724
Correos:
<email address hidden>
<email address hidden>

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

 Question:

.... did you apply my diff????, or apply other changes????

2010/1/21 Jay (Open ERP) <email address hidden>

> Fixed by revision 4193 <email address hidden>.
>
> These modules really need some good testing and analysis.
>
> Thanks.
>
>
> ** Changed in: openobject-addons
> Status: Confirmed => Fix Released
>
> --
> Error in SQL query, when you try to make a payment without select an
> invoice
> https://bugs.launchpad.net/bugs/510181
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in OpenObject Addons Modules: Fix Released
>
> Bug description:
> When try to add a payment in:
>
> Finantial management > Voucher Entries > Select all aoptons here.
> Then....
>
> In the lines, you try to make a payment in advance "without invoice
> related", give an error in SQL query.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/openobject-addons/+bug/510181/+subscribe
>

--
Saludos Cordiales

Nhomar G. Hernandez M.
+58-414-4110269
+58-212-6615932
+58-212-9536734 ext 124
+58-212-9512643
Web-Blog: http://geronimo.com.ve
Servicios IT: http://openerp.netquatro.com
Linux-Counter: 467724
Correos:
<email address hidden>
<email address hidden>

Revision history for this message
Jay Vora (Serpent Consulting Services) (jayvora) wrote :

Yes Nhomar,

You are right, but these modules need improvemnts.

I had to check other bugs too and solved them with this one. so, its not fully your patch.

Thanks.

Revision history for this message
Nhomar - Vauxoo (nhomar) wrote :

Ok...

I know about the improvements, we are working on them too, if you can tell what are the improvements that you think this needs we can help with development, We have some Ideas, and most of all, the Banking Cheks Control, and IMHO this behaviour needs to be there. The point where you receive or make them!.

I will make a blueprint!

Nhomar

Revision history for this message
Jay Vora (Serpent Consulting Services) (jayvora) wrote :

Thank you for the blueprint.

We will work towards making the module generic. We will appreciate your inputs.

Thank you for your feedback.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments