[7.0]SQL server error on products

Bug #1281762 reported by S Lec on 2014-02-18
50
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Odoo Addons
Fix Released
Medium
OpenERP R&D Addons Team 2

Bug Description

I did a manual bzr pull on all 3 repos, then:
- create db
- install MRP
- install Sales
- click Sales-Products-Products

2014-02-18 19:48:14,101 51195 ERROR test3 openerp.sql_db: Programming error: column "stock_move__product_id.name_template" must appear in the GROUP BY clause or be used in an aggregate function
LINE 1: ...RDER BY "stock_move__product_id"."default_code" ,"stock_mov...
                                                             ^
, in query SELECT min(stock_move.id) AS id, count(stock_move.id) AS product_id_count,"stock_move"."product_id" FROM "stock_move" LEFT JOIN "product_product" as "stock_move__product_id" ON ("stock_move"."product_id" = "stock_move__product_id"."id") WHERE ((("stock_move"."product_id" in (%s)) AND FALSE) AND ("stock_move"."state" in (%s,%s,%s))) GROUP BY "stock_move"."product_id","stock_move__product_id"."default_code" ORDER BY "stock_move__product_id"."default_code" ,"stock_move__product_id"."name_template"

bzr branch nick: openobject-server revno: 5230
bzr branch nick: openobject-addons revno: 9840
bzr branch nick: web-7 revno: 4137

Changed in openobject-addons:
assignee: nobody → OpenERP R&D Addons Team 2 (openerp-dev-addons2)
importance: Undecided → Medium
status: New → Confirmed
summary: - SQL server error on products
+ [7.0]SQL server error on products
Javier (javierjcf) on 2014-02-19
Changed in openobject-addons:
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Jasmin Savard (jasmin-savard) wrote :

I have the same problem. I did a bzr pull on all 3 branches and I get the same exact error.

Issue exist when you try to group stock.move by product.

Hello,

Indeed there was a special case we had not considered on the read_group while doing the fix at revision 5237.
This is now fixed at the following revision.

revno: 5239 [merge]
revision-id: <email address hidden>

Thanks for the report

Changed in openobject-addons:
status: Confirmed → Fix Released
Jasmin Savard (jasmin-savard) wrote :

I confirm that revno: 5239 fixed it for me.

Jean Ventura (1-jv) wrote :

Me too. I confirm that revno: 5239 fixed it for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers